Bug 1121964 - Please update vmtoolsd.service to support cloud-init customization by default
Please update vmtoolsd.service to support cloud-init customization by default
Status: VERIFIED FIXED
Classification: SUSE Linux Enterprise Server
Product: Beta SUSE Linux Enterprise Server 15 SP1
Classification: SUSE Linux Enterprise Server
Component: Virtualization: Other
Beta 2
x86-64 SLES 15
: P3 - Medium : Normal
: ---
Assigned To: Kirk Allan
Antoine Ginies
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-01-15 09:27 UTC by vmware gos
Modified: 2019-04-22 01:53 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vmware gos 2019-01-15 09:27:23 UTC
VMWare plan to support cloud-init customization by default, which need vmtoolsd.service to add below 2 lines to [Unit] part.

DefaultDependencies=no
Before=cloud-init-local.service

Could you help to add that?

Thanks,
VMWare GOS QE
Comment 3 Kirk Allan 2019-02-12 17:36:10 UTC
The changes have been submitted.  Waiting for acceptance.
Comment 4 vmware gos 2019-03-05 05:49:05 UTC
SLE 15 SP1 Beta4 has fix this issue.

pek2-gosv-16-dhcp25:~ # cat /etc/issue

Welcome to SUSE Linux Enterprise Server 15 SP1 Beta4 (x86_64) - Kernel \r (\l).

eth0: \4{eth0} \6{eth0}
pek2-gosv-16-dhcp25:~ # cat /etc/systemd/system/multi-user.target.wants/vmtoolsd.service
[Unit]
Description=open-vm-tools: vmtoolsd service for virtual machines hosted on VMware
Documentation=http://github.com/vmware/open-vm-tools
ConditionVirtualization=vmware
Requires=vgauthd.service
After=vgauthd.service
DefaultDependencies=no
Before=cloud-init-local.service

[Service]
Type=forking
PIDFile=/var/run/vmtoolsd.pid
ExecStart=/usr/bin/vmtoolsd --background /var/run/vmtoolsd.pid
TimeoutStopSec=5

[Install]
WantedBy=multi-user.target
Also=vgauthd.service


-VMWare GOS QA
Comment 6 Swamp Workflow Management 2019-03-20 17:14:58 UTC
SUSE-RU-2019:0667-1: An update that has four recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1115118,1121964,1122435,1124397
CVE References: 
Sources used:
SUSE Linux Enterprise Server 12-SP4 (src):    open-vm-tools-10.3.5-4.3.1
SUSE Linux Enterprise Desktop 12-SP4 (src):    open-vm-tools-10.3.5-4.3.1
Comment 7 Swamp Workflow Management 2019-03-21 23:21:07 UTC
SUSE-RU-2019:0696-1: An update that has four recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1115118,1121964,1122435,1124397
CVE References: 
Sources used:
SUSE Linux Enterprise Server 12-SP3 (src):    open-vm-tools-10.3.5-3.22.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    open-vm-tools-10.3.5-3.22.1
SUSE CaaS Platform ALL (src):    open-vm-tools-10.3.5-3.22.1
SUSE CaaS Platform 3.0 (src):    open-vm-tools-10.3.5-3.22.1
Comment 8 Swamp Workflow Management 2019-03-29 14:11:32 UTC
openSUSE-RU-2019:1078-1: An update that has four recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1115118,1121964,1122435,1124397
CVE References: 
Sources used:
openSUSE Leap 42.3 (src):    open-vm-tools-10.3.5-22.1

*** NOTE: This information is not intended to be used for external
    communication, because this may only be a partial fix.
    If you have questions please reach out to maintenance coordination.
Comment 10 Swamp Workflow Management 2019-04-01 22:10:20 UTC
SUSE-RU-2019:14006-1: An update that has three recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1115118,1121964,1124397
CVE References: 
Sources used:
SUSE Linux Enterprise Server 11-SP4 (src):    open-vm-tools-10.3.5-8.12.2
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    open-vm-tools-10.3.5-8.12.2

*** NOTE: This information is not intended to be used for external
    communication, because this may only be a partial fix.
    If you have questions please reach out to maintenance coordination.
Comment 11 Swamp Workflow Management 2019-04-02 10:11:50 UTC
openSUSE-RU-2019:1102-1: An update that has 5 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1115118,1121964,1122435,1124397,1126102
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    open-vm-tools-10.3.5-lp150.2.10.2, xmlsec1-1.2.26-lp150.7.2

*** NOTE: This information is not intended to be used for external
    communication, because this may only be a partial fix.
    If you have questions please reach out to maintenance coordination.
Comment 12 Kirk Allan 2019-04-04 15:55:04 UTC
The fix for this issue is now available for install.  Marking as fixed.
Comment 13 vmware gos 2019-04-22 01:53:50 UTC
The fix of this issue has been in the Beta4, RC1 and RC2.

So mark this PR verified.