Bug 1120935 - mutt: SLE imported update drops the -doc and -lang split
mutt: SLE imported update drops the -doc and -lang split
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Other
Leap 42.3
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Dr. Werner Fink
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-01-07 13:30 UTC by Andreas Stieger
Modified: 2019-01-17 17:13 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Stieger 2019-01-07 13:30:03 UTC
A maintenance update for mutt was imported from SLE 12 into the Leap 42.3 Maintenance queue:
https://build.opensuse.org/project/show/openSUSE:Maintenance:9239

Install checker complains:

found conflict of mutt-1.10.1-2.3.1.x86_64 with mutt-doc-1.8.2-1.7.noarch:
  - /usr/share/doc/packages/mutt/[...]
found conflict of mutt-1.10.1-2.3.1.x86_64 with mutt-lang-1.8.2-1.7.noarch:
  - /usr/share/locale/[...]

The spec change relative to the previous Leap 42.3 package drops the -doc and -lang packages:
https://build.opensuse.org/package/rdiff/openSUSE:Maintenance:9239/mutt.openSUSE_Leap_42.3_Update?linkrev=base&rev=2
The package was switched to be inherited from SLE 12 so this was never relevant or checked there.
https://build.opensuse.org/package/rdiff/openSUSE:Leap:42.3:Update/00Meta?linkrev=base&rev=167

So this is not entirely in sync, including a bit of changelog. We should decide whether to fork the package to retainin the -doc and -lang split in Leap 42.3, or make it parameterized...
Comment 1 Andreas Stieger 2019-01-07 13:31:59 UTC
proposed (fork): https://build.opensuse.org/request/show/663356
Comment 2 Dr. Werner Fink 2019-01-07 13:42:05 UTC
AFAIU the had already a fork or how do the -doc/-lang package had happen?(In reply to Andreas Stieger from comment #1)
> proposed (fork): https://rudin.suse.de:8894/request/show/663356

There seems to an autobot fail here:

 Output of check script:
 Attention, krb5-config is not mentioned in spec files as source or patch.
Comment 3 Swamp Workflow Management 2019-01-07 15:41:49 UTC
This is an autogenerated message for OBS integration:
This bug (1120935) was mentioned in
https://build.opensuse.org/request/show/663361 42.3 / mutt
Comment 4 Andreas Stieger 2019-01-07 15:47:53 UTC
For Leap 42.3 -doc and -lang was split, but not in SLE. This is why this appears to have "changed" when attempting to use the SLE 12 sources for a Leap 42.3 update.
Comment 5 Dr. Werner Fink 2019-01-14 12:26:59 UTC
SR had been accepted, thanks
Comment 6 Swamp Workflow Management 2019-01-17 17:13:29 UTC
openSUSE-SU-2019:0052-1: An update that solves 16 vulnerabilities and has 6 fixes is now available.

Category: security (important)
Bug References: 1061343,1094717,1101428,1101566,1101567,1101568,1101569,1101570,1101571,1101573,1101576,1101577,1101578,1101581,1101582,1101583,1101588,1101589,1120935,980830,982129,986534
CVE References: CVE-2014-9116,CVE-2018-14349,CVE-2018-14350,CVE-2018-14351,CVE-2018-14352,CVE-2018-14353,CVE-2018-14354,CVE-2018-14355,CVE-2018-14356,CVE-2018-14357,CVE-2018-14358,CVE-2018-14359,CVE-2018-14360,CVE-2018-14361,CVE-2018-14362,CVE-2018-14363
Sources used:
openSUSE Leap 42.3 (src):    mutt-1.10.1-2.5.1