Bug 1119636 - Backintime-qt4 does not start with ModuleNotFoundError: No module named 'PyQt4.sip'
Backintime-qt4 does not start with ModuleNotFoundError: No module named 'PyQt...
Status: RESOLVED FIXED
: 1119782 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
x86-64 SUSE Other
: P5 - None : Normal with 5 votes (vote)
: ---
Assigned To: Tejas Guruswamy
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-12-15 14:06 UTC by Sebastian Kuhne
Modified: 2022-02-02 14:45 UTC (History)
9 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Kuhne 2018-12-15 14:06:45 UTC
I am not sure if my issue with backintime is related to bug 1037475.

However, with the newest TW 20181213, backintine-qt4 does not start anymore:

#
sebastian@linux-sebastian:~> backintime-qt4
Traceback (most recent call last):
  File "/usr/share/backintime/qt4/app.py", line 30, in <module>
    import qt4tools
  File "/usr/share/backintime/qt4/qt4tools.py", line 21, in <module>
    from PyQt4.QtGui import QFont, QFileDialog, QListView, QAbstractItemView,      \
ModuleNotFoundError: No module named 'PyQt4.sip'
#

It is version 1.1.24-1.2 from main repository.
All the hints in bug 1037475 did not help.
Comment 1 Bunte Katze 2018-12-16 16:45:55 UTC
I am experiencing the same issue.

Upstream bug report: https://github.com/bit-team/backintime/issues/964

Here some package lists - hope this helps:

zypper se -si backintime                                                                                                              
S  | Name            | Type    | Version    | Arch   | Repository  
---+-----------------+---------+------------+--------+-------------
i+ | backintime      | package | 1.1.24-1.2 | noarch | openSUSE Oss
i+ | backintime-lang | package | 1.1.24-1.2 | noarch | openSUSE Oss
i+ | backintime-qt4  | package | 1.1.24-1.2 | noarch | openSUSE Oss

zypper se -si python3
S  | Name                     | Type    | Version                        | Arch   | Repository            
---+--------------------------+---------+--------------------------------+--------+-----------------------
i+ | libpython3_5m1_0         | package | 3.5.1-3.6                      | x86_64 | (System Packages)     
i+ | libpython3_6m1_0         | package | 3.6.5-3.3                      | x86_64 | openSUSE Oss          
i  | libpython3_6m1_0-32bit   | package | 3.6.5-3.3                      | x86_64 | openSUSE Oss          
i+ | python3                  | package | 3.6.5-3.4                      | x86_64 | openSUSE Oss          
i+ | python3-Automat          | package | 0.6.0-5.12                     | noarch | devel:languages:python
i+ | python3-Cycler           | package | 0.10.0-3.1                     | noarch | openSUSE Oss          
i+ | python3-Pillow           | package | 5.3.0-82.1                     | x86_64 | devel:languages:python
i  | python3-PyHamcrest       | package | 1.9.0-7.1                      | noarch | devel:languages:python
i+ | python3-PyNaCl           | package | 1.3.0-6.1                      | x86_64 | devel:languages:python
i+ | python3-PySocks          | package | 1.6.8-11.1                     | noarch | devel:languages:python
i+ | python3-PyYAML           | package | 3.13-1.2                       | x86_64 | openSUSE Oss          
i+ | python3-SecretStorage    | package | 2.3.1-21.1                     | noarch | devel:languages:python
i+ | python3-Twisted          | package | 18.9.0-2.1                     | x86_64 | openSUSE Oss          
i+ | python3-apparmor         | package | 2.13-6.1                       | x86_64 | openSUSE Oss          
i+ | python3-appdirs          | package | 1.4.3-19.2                     | noarch | devel:languages:python
i+ | python3-asn1crypto       | package | 0.24.0-12.1                    | noarch | devel:languages:python
i+ | python3-attrs            | package | 18.2.0-1.1                     | noarch | openSUSE Oss          
i+ | python3-backports_abc    | package | 0.5-2.1                        | noarch | openSUSE Oss          
i+ | python3-base             | package | 3.6.5-3.3                      | x86_64 | openSUSE Oss          
i+ | python3-bcrypt           | package | 3.1.4-11.3                     | x86_64 | devel:languages:python
i+ | python3-bind             | package | 9.11.2-42.1                    | noarch | openSUSE Oss          
i+ | python3-bottle           | package | 0.12.13-1.4                    | noarch | openSUSE Oss          
i+ | python3-cairo            | package | 1.15.1-1.2                     | x86_64 | openSUSE Oss          
i+ | python3-cairocffi        | package | 0.8.1-2.1                      | noarch | openSUSE Oss          
i+ | python3-certifi          | package | 2018.4.16-2.1                  | noarch | openSUSE Oss          
i+ | python3-cffi             | package | 1.11.5-65.1                    | x86_64 | devel:languages:python
i+ | python3-chardet          | package | 3.0.4-4.1                      | noarch | openSUSE Oss          
i  | python3-cmdln            | package | 2.0.0-40.9                     | noarch | devel:languages:python
i+ | python3-constantly       | package | 15.1.0-2.1                     | noarch | openSUSE Oss          
i+ | python3-coverage         | package | 4.5.1-2.2                      | x86_64 | openSUSE Oss          
i  | python3-createrepo_c     | package | 0.10.0.git20170131.04828e6-3.2 | x86_64 | openSUSE Oss          
i+ | python3-cryptography     | package | 2.4.1-114.1                    | x86_64 | devel:languages:python
i+ | python3-cssselect        | package | 1.0.3-23.1                     | noarch | devel:languages:python
i+ | python3-cupshelpers      | package | 1.5.7-16.3                     | noarch | openSUSE Oss          
i+ | python3-curses           | package | 3.6.5-3.4                      | x86_64 | openSUSE Oss          
i+ | python3-dbm              | package | 3.6.5-3.4                      | x86_64 | openSUSE Oss          
i+ | python3-dbus-python      | package | 1.2.8-2.1                      | x86_64 | openSUSE Oss          
i  | python3-decorator        | package | 4.3.0-45.1                     | noarch | devel:languages:python
i+ | python3-devel            | package | 3.6.5-3.3                      | x86_64 | openSUSE Oss          
i+ | python3-ecdsa            | package | 0.13-3.1                       | noarch | openSUSE Oss          
i  | python3-entrypoints      | package | 0.2.3-12.1                     | noarch | devel:languages:python
i+ | python3-firewall         | package | 0.6.3-1.1                      | noarch | openSUSE Oss          
i  | python3-fs               | package | 2.0.4-12.1                     | noarch | devel:languages:python
i+ | python3-gevent           | package | 1.3.5-1.1                      | x86_64 | openSUSE Oss          
i+ | python3-gobject          | package | 3.30.4-1.1                     | x86_64 | openSUSE Oss          
i+ | python3-gobject-Gdk      | package | 3.30.4-1.1                     | x86_64 | openSUSE Oss          
i+ | python3-gobject-cairo    | package | 3.30.4-1.1                     | x86_64 | openSUSE Oss          
i  | python3-gobject2         | package | 2.28.7-2.2                     | x86_64 | openSUSE Oss          
i+ | python3-greenlet         | package | 0.4.15-1.1                     | x86_64 | openSUSE Oss          
i+ | python3-gst              | package | 1.14.4-1.1                     | x86_64 | openSUSE Oss          
i  | python3-h2               | package | 3.0.1-5.1                      | noarch | devel:languages:python
i  | python3-hpack            | package | 3.0.0-5.1                      | noarch | devel:languages:python
i+ | python3-httplib2         | package | 0.10.3-3.2                     | noarch | openSUSE Oss          
i  | python3-hyperframe       | package | 5.1.0-9.1                      | noarch | devel:languages:python
i+ | python3-hyperlink        | package | 17.2.1-5.1                     | noarch | devel:languages:python
i+ | python3-idle             | package | 3.6.5-3.3                      | x86_64 | openSUSE Oss          
i+ | python3-idna             | package | 2.7-1.1                        | noarch | openSUSE Oss          
i+ | python3-incremental      | package | 17.5.0-1.3                     | noarch | openSUSE Oss          
i+ | python3-javapackages     | package | 5.3.0-2.1                      | noarch | openSUSE Oss          
i  | python3-keyczar          | package | 0.716-16.1                     | noarch | devel:languages:python
i+ | python3-keyring          | package | 15.1.0-71.3                    | noarch | devel:languages:python
i  | python3-keyrings.alt     | package | 3.1-1.1                        | noarch | devel:languages:python
i+ | python3-kiwisolver       | package | 1.0.1-8.8                      | x86_64 | devel:languages:python
i+ | python3-lxml             | package | 4.2.5-104.2                    | x86_64 | devel:languages:python
i+ | python3-matplotlib       | package | 3.0.2-1.1                      | x86_64 | openSUSE Oss          
i+ | python3-matplotlib-cairo | package | 3.0.2-1.1                      | x86_64 | openSUSE Oss          
i+ | python3-matplotlib-gtk3  | package | 3.0.2-1.1                      | x86_64 | openSUSE Oss          
i+ | python3-matplotlib-tk    | package | 3.0.2-1.1                      | x86_64 | openSUSE Oss          
i+ | python3-ndg-httpsclient  | package | 0.4.0-7.1                      | noarch | devel:languages:python
i+ | python3-nose             | package | 1.3.7-10.1                     | noarch | openSUSE Oss          
i+ | python3-numpy            | package | 1.15.3-1.1                     | x86_64 | openSUSE Oss          
i+ | python3-olefile          | package | 0.45.1-9.1                     | noarch | devel:languages:python
i+ | python3-openshot         | package | 0.2.2-1.1                      | x86_64 | openSUSE Oss          
i+ | python3-packaging        | package | 17.1-21.89                     | noarch | devel:languages:python
i+ | python3-paramiko         | package | 2.4.2-2.1                      | noarch | openSUSE Oss          
i  | python3-pathspec         | package | 0.5.6-4.1                      | noarch | devel:languages:python
i+ | python3-pexpect          | package | 4.6.0-2.2                      | noarch | openSUSE Oss          
i+ | python3-pip              | package | 18.1-1.1                       | noarch | openSUSE Oss          
i+ | python3-ply              | package | 3.11-71.2                      | noarch | devel:languages:python
i+ | python3-psutil           | package | 5.4.8-106.1                    | x86_64 | devel:languages:python
i+ | python3-ptyprocess       | package | 0.6.0-1.1                      | noarch | openSUSE Oss          
i+ | python3-py               | package | 1.7.0-1.1                      | noarch | openSUSE Oss          
i+ | python3-pyOpenSSL        | package | 17.5.0-2.2                     | noarch | openSUSE Oss          
i+ | python3-pyasn1           | package | 0.4.4-1.1                      | noarch | openSUSE Oss          
i+ | python3-pyasn1-modules   | package | 0.2.2-52.2                     | noarch | devel:languages:python
i+ | python3-pycparser        | package | 2.19-1.1                       | noarch | openSUSE Oss          
i+ | python3-pycryptodome     | package | 3.6.6-2.1                      | x86_64 | openSUSE Oss          
i+ | python3-pycups           | package | 1.9.73-1.3                     | x86_64 | openSUSE Oss          
i+ | python3-pycurl           | package | 7.43.0.2-5.1                   | x86_64 | openSUSE Oss          
i  | python3-pygit2           | package | 0.27.0-45.11                   | x86_64 | devel:languages:python
i+ | python3-pyparsing        | package | 2.3.1~test5-1.1                | noarch | openSUSE Oss          
i+ | python3-pyserial         | package | 3.4-1.3                        | noarch | openSUSE Oss          
i+ | python3-pysmbc           | package | 1.0.15.8-1.3                   | x86_64 | openSUSE Oss          
i+ | python3-python-dateutil  | package | 2.7.3-1.1                      | noarch | openSUSE Oss          
i+ | python3-pytz             | package | 2018.5-1.1                     | noarch | openSUSE Oss          
i+ | python3-pyxdg            | package | 0.26-1.1                       | noarch | openSUSE Oss          
i+ | python3-pyzmq            | package | 17.1.2-1.1                     | x86_64 | openSUSE Oss          
i+ | python3-qt4              | package | 4.12.3-1.1                     | x86_64 | openSUSE Oss          
i+ | python3-qt5              | package | 5.11.3-3.1                     | x86_64 | openSUSE Oss          
i+ | python3-requests         | package | 2.20.1-1.1                     | noarch | openSUSE Oss          
i  | python3-rpm              | package | 4.14.2.1-2.1                   | x86_64 | openSUSE Oss          
i+ | python3-service_identity | package | 17.0.0-2.1                     | noarch | openSUSE Oss          
i+ | python3-setuptools       | package | 40.5.0-1.1                     | noarch | openSUSE Oss          
i+ | python3-simplejson       | package | 3.16.1-1.1                     | x86_64 | openSUSE Oss          
i+ | python3-sip              | package | 4.19.13-1.1                    | x86_64 | openSUSE Oss          
i+ | python3-six              | package | 1.11.0-4.1                     | noarch | openSUSE Oss          
i  | python3-slip             | package | 0.6.5-18.1                     | noarch | devel:languages:python
i  | python3-slip-dbus        | package | 0.6.5-18.1                     | noarch | devel:languages:python
i  | python3-solv             | package | 0.7.1-1.1                      | x86_64 | openSUSE Oss          
i+ | python3-speechd          | package | 0.8.8-3.2                      | x86_64 | openSUSE Oss          
i  | python3-talloc           | package | 2.1.14-1.1                     | x86_64 | openSUSE Oss          
i  | python3-talloc-32bit     | package | 2.1.14-1.1                     | x86_64 | openSUSE Oss          
i+ | python3-tk               | package | 3.6.5-3.4                      | x86_64 | openSUSE Oss          
i+ | python3-tornado          | package | 4.5.3-7.1                      | x86_64 | openSUSE Oss          
i+ | python3-urllib3          | package | 1.24-1.1                       | noarch | openSUSE Oss          
i+ | python3-vapoursynth      | package | 43-3.5                         | x86_64 | openSUSE Oss          
i+ | python3-wheel            | package | 0.32.3-1.1                     | noarch | openSUSE Oss          
i+ | python3-xcb-proto-devel  | package | 7.6_1.13-1.2                   | x86_64 | openSUSE Oss          
i  | python3-xcffib           | package | 0.5.1-5.1                      | noarch | devel:languages:python
i+ | python3-yamllint         | package | 1.11.1-6.1                     | noarch | devel:languages:python
i+ | python3-zope.interface   | package | 4.5.0-1.1                      | x86_64 | openSUSE Oss          
i+ | python3-zope.root        | package | 4.3.3-1.2                      | x86_64 | (System Packages)     
i  | python3-zypp-plugin      | package | 0.6.3-3.1                      | noarch | openSUSE Oss        

zypper se -si sip
S  | Name                      | Type    | Version       | Arch   | Repository  
---+---------------------------+---------+---------------+--------+-------------
i+ | libosip2                  | package | 5.0.0-1.6     | x86_64 | openSUSE Oss
i+ | libosip2-devel            | package | 5.0.0-1.6     | x86_64 | openSUSE Oss
i+ | libsofia-sip-ua-glib3     | package | 1.12.11-16.14 | x86_64 | openSUSE Oss
i+ | libsofia-sip-ua0          | package | 1.12.11-16.14 | x86_64 | openSUSE Oss
i+ | python-qscintilla-qt4-sip | package | 2.10.8-2.1    | x86_64 | openSUSE Oss
i+ | python-sip-common         | package | 4.19.13-1.1   | x86_64 | openSUSE Oss
i+ | python2-sip               | package | 4.19.13-1.1   | x86_64 | openSUSE Oss
i+ | python3-sip               | package | 4.19.13-1.1   | x86_64 | openSUSE Oss  

zypper se -si qt4
S  | Name                      | Type    | Version    | Arch   | Repository  
---+---------------------------+---------+------------+--------+-------------
i+ | backintime-qt4            | package | 1.1.24-1.2 | noarch | openSUSE Oss
i+ | libqscintilla2_qt4-13     | package | 2.10.8-2.1 | x86_64 | openSUSE Oss
i+ | libqt4                    | package | 4.8.7-14.3 | x86_64 | openSUSE Oss
i+ | libqt4-32bit              | package | 4.8.7-14.3 | x86_64 | openSUSE Oss
i+ | libqt4-linguist           | package | 4.8.7-14.3 | x86_64 | openSUSE Oss
i+ | libqt4-qt3support         | package | 4.8.7-14.3 | x86_64 | openSUSE Oss
i+ | libqt4-qt3support-32bit   | package | 4.8.7-14.3 | x86_64 | openSUSE Oss
i+ | libqt4-sql                | package | 4.8.7-14.3 | x86_64 | openSUSE Oss
i+ | libqt4-sql-32bit          | package | 4.8.7-14.3 | x86_64 | openSUSE Oss
i+ | libqt4-sql-sqlite         | package | 4.8.7-14.3 | x86_64 | openSUSE Oss
i+ | libqt4-sql-sqlite-32bit   | package | 4.8.7-14.3 | x86_64 | openSUSE Oss
i+ | libqt4-x11                | package | 4.8.7-14.3 | x86_64 | openSUSE Oss
i+ | libqt4-x11-32bit          | package | 4.8.7-14.3 | x86_64 | openSUSE Oss
i+ | python-qscintilla-qt4-sip | package | 2.10.8-2.1 | x86_64 | openSUSE Oss
i+ | python-qt4-utils          | package | 4.12.3-1.1 | x86_64 | openSUSE Oss
i+ | python2-qt4               | package | 4.12.3-1.1 | x86_64 | openSUSE Oss
i+ | python3-qt4               | package | 4.12.3-1.1 | x86_64 | openSUSE Oss
i+ | qt4-qtscript              | package | 0.2.0-13.2 | x86_64 | openSUSE Oss

pip list
Package          Version  
---------------- ---------
apparmor         2.13     
appdirs          1.4.3    
asn1crypto       0.24.0   
attrs            18.2.0   
Automat          0.6.0    
backports-abc    0.5      
bcrypt           3.1.4    
bottle           0.12.13  
cached-property  1.5.1    
cairocffi        0.8.1    
certifi          2018.4.16
cffi             1.11.5   
chardet          3.0.4    
cmdln            2.0.0    
ConfigArgParse   0.13.0   
constantly       15.1.0   
coverage         4.5.1    
cryptography     2.4.1    
cssselect        1.0.3    
cupshelpers      1.0      
cycler           0.10.0   
decorator        4.3.0    
devedeng         4.11.0   
ecdsa            0.13     
entrypoints      0.2.3    
fs               2.0.4    
gevent           1.3.5    
gixy             0.1.20   
greenlet         0.4.15   
h2               3.0.1    
hpack            3.0.0    
httplib2         0.10.3   
hyperframe       5.1.0    
hyperlink        17.2.1   
idna             2.7      
incremental      17.5.0   
isc              2.0      
javapackages     5.3.0    
Jinja2           2.10     
keyring          15.1.0   
keyrings.alt     3.1      
kiwisolver       1.0.1    
LibAppArmor      2.13     
lxml             4.2.5    
MarkupSafe       1.0      
matplotlib       3.0.2    
meld             3.19.0   
ndg-httpsclient  0.4.0    
nose             1.3.7    
numpy            1.15.3   
olefile          0.45.1   
openshot-qt      2.4.3    
packaging        17.1     
paramiko         2.4.2    
pathspec         0.5.6    
pexpect          4.6.0    
Pillow           5.3.0    
pip              18.1     
ply              3.11     
powerline-status 2.7      
psutil           5.4.8    
ptyprocess       0.6.0    
py               1.7.0    
pyasn1           0.4.4    
pyasn1-modules   0.2.2    
pycairo          1.15.1   
pycparser        2.19     
pycryptodome     3.6.6    
pycups           1.9.73   
pycurl           7.43.0.2 
pygit2           0.27.0   
PyGObject        3.30.4   
PyHamcrest       1.9.0    
PyNaCl           1.3.0    
pyOpenSSL        17.5.0   
pyparsing        2.3.1    
pyserial         3.4      
pysmbc           1.0.15.8 
PySocks          1.6.8    
python-dateutil  2.7.3    
python-keyczar   0.71h    
pytz             2018.5   
pyxdg            0.26     
PyYAML           3.13     
pyzmq            17.1.2   
requests         2.20.1   
rpm              4.14.2.1 
SecretStorage    2.3.1    
service-identity 17.0.0   
setuptools       40.5.0   
simplejson       3.16.1   
sip              4.19.8   
six              1.11.0   
slip             0.6.5    
slip.dbus        0.6.5    
tornado          4.5.3    
Twisted          18.9.0   
urllib3          1.24     
wheel            0.32.3   
xcffib           0.5.1    
yamllint         1.11.1   
zope.interface   4.5.0
Comment 2 Bunte Katze 2018-12-16 17:09:15 UTC
My not-so-much informed theory is based on:

"PyQt4 and Qt v4 are no longer supported and no new releases will be made. PyQt5 and Qt v5 are strongly recommended for all new development."
https://www.riverbankcomputing.com/software/pyqt/intro

Might it be that OpenSUSE tries to run this on PyQt4, while `sip` from riverbankcomputing only supports Qt5 any more?

I did git clone https://github.com/bit-team/backintime.git and built backintime and backintime-qt4_polkit from source by following the instructions in https://github.com/bit-team/backintime.

I did, however, use the current master (1.2.0~alpha, https://github.com/bit-team/backintime/commits/master @ ba37b1e), not the latest (old) release (1.1.24, https://github.com/bit-team/backintime/releases) 

In any case, the current git master works. I cannot yet tell if there are any regressions (given that master is named "~alpha"...)
Comment 3 Sebastian Kuhne 2019-01-03 06:36:15 UTC
I tried to follow the instructions under
https://github.com/bit-team/backintime/issues/964 - however, I failed to install PyQt4.sip (the installation went right obviously but backintime still fails to start).

I have to admit that I am not an expert in Python - so if someone could build the right files and dependencies into the TW standard repositories would be very much appreciated.

Unfortunately, I am running in big trouble without backintime, but that's just my personal issue.
Comment 4 Tejas Guruswamy 2019-01-03 16:59:06 UTC
PyQt4 now requires a private copy of sip which is not currently being built in python-sip in TW.

@TheBlackCat, is it possible to build and install PyQt4.sip alongside PyQt5.sip in python-sip?
Comment 5 Tejas Guruswamy 2019-01-05 04:40:26 UTC
*** Bug 1119782 has been marked as a duplicate of this bug. ***
Comment 6 Wolfgang Bauer 2019-01-06 02:18:16 UTC
I gave it i try, can you please try the packages from here and report back whether they fix the issue?
https://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Qt5/

If they do fix the problem, I'll try to submit them to the devel project...
Comment 7 Sebastian Kuhne 2019-01-06 06:23:58 UTC
Wolfgang,

I did the following:

Added https://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Qt5/openSUSE_Factory/ to the repositories

Then, forced the updates from
- python-sip-common (4.19.13.1.1-x64_64 --> 4.19.13-27.1-x86_64)
- python2-sip (4.19.13.1.1-x64_64 --> 4.19.13-27.1-x86_64)
- python3-sip (4.19.13.1.1-x64_64 --> 4.19.13-27.1-x86_64)

That fixed the issue obviously - Backintime is back to work.

Maybe it is worth that someone else could give it a try it but is seems to be the solution.

Thanks a lot!
Comment 8 Frank Krüger 2019-01-06 09:12:00 UTC
(In reply to Wolfgang Bauer from comment #6)
> I gave it i try, can you please try the packages from here and report back
> whether they fix the issue?
> https://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/
> Qt5/
> 
> If they do fix the problem, I'll try to submit them to the devel project...

I can confirm that issue is fixed. Thx.
Comment 9 Oliver Grad 2019-01-06 10:10:54 UTC
Hi,

as far as my situation is concerned the issue seems to be fixed.

BR,
Oliver
Comment 10 Tejas Guruswamy 2019-01-06 18:38:23 UTC
Thank you Wolfgang, your python-sip changes look good to me, please submit them to KDE:Qt and Factory. I will keep the bug open till the patch is accepted but this should be all that is needed (at least until backintime moves to qt5).
Comment 11 patrick shanahan 2019-01-07 17:46:53 UTC
Wolfgang, your python-sip changes solve my problems with backintime-qt4 also.
Comment 12 Hans-Dieter Schulze 2019-01-08 05:47:59 UTC
Hello Wolfgang, Backintime (Tumbleweed) is working again. Thank you.
Comment 13 Wolfgang Bauer 2019-01-08 12:41:51 UTC
Submit request created, let's see if it gets accepted:
https://build.opensuse.org/request/show/663652

This will probably only be a "temporary workaround" though, I'm afraid.
AFAIK the next major release of python-sip won't support Qt4 at all anymore. (I don't know when that will happen though)
Comment 14 Sebastian Kuhne 2019-01-16 05:41:54 UTC
Hi Tejas,

it seems that Wolfgang (Thanks again) has implemented the bugfix already in the TW repos.

Do you agree to close this bug now?

Best regards
Sebastian
Comment 15 Frank Krüger 2019-01-16 09:35:50 UTC
Works for me with current TW. Does someone know whether or when backintime will move to qt5?
Comment 16 Tejas Guruswamy 2019-01-17 03:04:16 UTC
Thanks again Wolfgang, I am now closing this issue.

(In reply to Frank Kruger from comment #15)
> Does someone know whether or when backintime will move to qt5?

the current git master (https://github.com/bit-team/backintime/) is python3 and qt5, but I have no idea whether it is functional or when the developer plans to release.