Bug 1119495 - keyboard lags and multiple messages libinput error client bug offset negative
keyboard lags and multiple messages libinput error client bug offset negative
Status: RESOLVED DUPLICATE of bug 1117833
: 1116615 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-12-14 08:41 UTC by Victor Zhestkov
Modified: 2018-12-15 21:07 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Zhestkov 2018-12-14 08:41:23 UTC
Latest Tumbleweed with permanent keyboard micro lags and a lot of messages in the journal:
Dec 14 11:33:46 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce: offset negative (-70ms)
Dec 14 11:33:46 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce short: offset negative (-83ms)
Dec 14 11:34:12 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce short: offset negative (-4ms)
Dec 14 11:34:22 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce: offset negative (-70ms)
Dec 14 11:34:22 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce short: offset negative (-83ms)
Dec 14 11:34:24 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce: offset negative (-15ms)
Dec 14 11:34:24 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce short: offset negative (-29ms)
Dec 14 11:34:56 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce short: offset negative (-9ms)
Dec 14 11:34:59 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce short: offset negative (-6ms)
Dec 14 11:35:15 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce short: offset negative (-11ms)
Dec 14 11:35:27 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce short: offset negative (-9ms)
Dec 14 11:36:03 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce: offset negative (-92ms)
Dec 14 11:36:03 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce short: offset negative (-105ms)
Dec 14 11:36:05 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce: offset negative (-13ms)
Dec 14 11:36:05 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce short: offset negative (-26ms)
Dec 14 11:36:24 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce: offset negative (-26ms)
Dec 14 11:36:24 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce short: offset negative (-39ms)
Dec 14 11:36:30 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce: offset negative (-16ms)
Dec 14 11:36:30 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce short: offset negative (-29ms)
Dec 14 11:37:19 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce: offset negative (-86ms)
Dec 14 11:37:19 MYHOST org.gnome.Shell.desktop[2777]: libinput error: client bug: timer event21 debounce short: offset negative (-99ms)
Comment 1 Michiel Janssens 2018-12-14 16:12:05 UTC
*** Bug 1116615 has been marked as a duplicate of this bug. ***
Comment 2 Victor Zhestkov 2018-12-14 19:00:55 UTC
I have another laptop, but ThinkPad T470p, and tumbleweed on this laptop seems have no such issue. But the packages are the same.
I've also checked XOrg on T460 and it works better, the micro freezes also persist but less in time and have quite different behavior. Under wayland the freezes lead to repeated key presses, but under XOrg it just freezes and print the character with a little delay. I didn't notice high CPU utilization during such freezes.
I can provide any required information from both of the systems.
Thanks for advance for any recommendations.
Comment 3 Victor Zhestkov 2018-12-15 21:07:35 UTC
The same behaviour and probably hardware related

*** This bug has been marked as a duplicate of bug 1117833 ***