Bug 1114586 - grub2-mkconfig is not building menu for other systems.
grub2-mkconfig is not building menu for other systems.
Status: RESOLVED DUPLICATE of bug 1113615
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Bootloader
Current
x86-64 SUSE Other
: P5 - None : Major (vote)
: ---
Assigned To: Jiri Srain
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-11-04 04:19 UTC by Neil Rickert
Modified: 2018-11-05 06:31 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Transcript from running grub2-mkconfig (2.34 KB, text/plain)
2018-11-04 04:23 UTC, Neil Rickert
Details
Transcript for second run of "grub2-mkconfig" (2.93 KB, text/plain)
2018-11-04 04:34 UTC, Neil Rickert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Neil Rickert 2018-11-04 04:19:25 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build Identifier: 

Booting Tumbleweed, I find nothing in the menu other than Tumbleweed.  There are no entries for other systems on this computer.

It looks as if os-prober or the script 30_os-prober is failing.

Running os-prober by itself looks to be okay.  So I think the 30_os-probler script is failing, and leaving a mess behind.

Will attach some transcripts showing the problems.

Reproducible: Always
Comment 1 Neil Rickert 2018-11-04 04:23:42 UTC
Created attachment 788351 [details]
Transcript from running grub2-mkconfig

When I run "grub2-mkconfig", it does list all of the other systems that it finds.  But it does not build menu entries for them.

I used: grep menuentry grub.cfg
to list the generated  menu entries, and it does not have any for the systems found.  Previously, it used to generate a menu entry for all listed systems except Solus.
Comment 2 Neil Rickert 2018-11-04 04:34:18 UTC
Created attachment 788352 [details]
Transcript for second run of "grub2-mkconfig"

After running "grub2-mkconfig" the first time, os-prober is broken until reboot.

This transcript shows the content of "/var/lib/os-prober/mount".  It looks as if os-prober was aborted before fully cleaning up.

The transcript also shows the output from running "grub2-mkconfig" a second time, where it fails to find other systems.

I'll note that if I reboot, then run os-prober from the command line, that works fine.  And I can repeat that without a problem.  It is only after running "grub2-mkconfig" that it fails.  That's why I suspect that the "30_os-prober" script is failing, and causing "os-prober" to abort without cleaning up.

I don't know whether this is relevant.  "/etc/default/grub" does contain:
GRUB_ENABLE_CRYPTODISK="y"

A side note: Bugzilla search for "os-prober" seemed to not work.  And the list of 100 recent bugs seems several years out of date.
Comment 3 Frank Krüger 2018-11-04 08:08:49 UTC
Might be a duplicate of https://bugzilla.opensuse.org/show_bug.cgi?id=1113615.
Comment 4 Neil Rickert 2018-11-04 13:56:56 UTC
>Might be a duplicate

You are probably right.  Thanks for the reference.  Bugzilla search seems to not be working for me.

So maybe the fix is in the works.  We can let this sit for a few days to see if it shows up.
Comment 5 Frank Krüger 2018-11-04 15:30:15 UTC
(In reply to Neil Rickert from comment #4)
> >Might be a duplicate
> 
> You are probably right.  Thanks for the reference.  Bugzilla search seems to
> not be working for me.
> 
> So maybe the fix is in the works.  We can let this sit for a few days to see
> if it shows up.

You might give the fixed version of os-prober a try: https://download.opensuse.org/repositories/home:/michael-chang:/boo:/1113615/openSUSE_Factory/
Comment 6 Neil Rickert 2018-11-04 18:02:06 UTC
Thanks.  But I'll probably wait for the fix to show up in a future snapshot.

I make sure that I have multiple ways of booting, so I can manage for now.  However, others are beginning to report problems at opensuse forums.  Waiting for a snapshot to fix it, will allow me to know that it is fixed for everybody.
Comment 7 Jiri Srain 2018-11-05 06:31:22 UTC
OK, closing as Duplicate.

Please, reopen if this judgment shows to be wrong.

*** This bug has been marked as a duplicate of bug 1113615 ***