Bug 1114573 - Expand libyui to support setting YImage from icon theme
Expand libyui to support setting YImage from icon theme
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P3 - Medium : Enhancement (vote)
: ---
Assigned To: YaST Team
Jiri Srain
https://trello.com/c/PX0Seh0i
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-11-03 18:03 UTC by Sasi Olin
Modified: 2018-11-16 13:27 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sasi Olin 2018-11-03 18:03:28 UTC
YImage is commonly used to display icons, both qt and gtk support setting images from icon themes.
Comment 1 Stefan Hundhammer 2018-11-12 16:23:47 UTC
Since we don't have the Gtk UI anymore, this is mostly a Qt UI (libyui-qt) thing; this is a non-issue for the NCurses UI.

One caveat is that the YImage widget may also be used to display other stuff than icons: Big pixmaps of any kind; screenshots or whatever. So we have to be careful to simply cut off a path.

But if no path is given, we could simply try loading a theme icon. We'll have to investigate that further.
Comment 2 Sasi Olin 2018-11-16 13:27:50 UTC
Resolved via latest changes to libyui-qt