Bug 1114192 - yast2-ruby-bindings does not support new grammatical form of month names
yast2-ruby-bindings does not support new grammatical form of month names
Status: RESOLVED DUPLICATE of bug 1107953
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-31 14:01 UTC by Martin Liška
Modified: 2018-10-31 15:14 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liška 2018-10-31 14:01:21 UTC
Error can be seen here, which is a staging project for new glibc:
https://build.opensuse.org/package/live_build_log/openSUSE:Factory:Staging:C/yast2-ruby-bindings/standard/x86_64

error:

[   49s] 7:   1) Yast::Builtins.strftime in a system set to Czech returns the localized formatted time
[   49s] 7:      Failure/Error: expect(Yast::Builtins.strftime(time, format)).to eq "\u00FAnor - 29 - 12:13:14"
[   49s] 7: 
[   49s] 7:        expected: "\u00FAnor - 29 - 12:13:14"
[   49s] 7:             got: "\u00FAnora - 29 - 12:13:14"

glibc changelog:
https://www.sourceware.org/ml/libc-alpha/2018-08/msg00003.html
Comment 1 Martin Liška 2018-10-31 15:13:24 UTC
Steps to reproduce:

$ osc co openSUSE:Factory:Staging:C/yast2-ruby-bindings
$ cd openSUSE:Factory:Staging:C/yast2-ruby-bindings
$ osc build
Comment 2 Lukas Ocilka 2018-10-31 15:14:51 UTC
Already fixed in https://github.com/yast/yast-ruby-bindings/pull/218
thx to Arvin.

*** This bug has been marked as a duplicate of bug 1107953 ***