Bug 1114133 - KiCad footprint wizard broken
KiCad footprint wizard broken
Status: RESOLVED DUPLICATE of bug 1114132
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other SUSE Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-31 09:20 UTC by Aaron Williams
Modified: 2018-10-31 10:23 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Williams 2018-10-31 09:20:17 UTC
In kicad-5.0.1-lp150.58.1.x86_64 I get the following error when I attempt to use the footprint wizard in the footprint editor to create a new footprint.

  File "/usr/usr/lib64/python2.7/site-packages/pcbnew.py", line 3866, in GetFootprint
    self.BuildFootprint()

  File "/usr/share/kicad/scripting/plugins/FootprintWizardBase.py", line 139, in BuildFootprint
    fpid = pcbnew.LIB_ID(self.module.GetValue())  # the name in library

  File "/usr/usr/lib64/python2.7/site-packages/pcbnew.py", line 5502, in __init__
    this = _pcbnew.new_LIB_ID(*args)

NotImplementedError: Wrong number or type of arguments for overloaded function 'new_LIB_ID'.
  Possible C/C++ prototypes are:
    LIB_ID::LIB_ID()
    LIB_ID::LIB_ID(wxString const &,wxString const &,wxString const &)
    LIB_ID::LIB_ID(wxString const &,wxString const &)
Comment 1 Andreas Stieger 2018-10-31 10:23:28 UTC
duplicate report

*** This bug has been marked as a duplicate of bug 1114132 ***