Bug 1114132 - KiCad footprint wizard broken
KiCad footprint wizard broken
Status: RESOLVED WONTFIX
: 1114133 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other SUSE Other
: P5 - None : Normal (vote)
: ---
Assigned To: Stefan Brüns
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-31 09:18 UTC by Aaron Williams
Modified: 2020-12-30 10:01 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Williams 2018-10-31 09:18:36 UTC
In kicad-5.0.1-lp150.58.1.x86_64 I get the following error when I attempt to use the footprint wizard in the footprint editor to create a new footprint.

  File "/usr/usr/lib64/python2.7/site-packages/pcbnew.py", line 3866, in GetFootprint
    self.BuildFootprint()

  File "/usr/share/kicad/scripting/plugins/FootprintWizardBase.py", line 139, in BuildFootprint
    fpid = pcbnew.LIB_ID(self.module.GetValue())  # the name in library

  File "/usr/usr/lib64/python2.7/site-packages/pcbnew.py", line 5502, in __init__
    this = _pcbnew.new_LIB_ID(*args)

NotImplementedError: Wrong number or type of arguments for overloaded function 'new_LIB_ID'.
  Possible C/C++ prototypes are:
    LIB_ID::LIB_ID()
    LIB_ID::LIB_ID(wxString const &,wxString const &,wxString const &)
    LIB_ID::LIB_ID(wxString const &,wxString const &)
Comment 1 Andreas Stieger 2018-10-31 10:23:28 UTC
*** Bug 1114133 has been marked as a duplicate of this bug. ***
Comment 2 Aaron Williams 2018-10-31 18:51:09 UTC
Note that /usr/usr is also a bug I have run into in the past with KiCad and created a symlink in order for this to work in the past. This is also referred to in https://forum.kicad.info/t/3d-models-not-showing/12494/9.

Also see https://forum.kicad.info/t/3d-viewer-not-showing-3d-models-after-update-to-nightly/6153/17
Comment 3 Andreas Stieger 2020-12-30 10:01:07 UTC
cleaning up... Leap 15.0 is discontinued, the package has since moved on. Please re-open if this occurs with a current Tumbleweed build or supported Leap release