Bug 1113946 - ceph build fails in openSUSE:Factory:Staging:C
ceph build fails in openSUSE:Factory:Staging:C
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Nathan Cutler
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-30 12:50 UTC by Martin Liška
Modified: 2021-07-19 10:42 UTC (History)
3 users (show)

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Liška 2018-10-30 12:50:28 UTC
Fails here:
https://build.opensuse.org/public/build/openSUSE:Factory:Staging:C/standard/x86_64/ceph/_log

due to:
[ 2933s] /home/abuild/rpmbuild/BUILD/ceph-13.2.0-210-g0e990e900d/src/mgr/PythonCompat.h: In function 'char* PyString_AsString(PyObject*)':
[ 2933s] /home/abuild/rpmbuild/BUILD/ceph-13.2.0-210-g0e990e900d/src/mgr/PythonCompat.h:17:26: error: invalid conversion from 'const char*' to 'char*' [-fpermissive]
[ 2933s]    return PyUnicode_AsUTF8(string);
[ 2933s]           ~~~~~~~~~~~~~~~~^~~~~~~~


which is caused by Python update. Please fix it.
Comment 1 Nathan Cutler 2018-11-01 07:24:00 UTC
We have a completely new version of Ceph ready to go into Factory here https://build.opensuse.org/request/show/644858 but it's being tested in openSUSE:Factory:Staging:F :-(

Could we switch it over to Staging:C to see if it fixes the issue?
Comment 2 Nathan Cutler 2018-11-01 07:31:39 UTC
Ah, now I see it: http://tracker.ceph.com/issues/35984

Fixed in master, but not yet backported to nautilus. On it.
Comment 3 Nathan Cutler 2018-11-01 07:38:38 UTC
Should be fixed by https://build.opensuse.org/request/show/645862 - I submitted it with a note that it should be tested in openSUSE:Factory:Staging:C.
Comment 4 Nathan Cutler 2018-11-01 07:41:15 UTC
Clarification: the bug actually *is* fixed in nautilus. I lied in Comment 2.