Bug 1113749 - (CVE-2018-18718) VUL-1: CVE-2018-18718: gthumb: double-free in the add_themes_from_dir method
(CVE-2018-18718)
VUL-1: CVE-2018-18718: gthumb: double-free in the add_themes_from_dir method
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 42.3
Other Other
: P4 - Low : Minor (vote)
: ---
Assigned To: openSUSE GNOME
Security Team bot
https://smash.suse.de/issue/218204/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-29 14:25 UTC by Karol Babioch
Modified: 2019-04-14 14:41 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Karol Babioch 2018-10-29 14:26:20 UTC
Upstream issue: https://gitlab.gnome.org/GNOME/gthumb/issues/18
Comment 2 Swamp Workflow Management 2019-01-02 15:40:06 UTC
This is an autogenerated message for OBS integration:
This bug (1113749) was mentioned in
https://build.opensuse.org/request/show/662471 15.0+42.3+Backports:SLE-15 / gthumb
Comment 3 Dan Čermák 2019-01-08 17:27:20 UTC
This issue has been fixed via https://build.opensuse.org/request/show/662471 in Leap and via https://build.opensuse.org/request/show/660228 in Tumbleweed. As gthumb is no longer maintained in SLE, this bug should be resolved then.

Please reopen it if I'm wrong.
Comment 4 Swamp Workflow Management 2019-01-09 18:50:06 UTC
This is an autogenerated message for OBS integration:
This bug (1113749) was mentioned in
https://build.opensuse.org/request/show/664157 Factory / gthumb
Comment 5 Swamp Workflow Management 2019-01-12 02:20:29 UTC
openSUSE-SU-2019:0022-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1113749
CVE References: CVE-2018-18718
Sources used:
openSUSE Leap 42.3 (src):    gthumb-3.4.2-7.3.1
openSUSE Leap 15.0 (src):    gthumb-3.6.1-lp150.3.3.1
openSUSE Backports SLE-15 (src):    gthumb-3.6.1-bp150.2.3.1
Comment 6 Swamp Workflow Management 2019-01-14 14:10:07 UTC
This is an autogenerated message for OBS integration:
This bug (1113749) was mentioned in
https://build.opensuse.org/request/show/665750 Factory / gthumb