Bug 1113641 - chrony not enabled by default
chrony not enabled by default
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Reinhard Max
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-29 00:30 UTC by Christian Boltz
Modified: 2018-11-14 14:51 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
y2logs (1.70 MB, application/octet-stream)
2018-10-29 18:22 UTC, Christian Boltz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Boltz 2018-10-29 00:30:28 UTC
I did a fresh Tumbleweed installation on 2018-10-04 (with the KDE default pattern), and after a few weeks I noticed that the clock was running out of sync.

The reason: chrony was installed, but disabled.

It should be enabled by default to ensure that the clock stays in sync.


In case it's relevant: I did not provide the wifi password during the installation, therefore the installer didn't have internet access. After the installation, I did of course set up the wifi connection ;-)

If you need the YaST logs or other logs, please tell me.


As a sidenote: someone on the opensuse-factory ML proposed to enable systemd-timesyncd instead. That might be an alternative solution. I'll let you decide if you simply enable chrony by default, or if you want to fight that out with the systemd maintainers ;-)
Comment 1 Christian Boltz 2018-10-29 18:22:43 UTC
Created attachment 787588 [details]
y2logs

Josef asked for y2logs on the mailinglist - here they are ;-)
Comment 2 Reinhard Max 2018-11-14 14:51:10 UTC
I just did a fresh installation of Snapshot20181112 in a VM and couldn't reproduce it.

During installation I checked the NTP dialoge and found that running the service was preselected. After the first boot I verified that chronyd was running and had synced the local clock to an ntp server.