Bug 1113636 - gnome-shell failed to start, libmozjs-60.so error
gnome-shell failed to start, libmozjs-60.so error
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
HP All
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-28 18:21 UTC by Yura Beznos
Modified: 2021-04-15 14:20 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
libmozjs-60 crashed on those *.desktop files (1.10 KB, application/gzip)
2018-10-29 12:48 UTC, Yura Beznos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yura Beznos 2018-10-28 18:21:27 UTC
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8
Build Identifier: 

After "zypper up" and reboot can't login into gnome desktop.


Reproducible: Always

Steps to Reproduce:
1. Boot into login
2. submit username and password
3. again on login screen after screen flickering
Actual Results:  
gnome-shell crashes every time I am trying to log in.


gdb.txt ===
Thread 1 "gnome-shell" received signal SIGSEGV, Segmentation fault.
0x00007f261556bdb6 in ?? () from /usr/lib64/libmozjs-60.so
#0  0x00007f261556bdb6 in  () at /usr/lib64/libmozjs-60.so
#1  0x00007f261a5ae580 in gjs_string_from_utf8 () at /usr/lib64/libgjs.so.0
#2  0x00007f261a565ff2 in gjs_value_from_g_argument () at /usr/lib64/libgjs.so.0
#3  0x00007f261a577ec4 in  () at /usr/lib64/libgjs.so.0
#4  0x00007f261a5784d0 in  () at /usr/lib64/libgjs.so.0
#5  0x0000131c854478cb in  ()
#6  0x00007ffce08b2d18 in  ()
#7  0x00007ffce08b2c50 in  ()
#8  0x0000000000000000 in  ()
'gjs_dumpstack' has unknown return type; cast the call to its declared return type
A debugging session is active.
gdb.txt ===

journal ===
ct 28 20:50:40 linux-mh3d org.gnome.Shell.desktop[3429]: Hit MOZ_CRASH(invalid UTF-8 string: ReportInvalidCharacte
r) at /home/abuild/rpmbuild/BUILD/firefox-60.1.0/js/src/vm/CharacterEncoding.cpp:339
Oct 28 20:50:40 linux-mh3d kernel: show_signal_msg: 39 callbacks suppressed
Oct 28 20:50:40 linux-mh3d kernel: gnome-shell[3429]: segfault at 0 ip 00007f261556bdb6 sp 00007ffce08b2430 error 6
 in libmozjs-60.so[7f26154a9000+c52000]
Oct 28 20:50:40 linux-mh3d kernel: Code: ff ff c7 04 25 00 00 00 00 4d 01 00 00 e8 72 ea f3 ff ba 53 01 00 00 48 8d 35 4e ed bf 00 48 8d 3d 2f 03 c0 00 e8 57 d6 ff ff <c7> 04 25 00 00 00 00 53 01 00 00 e8 4a ea f3 ff ba 44 01 00 00 48 
journal ===

cat /etc/SUSE-brand 
openSUSE
VERSION = 15.0

gnome extensions disabled (empty folder)
Comment 1 Dominique Leuenberger 2018-10-29 08:26:14 UTC
(In reply to Yura Beznos from comment #0)
> After "zypper up" and reboot can't login into gnome desktop.

What if you were to use "zypper dup" ?
Comment 2 Yura Beznos 2018-10-29 09:17:52 UTC
Did that (zypper dup) and changed every conflict to openSUSE repository.

After reboot error is the same:


gdb.txt ===
Thread 1 "gnome-shell" received signal SIGSEGV, Segmentation fault.
0x00007f8646e5ddb6 in ?? () from /usr/lib64/libmozjs-60.so
#0  0x00007f8646e5ddb6 in  () at /usr/lib64/libmozjs-60.so
#1  0x00007f864bcad580 in gjs_string_from_utf8 () at /usr/lib64/libgjs.so.0
#2  0x00007f864bc64ff2 in gjs_value_from_g_argument () at /usr/lib64/libgjs.so.0
#3  0x00007f864bc76ec4 in  () at /usr/lib64/libgjs.so.0
#4  0x00007f864bc774d0 in  () at /usr/lib64/libgjs.so.0
#5  0x000022b739a548cb in  ()
#6  0x00007fff9b9d0368 in  ()
#7  0x00007fff9b9d02a0 in  ()
#8  0x0000000000000000 in  ()
'gjs_dumpstack' has unknown return type; cast the call to its declared return type
A debugging session is active.
gdb.txt ===


journal --since today ===
Oct 29 12:11:00 linux-mh3d org.gnome.Shell.desktop[3938]: Hit MOZ_CRASH(invalid UTF-8 string: ReportInvalidC
haracter) at /home/abuild/rpmbuild/BUILD/firefox-60.1.0/js/src/vm/CharacterEncoding.cpp:339
Oct 29 12:11:00 linux-mh3d kernel: gnome-shell[3938]: segfault at 0 ip 00007f8646e5ddb6 sp 00007fff9b9cfa80 error 6 in libmozjs-60.so[7f8646d9b000+c52000]
Oct 29 12:11:00 linux-mh3d kernel: Code: ff ff c7 04 25 00 00 00 00 4d 01 00 00 e8 72 ea f3 ff ba 53 01 00 00 48 8d 35 4e ed bf 00 48 8d 3d 2f 03 c0 00 e8 57 d6 ff ff <c7> 04 25 00 00 00 00 53 01 00 00 e8 4a ea f3 ff ba 44 01 00 00 48
Oct 29 12:11:00 linux-mh3d systemd[1]: Started Process Core Dump (PID 4297/UID 0).
journal ===
Comment 3 Yura Beznos 2018-10-29 12:48:47 UTC
Created attachment 787531 [details]
libmozjs-60 crashed on those *.desktop files

libmozjs-60 crashed on those *.desktop files
Comment 4 Yura Beznos 2018-10-29 12:50:34 UTC
Found problem in those *.desktop files, after moving them out, everything works just fine.

Looks like the bug must be sent to the libmozjs developers.
Comment 5 Dominique Leuenberger 2021-04-15 14:20:33 UTC
Dear Reporter,

Thank you for taking the time to report this bug and helping to make openSUSE better.

We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in openSUSE since the time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a current, supported openSUSE version.

When you test it and it is still an issue, kindly reopen this bug and move it to the tested version of openSUSE. 

Truly yours.