Bug 1113622 - TW 20181022: Virtualization/virtualbox is uninstallable
TW 20181022: Virtualization/virtualbox is uninstallable
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Virtualization:Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Larry Finger
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-27 20:53 UTC by Andrei Dziahel
Modified: 2018-11-25 19:09 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Dziahel 2018-10-27 20:53:51 UTC
Repro:

`zypper -v install virtualbox`

Expected: virtualbox is installed successfully

Instead: dependency error

> Problem: nothing provides kernel-uname-r = 4.18.14-1-default needed by virtualbox-host-kmp-default-5.2.18_k4.18.14_1-1.9.x86_64
>  Solution 1: do not install virtualbox-5.2.18-1.9.x86_64
>  Solution 2: break virtualbox-host-kmp-default-5.2.18_k4.18.14_1-1.9.x86_64 by ignoring some of its dependencies
Comment 1 Rihards Olups 2018-10-27 20:59:09 UTC
This also affects virtualbox-guest-kmp-default, and in turn also virtualbox-guest-tools and virtualbox-guest-x11.
Comment 2 Larry Finger 2018-10-28 01:11:17 UTC
I just tested on my system and all packages reinstalled correctly for kernel 4.18.14. There seems to be a problem for kernel 4.18.18. I'm not certain why VB is not building correctly for that kernel.

I am finishing the tests for VB 5.2.20 and will be pushing it soon, likely tomorrow. Once that hits Factory, these problems should be resolved.
Comment 3 Rihards Olups 2018-11-25 18:45:32 UTC
This seems to work OK with Tumbleweed 20181122.
Comment 4 Andrei Dziahel 2018-11-25 19:09:47 UTC
Totally forgot about this one, sorry. True, it started working after kernel rebuild in the next snapshot.