Bug 1113615 - TW 20181022 doesn't detect other OSes when setting up boot loader
TW 20181022 doesn't detect other OSes when setting up boot loader
Status: VERIFIED FIXED
: 1114586 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Bootloader
Current
x86-64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Michael Chang
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-27 13:00 UTC by Chris Ward
Modified: 2019-04-03 22:51 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Result of 'save_y2logs' (2.96 MB, application/x-compressed-tar)
2018-10-27 13:29 UTC, Chris Ward
Details
Output of grub2-mkconfig -o /boot/grub2/grub.cfg (3.77 KB, text/x-log)
2018-10-28 15:20 UTC, Chris Ward
Details
Output of journalctl while running os-prober (5.60 KB, text/x-log)
2018-10-30 09:39 UTC, Chris Ward
Details
Output of 'lsblk -f' (1.67 KB, text/x-log)
2018-10-30 09:40 UTC, Chris Ward
Details
generated grub.cfg (6.18 KB, text/plain)
2018-10-30 19:20 UTC, Cristian ANITA
Details
Output of os-prober,journalctl, and lsblk (7.50 KB, text/x-log)
2018-10-30 20:02 UTC, Chris Ward
Details
Output of os-prober with TW 20181107 (179 bytes, text/x-log)
2018-11-08 19:22 UTC, Chris Ward
Details
Output of journalctl at TW 20181107 while os-prober runs (4.90 KB, text/x-log)
2018-11-08 19:23 UTC, Chris Ward
Details
Output of lsblk -f at TW 20181107 (1.73 KB, text/x-log)
2018-11-08 19:25 UTC, Chris Ward
Details
Output of grub2-mkconfig -o /boot/grub2/grub.cfg at TW20181107 (571 bytes, text/x-log)
2018-11-08 19:30 UTC, Chris Ward
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Ward 2018-10-27 13:00:20 UTC
I have a machine with Windows and Leap 15.0 on an internal disk, and Tumbleweed and Centos 7.5 on an external disk. After update to TW 20181022, on booting the system from the external disk, only Tumbleweed is shown on the GRUB menu.

This is a recent change; I previously had the system at TW 201810xx for some lower xx, and the GRUB menu showed all 4 operating systems as it should do.
Comment 1 Chris Ward 2018-10-27 13:20:14 UTC
This behaviour only happens on one of my 2 external hard disks; I will investigate further what is different in the failing case.
Comment 2 Chris Ward 2018-10-27 13:29:52 UTC
Created attachment 787469 [details]
Result of 'save_y2logs'

Please find attached the result of 'save_y2logs'. The most recent YAST2 session was an attempt to re-set-up the bootloader to find the missing operating systems.
Comment 3 Chris Ward 2018-10-27 14:18:30 UTC
On running 'yast2 bootloader' 2 more times, the Windows and Leap systems (from the internal disk) have appeared on the grub . So only the Centos system is missing now.
Comment 4 Frank Krüger 2018-10-28 14:22:58 UTC
Does 'grub2-mkconfig -o /boot/grub2/grub.cfg' provide a useful hint?
Comment 5 Chris Ward 2018-10-28 15:20:52 UTC
Created attachment 787478 [details]
Output of grub2-mkconfig -o /boot/grub2/grub.cfg

I have attached the output of grub2-mkconfig. It seems to find centos; next to try rebooting and see if centos is offered.
Comment 6 Chris Ward 2018-10-28 15:25:26 UTC
No, the boot screen didn't offer an option to boot centos.
Comment 7 Frank Krüger 2018-10-28 15:49:03 UTC
(In reply to Chris Ward from comment #6)
> No, the boot screen didn't offer an option to boot centos.

The update to TW20181022 also changed os-prober from 1.74 to 1.76. Although I doubt that these changes are related to the current issue I would give version 1.74 (from Leap 15) a try (https://software.opensuse.org/package/os-prober?search_term=os-prober).
Comment 8 Chris Ward 2018-10-28 16:13:33 UTC
(In reply to Frank Kruger from comment #7)
> 
> The update to TW20181022 also changed os-prober from 1.74 to 1.76. Although
> I doubt that these changes are related to the current issue I would give
> version 1.74 (from Leap 15) a try
> (https://software.opensuse.org/package/os-prober?search_term=os-prober).

os-prober from Leap 15 (version 1.74) fixes my problem; I'm typing this from the freshly-booted centos system. So os-prober 1.76 is broken. Will experts fix it for me (and everyone else), or can I attempt to fix it myself ?
Comment 9 Frank Krüger 2018-10-28 16:31:54 UTC
(In reply to Chris Ward from comment #8)
> (In reply to Frank Kruger from comment #7)
> > 
> > The update to TW20181022 also changed os-prober from 1.74 to 1.76. Although
> > I doubt that these changes are related to the current issue I would give
> > version 1.74 (from Leap 15) a try
> > (https://software.opensuse.org/package/os-prober?search_term=os-prober).
> 
> os-prober from Leap 15 (version 1.74) fixes my problem; I'm typing this from
> the freshly-booted centos system. So os-prober 1.76 is broken. Will experts
> fix it for me (and everyone else), or can I attempt to fix it myself ?

Glad to hear that version 1.74 fixes the issue (cc maintainer of os-prober).
Comment 11 Michael Chang 2018-10-30 07:41:43 UTC
Hi Chris,

Would you please help to provide journalctl output running os-prober commands ?

> START=$(date +%s)
> os-prober
> journalctl --identifier=os-prober --since=@$START

Thanks.
Comment 12 Michael Chang 2018-10-30 07:58:42 UTC
And also the output of 

> lsblk -f
Comment 13 Chris Ward 2018-10-30 09:39:09 UTC
Created attachment 787667 [details]
Output of journalctl while running os-prober

I don't currently have access to the original system, but here is another system with multiple OSes which shows the same problem. Here I have TW on one disk, and leap-15.0 and Red Hat Enterprise Linux on another disk. The boot screen only shows the TW system
Comment 14 Chris Ward 2018-10-30 09:40:02 UTC
Created attachment 787668 [details]
Output of 'lsblk -f'

Here is the output of 'lsblk -f' on this second system.
Comment 15 Cristian ANITA 2018-10-30 19:19:25 UTC
I would like to confirm this bug (it appeared on TW 20181022 and is still present in 20181029).
Tumbleweed, Kubuntu 18.04 and Win 10 are installed on SSD (EFI; no secure boot); TW is default. Since 20181022 Kubuntu is missing from grub menu (but Windows is OK). I can boot Kubuntu from BIOS.
Below output from os-prober and grub2-mkconfig.

> os-prober
/dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
/dev/nvme0n1p7:Ubuntu 18.04.1 LTS (18.04):Ubuntu:linux

> grub2-mkconfig -o /boot/grub2/grub.cfg
Generating grub configuration file ...
Found theme: /boot/grub2/themes/openSUSE/theme.txt
Found linux image: /boot/vmlinuz-4.18.15-1-default
Found initrd image: /boot/initrd-4.18.15-1-default
Found Windows Boot Manager on /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
Found Ubuntu 18.04.1 LTS (18.04) on /dev/nvme0n1p7
done

But generated grub.cfg has no Kubuntu entry (I will attach file)

Please note that after I run above commands several times their output sometimes contains:
rmdir: failed to remove '/var/lib/os-prober/mount': Device or resource busy
Comment 16 Cristian ANITA 2018-10-30 19:20:29 UTC
Created attachment 787908 [details]
generated grub.cfg
Comment 17 Chris Ward 2018-10-30 20:02:25 UTC
Created attachment 787912 [details]
Output of os-prober,journalctl, and lsblk
Comment 18 Chris Ward 2018-10-30 20:03:45 UTC
Here is the output of (START=$(date +%s);os-prober;journalctl --identifier=os-prober --since=@$START;lsblk -f) 2>&1|tee os-prober-lsblk.log
after reinstalling the newer os-prober on the failing system.
Comment 19 Michael Chang 2018-10-31 08:00:06 UTC
@Chris, @Cristian

Sorry. It turns out to be my problem, not version 1.76. The regression is caused by linux-boot-prober got aborted prematurely due to error in command grub-probe not found. And that is a mistake from me for not eliminating it while rebasing patch on top 1.76.

I have verified the fix and submitted to openSUSE:Factory. The SR is

https://build.opensuse.org/request/show/645672

Here setting the resolution to fixed, pls reopen if you still have problem, or if you need anything from me.
Comment 20 Jiri Srain 2018-11-05 06:31:23 UTC
*** Bug 1114586 has been marked as a duplicate of this bug. ***
Comment 21 Chris Ward 2018-11-08 19:22:15 UTC
Created attachment 789095 [details]
Output of os-prober with TW 20181107

I have installed TW 20181107. os-prober is now at level 1.76-2.1, but the problem is still there. Here is the output of os-prober
Comment 22 Chris Ward 2018-11-08 19:23:48 UTC
Created attachment 789096 [details]
Output of journalctl at TW 20181107 while os-prober runs

Here is the output of journalctl
Comment 23 Chris Ward 2018-11-08 19:25:01 UTC
Created attachment 789098 [details]
Output of lsblk -f at TW 20181107

Here is the output of lsblk -f
Comment 24 Chris Ward 2018-11-08 19:26:27 UTC
TW 20181107 ( with os-prober 1.76-2.1) doesn't resolve the issue.
Comment 25 Chris Ward 2018-11-08 19:30:06 UTC
Created attachment 789099 [details]
Output of grub2-mkconfig -o /boot/grub2/grub.cfg at TW20181107

Here is the output of grub2-mkconfig. This finds all the operating systems.
Comment 26 Chris Ward 2018-11-08 19:32:14 UTC
After running grub2-mkconfig, all the OSes appear when I go into yast2 to change the bootloader configuration. Let me reboot and check if centos is offered now.
Comment 27 Chris Ward 2018-11-08 19:36:28 UTC
After running grub2-mkconfig, all the OSes are available in the boot menu. So I can close this issue now.
Comment 28 Chris Ward 2018-11-08 19:36:54 UTC
Verified fixed.
Comment 29 Cristian ANITA 2018-11-08 19:37:53 UTC
TW 20181107 fixed the issue for me. Thank you Michael!
Comment 30 Chris Ward 2018-11-09 08:10:50 UTC
Thanks to Michael from me, as well !
Comment 31 Swamp Workflow Management 2019-03-12 07:50:19 UTC
This is an autogenerated message for OBS integration:
This bug (1113615) was mentioned in
https://build.opensuse.org/request/show/684185 15.0 / os-prober
Comment 33 Swamp Workflow Management 2019-03-27 17:09:58 UTC
SUSE-RU-2019:0782-1: An update that has 5 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1026766,1101942,1113615,1118279,1125729
CVE References: 
Sources used:
SUSE Linux Enterprise Workstation Extension 15 (src):    os-prober-1.76-5.3.1

*** NOTE: This information is not intended to be used for external
    communication, because this may only be a partial fix.
    If you have questions please reach out to maintenance coordination.
Comment 34 Swamp Workflow Management 2019-04-03 22:18:07 UTC
openSUSE-RU-2019:1135-1: An update that has 5 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1026766,1101942,1113615,1118279,1125729
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    os-prober-1.76-lp150.3.3.1

*** NOTE: This information is not intended to be used for external
    communication, because this may only be a partial fix.
    If you have questions please reach out to maintenance coordination.