Bug 1113614 - Yast2 samba-server module does not write smb.conf
Yast2 samba-server module does not write smb.conf
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-27 12:23 UTC by Stefan Brüns
Modified: 2018-12-03 08:18 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
jbenet: needinfo?


Attachments
Yast2 log file in tar format (200.00 KB, application/x-tar)
2018-10-31 09:36 UTC, john bennett
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Brüns 2018-10-27 12:23:54 UTC
Tried changing the following settings:

1. workgroup name
2. disable one of the default shares
3. enabling usershares

None of these changes update /etc/samba/smb.conf.

When clicking on "OK", the dialog immediately closes.

There is nothing in the y2log which indicates a crash, last lines:
----
2018-10-27 14:14:08 <1> pebbles(15973) [Ruby] samba-server/dialogs.rb:266 Initial role: STANDALONE
2018-10-27 14:14:25 <1> pebbles(15973) [Ruby] samba-server/dialogs.rb:309 Setting workgroup 'MYWORKGROUP'
2018-10-27 14:14:25 <1> pebbles(15973) [Ruby] samba-server/dialogs.rb:325 Role type not changed (STANDALONE)
2018-10-27 14:14:25 <1> pebbles(15973) [Ruby] samba-server/dialogs.rb:343 Disabling wins support, using server '<none>'
2018-10-27 14:14:25 <1> pebbles(15973) [Ruby] samba-server/dialogs.rb:356 Setting WINS via DHCP to 'true' returned 'false'
2018-10-27 14:14:25 <1> pebbles(15973) [Ruby] samba-server/dialogs.rb:370 Setting WINS Host Resolution 'false' returned 'true'
2018-10-27 14:14:25 <1> pebbles(15973) [Ruby] samba-server/complex.rb:91 Number of connected users: 0
2018-10-27 14:14:25 <1> pebbles(15973) [Ruby] yast2/systemctl.rb:33 systemctl show nmb.service  --property=Id  --property=MainPID  --property=Description  --property=LoadState  --property=ActiveState  --property=SubState  --property=UnitFileState  --property=FragmentPath  --property=CanReload 
2018-10-27 14:14:25 <1> pebbles(15973) [Ruby] yast2/systemctl.rb:33 systemctl show smb.service  --property=Id  --property=MainPID  --property=Description  --property=LoadState  --property=ActiveState  --property=SubState  --property=UnitFileState  --property=FragmentPath  --property=CanReload 
2018-10-27 14:14:25 <1> pebbles(15973) [Ruby] clients/samba-server.rb:347 Samba-server module finished
2018-10-27 14:14:25 <1> pebbles(15973) [Ruby] clients/samba-server.rb:348 ----------------------------------------
2018-10-27 14:14:25 <1> pebbles(15973) [Interpreter] bin/y2start:58 Called YaST client returned.
2018-10-27 14:14:25 <1> pebbles(15973) [qt-ui] YQUI.cc(uiThreadDestructor):331 Destroying UI thread
2018-10-27 14:14:25 <1> pebbles(15973) [qt-ui] YQUI.cc(~YQUI):314 Closing down Qt UI.
2018-10-27 14:14:25 <1> pebbles(15973) [Y2Ruby] binary/YRuby.cc(~YRuby):117 Shutting down ruby interpreter.
2018-10-27 14:14:25 <1> pebbles(15973) [Y2Perl] YPerl.cc(destroy):164 Shutting down embedded Perl interpreter.
----

Tumbleweed 20181022
yast2-samba-server-4.1.0-1.1.noarch
yast2-samba-client-4.0.2-1.1.noarch
Comment 1 Martin Vidner 2018-10-29 12:27:47 UTC
Thanks for the report!

Please attach the complete YaST logs:
https://en.opensuse.org/openSUSE:Report_a_YaST_bug
Comment 2 john bennett 2018-10-29 19:27:55 UTC
Yes, have found the same with an x86-64 DVD downloaded on 27th Oct 2018.  The version downloaded and installed on 19th Oct 2018 worked fine, Samba settings saved correctly and networking worked fine.  Looks like the Samba GUI has been updated incorrectly and now doesn't save settings to smb.conf.
Comment 3 Martin Vidner 2018-10-30 11:51:36 UTC
Thanks, John.

We still need the YaST logs:
https://en.opensuse.org/openSUSE:Report_a_YaST_bug
Comment 4 john bennett 2018-10-31 09:36:16 UTC
Created attachment 787994 [details]
Yast2 log file in tar format

Hello, 

I've attached the Yast2 log file as requested.  Please note that this was produced on a VirtualBox host machine but the same behaviour occurs on a real installation.
You will see that I have made several attempts, usually trying to change the Hostname to WALKER.
Regards,
John
Comment 5 Luk Crow 2018-11-07 10:25:19 UTC
Recent update to Yast fixed this issue for me.
Comment 6 Arvin Schnell 2018-11-30 10:21:12 UTC
Could be a duplicate of bug #1106876. Can the reporter please test with
yast2-samba-server 4.1.1 and confirm this?
Comment 7 Stefan Brüns 2018-12-01 20:56:59 UTC
1106876 is access restricted ...

At least modifying the usershare settings does work now, haven't tested anything else yet, although it probably works as well.
Comment 8 Arvin Schnell 2018-12-03 08:18:22 UTC
Thanks. Closing as fixed based on comment #7.