Bug 1113162 - Updating Kernel in Tumbleweed creates additional folders in root
Updating Kernel in Tumbleweed creates additional folders in root
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Stefan Dirsch
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-24 17:57 UTC by Nicklas Boman
Modified: 2018-11-12 16:02 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
kernel-default-devel output (27.07 KB, text/plain)
2018-10-25 09:09 UTC, Nicklas Boman
Details
kernel-default-devel without nvidia and nvidia install output (39.66 KB, text/plain)
2018-10-25 10:05 UTC, Nicklas Boman
Details
kernel-manual-triggerrun (28.08 KB, text/plain)
2018-10-25 12:00 UTC, Nicklas Boman
Details
kernel-modules output (6.69 KB, text/plain)
2018-10-25 12:52 UTC, Nicklas Boman
Details
kernel-default-devel and nvidia output (15.17 KB, text/x-log)
2018-10-26 14:09 UTC, Nicklas Boman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicklas Boman 2018-10-24 17:57:05 UTC
Hey, I am running openSUSE Tumbleweed with Nvidia repo (https://download.nvidia.com/opensuse/tumbleweed/)

and since a few weeks back when a "zypper dup" installs a new kernel version, it creates alot of junk folders in / and also changes permissions on /tmp (have below done a 'sudo chmod 1777 /tmp'

this is some of the output after an earlier "zypper dup" https://pastebin.com/yLadB7T8




drwxr-xr-x   3 root root  4096 24 okt 18.33  4.18.15-1-default/
drwxr-xr-x   2 root root  4096 22 okt 23.52  bin/
drwxr-xr-x   4 root root  4096 24 okt 18.36  boot/
drwxr-xr-x   2 root root  4096 24 okt 18.33  config.../
drwxr-xr-x  21 root root  4340 24 okt 18.36  dev/
drwxr-xr-x 150 root root 12288 24 okt 18.37  etc/
drwxr-xr-x   2 root root  4096 24 okt 18.33  GCC/
drwxr-xr-x   2 root root  4096 24 okt 18.33 '(GCC_PLUGINS)'/
drwxr-xr-x   7 root root  4096 22 okt 23.53  home/
drwxr-xr-x   9 root root  4096 24 okt 18.32  lib/
drwxr-xr-x   4 root root  4096 24 okt 18.32  lib64/
drwxr-xr-x   2 root root 16384 22 okt  2017  lost+found/
drwxr-xr-x   4 root root  4096 25 maj 22.22  mnt/
drwxr-xr-x   3 root root  4096 24 okt 18.33 '[N'/
drwxr-xr-x   2 root root  4096 24 okt 18.33 '(NEW)'/
drwxr-xr-x   6 root root  4096 19 okt 20.26  opt/
drwxr-xr-x   2 root root  4096 24 okt 18.33  plugins/
drwxr-xr-x 294 root root     0 23 okt 20.59  proc/
drwxr-xr-x   2 root root  4096 24 okt 18.33  Restart/
drwxr-xr-x  15 root root  4096 23 okt 01.38  root/
drwxr-xr-x  40 root root  1100 24 okt 18.37  run/
drwxr-xr-x   2 root root 12288 24 okt 18.32  sbin/
drwxr-xr-x   2 root root  4096 25 maj 22.22  selinux/
drwxr-xr-x   5 root root  4096 18 sep 23.22  srv/
drwxr-xr-x  13 root root     0 24 okt 18.33  sys/
drwxrwxrwt  33 root root 69632 24 okt 19.50  tmp/
drwxr-xr-x  12 root root  4096  3 aug 23.18  usr/
drwxr-xr-x  11 root root  4096  8 aug 18.02  var/
Comment 1 Michael Andres 2018-10-25 08:25:36 UTC
This is IMO an issue of the kernel package, or some kernel module,... Zypper does not compile/make anything.  Reassigning.
Comment 2 Takashi Iwai 2018-10-25 08:35:41 UTC
Please try to install only kernel package without Nvidia (after removing garbage dirs / files).

It doesn't matter about graphics, but just to know whether it's a kernel package or it's Nvidia stuff that spews garbage.
Comment 3 Nicklas Boman 2018-10-25 09:09:55 UTC
Created attachment 787125 [details]
kernel-default-devel output

Hey, it turns out it is kernel-default-devel who spews
Attached is the output
Comment 4 Takashi Iwai 2018-10-25 09:18:28 UTC
Could you try to uninstall nvidia package and retest?

Judging from the log, it seems happening during the build of Nvidia module.  I guess nvidia package has a trigger script that tries to rebuild the module upon the installation / update of kernel package automatically.
Comment 5 Nicklas Boman 2018-10-25 10:05:54 UTC
Created attachment 787136 [details]
kernel-default-devel without nvidia and nvidia install output

Yeah removing nvidia and reinstalling kernel-default-devel did not create the folders. But then re-installing nvidia created the folders...

Before this i created a reddit post where i was suggested to contact nvidia about this. Did so, but they said that opensuse created the .rpm files for the nvidia drivers?!
Comment 6 Takashi Iwai 2018-10-25 10:14:40 UTC
Stefan, could you check this?
Comment 7 Stefan Dirsch 2018-10-25 11:01:12 UTC
Hmm. I can't reproduce the issue. Nevertheless I believe it's triggered by running the %triggers of nvidia-gfxG05-kmp-default when installing kernel-default-devel. You can extract the %triggers script by running:

  rpm --triggers -q nvidia-gfxG05-kmp-default | tail -n +2 > triggers.sh

Then run it via

  sh ./triggers.sh

My guess is that figuring out the kernel version fails for some reason. Check this

  make -sC /usr/src/linux-obj/x86_64/default kernelrelease

And attach the output. Maybe then I can figure out what's wrong ...
Comment 8 Nicklas Boman 2018-10-25 12:00:28 UTC
Created attachment 787166 [details]
kernel-manual-triggerrun

Sure, see attached. This did not create any folders in root or change permission on /tmp 
but i guess it was not supposed to...
Comment 9 Stefan Dirsch 2018-10-25 12:18:38 UTC
Looks rather good. Only issue I found is:

depmod: ERROR: fstatat(5, nvidia.ko): No such file or directory
depmod: ERROR: fstatat(5, nvidia-modeset.ko): No such file or directory
depmod: ERROR: fstatat(5, nvidia-drm.ko): No such file or directory
depmod: ERROR: fstatat(5, nvidia-uvm.ko): No such file or directory

Seems running 'depmod 4.18.15-1-default' fails for some reason. Could you also provide output of

   find /lib/modules/|grep nvidia | grep -v ethernet
Comment 10 Nicklas Boman 2018-10-25 12:52:42 UTC
Created attachment 787174 [details]
kernel-modules output

ofcourse :)
Comment 11 Stefan Dirsch 2018-10-25 12:59:02 UTC
Thanks. And now 

# ls -l \
/lib/modules/4.18.15-1-default/weak-updates/updates/nvidia.ko \
/lib/modules/4.18.15-1-default/weak-updates/updates/nvidia-modeset.ko \
/lib/modules/4.18.15-1-default/weak-updates/updates/nvidia-drm.ko \
/lib/modules/4.18.15-1-default/weak-updates/updates/nvidia-uvm.ko \
/lib/modules/4.18.15-1-default/updates/nvidia.ko \
/lib/modules/4.18.15-1-default/updates/nvidia-modeset.ko \
/lib/modules/4.18.15-1-default/updates/nvidia-drm.ko \
/lib/modules/4.18.15-1-default/updates/nvidia-uvm.ko
Comment 12 Nicklas Boman 2018-10-25 14:08:28 UTC
Hey now, they are pointing to non-existant destinations it seems

because like this one does not exist : 
/lib/modules/4.18.12-1-default/updates/nvidia-drm.ko



☁  ~  ls -l \
/lib/modules/4.18.15-1-default/weak-updates/updates/nvidia.ko \
/lib/modules/4.18.15-1-default/weak-updates/updates/nvidia-modeset.ko \
/lib/modules/4.18.15-1-default/weak-updates/updates/nvidia-drm.ko \
/lib/modules/4.18.15-1-default/weak-updates/updates/nvidia-uvm.ko \
/lib/modules/4.18.15-1-default/updates/nvidia.ko \
/lib/modules/4.18.15-1-default/updates/nvidia-modeset.ko \
/lib/modules/4.18.15-1-default/updates/nvidia-drm.ko \
/lib/modules/4.18.15-1-default/updates/nvidia-uvm.ko
-rw-r--r-- 1 root root  4907200 25 okt 13.50 /lib/modules/4.18.15-1-default/updates/nvidia-drm.ko
-rw-r--r-- 1 root root 33024448 25 okt 13.50 /lib/modules/4.18.15-1-default/updates/nvidia.ko
-rw-r--r-- 1 root root  1752776 25 okt 13.50 /lib/modules/4.18.15-1-default/updates/nvidia-modeset.ko
-rw-r--r-- 1 root root 40415784 25 okt 13.50 /lib/modules/4.18.15-1-default/updates/nvidia-uvm.ko
lrwxrwxrwx 1 root root       52 25 okt 11.53 /lib/modules/4.18.15-1-default/weak-updates/updates/nvidia-drm.ko -> /lib/modules/4.18.12-1-default/updates/nvidia-drm.ko
lrwxrwxrwx 1 root root       48 25 okt 11.53 /lib/modules/4.18.15-1-default/weak-updates/updates/nvidia.ko -> /lib/modules/4.18.12-1-default/updates/nvidia.ko
lrwxrwxrwx 1 root root       56 25 okt 11.53 /lib/modules/4.18.15-1-default/weak-updates/updates/nvidia-modeset.ko -> /lib/modules/4.18.12-1-default/updates/nvidia-modeset.ko
lrwxrwxrwx 1 root root       52 25 okt 11.53 /lib/modules/4.18.15-1-default/weak-updates/updates/nvidia-uvm.ko -> /lib/modules/4.18.12-1-default/updates/nvidia-uvm.ko
☁  ~
Comment 13 Stefan Dirsch 2018-10-25 14:25:06 UTC
Ok. kernel-default runs weak-updates script in order to create such symlinks. Not sure, why it creates dangling links, but I cannot prevent that. I suggest to remove these dangling links manually. Maybe this is going to improve the situation and it only happened since the %trigger script didn't work on your system. On my system I don't have any weak-updates directories although I've updated my kernel-default/kernel-default-devel packages as well.
Comment 14 Stefan Dirsch 2018-10-26 13:02:59 UTC
(In reply to Stefan Dirsch from comment #13)
> Ok. kernel-default runs weak-updates script in order to create such
> symlinks. 

kernel-default-devel does this, not kernel-default. Sorry.

> Not sure, why it creates dangling links, but I cannot prevent
> that. 

Meanwhile I added the removal of such non-existing symlinks when installing the kmp package, but I still cannot reproduce the issue
with the creation of additional folders below "/" directory.

In case you can still reproduce it, you could try to make the update of kernel-default-devel in rpm verbose mode

  rpm -vv -Uhv kernel-default-devel... &> /tmp/log

and then attach the logfile.

But I'm afraid you need to download the RPM before with zypper

  zypper in -d  kernel-default-devel

and then find it somewhere /var/cache/zypp. :-(
Comment 15 Nicklas Boman 2018-10-26 14:09:52 UTC
Created attachment 787405 [details]
kernel-default-devel and nvidia output

Thanks for your efforts. Its strange that this seems to be mainly me who has this issue, and that you cant reproduce it...

I did like you said and ran the 'rpm -vv' but for the kernel-default-devel it didnt create any folders in / 
So i thought id also try to download the nvidia kmp and do the same with that. 
None of that created any folders, not sure if it was supposed to. Seems to be the 'dracut' that creates them, or when you run 'zypper' that calls dracut.

attached output of rpm -vv for both nvidia-default-devel and nvidia kmp package.
Comment 16 Stefan Dirsch 2018-10-29 11:04:03 UTC
Hmm. I can't see kernel-default-devel running any %trigger script, even no %post scripts. So maybe command just failed. I'm afraid we're getting nowhere here. :-(
Comment 17 Nicklas Boman 2018-10-29 18:55:30 UTC
Well,

Guess i can try to install a VM with Tumbleweed and see if it happens.
But yeah let it go... 

Thanks!
Comment 18 Stefan Dirsch 2018-11-12 16:02:07 UTC
Ok. Closing as WORKSFORME.