Bug 1113123 - Apache2 does no longer load mod_php7 after the last patch update
Apache2 does no longer load mod_php7 after the last patch update
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Apache
Current
x86-64 SUSE Other
: P0 - Crit Sit : Critical (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-24 14:40 UTC by Cesare Dieni
Modified: 2018-11-24 19:36 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cesare Dieni 2018-10-24 14:40:45 UTC
Since the most recent patch for apache2 was installed the httpd fails to load mod_php7 and generates the error described in the section of the log quoted below.

If I remove loading of mod_php7 (a2enmod -d php7) the httpd daemon runs just fine, but obviously none of the php pages are serviced.

My best guess is that a change to check/use threadsafe was made on the apache2 main module however, the mod_php7 module and/or the php7 package were not recompiled with that option.

I understand this is a development distribution, however I would have expected a certain level of QA, at least at the level of "it runs all modules or it does not". My bad if I expect too much.

----
phoenix:~ # rcapache2 start
Job for apache2.service failed because the control process exited with error code.
See "systemctl status apache2.service" and "journalctl -xe" for details.

phoenix:~ # journalctl -xe

Oct 24 10:09:47 phoenix systemd[1]: Starting The Apache Webserver...
-- Subject: Unit apache2.service has begun start-up
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit apache2.service has begun starting up.
Oct 24 10:09:47 phoenix start_apache2[3575]: [Wed Oct 24 10:09:47.355029 2018] [php7:crit] [pid 3575:tid 140090612414464] Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe.  You need to recompile PHP.
Oct 24 10:09:47 phoenix start_apache2[3575]: AH00013: Pre-configuration failed
Oct 24 10:09:47 phoenix systemd[1]: apache2.service: Main process exited, code=exited, status=1/FAILURE
Oct 24 10:09:47 phoenix systemd[1]: apache2.service: Failed with result 'exit-code'.
Oct 24 10:09:47 phoenix systemd[1]: Failed to start The Apache Webserver.
-- Subject: Unit apache2.service has failed
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit apache2.service has failed.
-- 
-- The result is RESULT.
Comment 1 Petr Gajdos 2018-10-24 18:42:54 UTC
I would expect you to use your favorite search engine before filling such bug report, but I would have probably expect too much.

Yes, we are testing php7 Apache HTTPD module during build, search for %check:
https://build.opensuse.org/public/build/devel:languages:php/openSUSE_Factory/x86_64/php7/_log
Comment 2 Cesare Dieni 2018-10-24 22:26:52 UTC
You are kidding me right? You really believe I am such a dumb ass reporting a bug before serching with your favorite search engine (and finding absolutely nothing of useful besides recompiling php), posting the issue on suse forum, breaking my head trying to find a fix for days, and bugging to hell all my friends who have a minimum of knowledge about linux?
Should you do proper regress testing before releasing in incomplete non-functional revision? You are saying you are testing now, well usually the testing should happen earlier. At least that is what I have learned in 30+ years working with IT. But it seems the good old days of software development and quality assurance are over and done....
Comment 3 Cesare Dieni 2018-11-21 14:50:40 UTC
This still has not been fixed, why? Almost one month now...
Comment 4 Petr Gajdos 2018-11-23 07:39:48 UTC
This is not a bug. Please read the php documentation.
Comment 5 Cesare Dieni 2018-11-24 15:05:32 UTC
What you are saying and what the logfile is reporting is conflicting. You say it is not a bug, the log says I need to recompile PHP. Either way, it is a bug. If all you can tell me is to read the documentation, without a hint of what I should be looking for, then you are the bug because you are failing to explain why this is not a bug. Or simply it is a bug because the logfile is reporting misleading information. Do you really expect me to recompile PHP just to use it on Apache2? My guess is not. So I'll keep on reopening this case until you give me some useful information.
Comment 6 Cesare Dieni 2018-11-24 15:58:41 UTC
What you are saying and what the logfile is reporting is conflicting. You say it is not a bug, the log says I need to recompile PHP. Either way, it is a bug. If all you can tell me is to read the documentation, without a hint of what I should be looking for, then you are the bug because you are failing to explain why this is not a bug. Or simply it is a bug because the logfile is reporting misleading information. Do you really expect me to recompile PHP just to use it on Apache2? My guess is not. So I'll keep on reopening this case until you give me some useful informationWhat you are saying and what the logfile is reporting is conflicting. You say it is not a bug, the log says I need to recompile PHP. Either way, it is a bug. If all you can tell me is to read the documentation, without a hint of what I should be looking for, then you are the bug because you are failing to explain why this is not a bug. Or simply it is a bug because the logfile is reporting misleading information. Do you really expect me to recompile PHP just to use it on Apache2? My guess is not. So I'll keep on reopening this case until you give me some useful information
Comment 7 Cesare Dieni 2018-11-24 19:36:18 UTC
Found a workaround, no thanks to you. It was not in the PHP documentation but rather the apache2 documentation. Try to be less concise next time you comment on something you know better than your interlocutor. Not everyone is at your level of knowledge...