Bug 1113001 - Out of date package: openSUSE:Factory/lmms
Out of date package: openSUSE:Factory/lmms
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Enhancement (vote)
: ---
Assigned To: Edgar Aichinger
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-24 03:27 UTC by Sean Lewis
Modified: 2021-10-25 13:48 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Lewis 2018-10-24 03:27:55 UTC
https://build.opensuse.org/package/show/openSUSE:Factory/lmms is out of date. Current upstream is available at: https://github.com/LMMS/lmms/archive/v1.2.0-rc7.tar.gz
Comment 1 Edgar Aichinger 2018-10-25 08:49:31 UTC
The new beta release 1.2.0-rc7 doesn't build currently, just like rc6... that comes from recent fluidsynth-2.0.0 release that isn't API compatible, and packages depending on or using their optional fluidsynth support have to be updated for that, upstream.

This lmms rc7 release doesn't contain a fix yet, but it has been written already and is about to be merged into stable 1.2.0 branch where the releases are drawn from. So I could wait for this pull request to be applied and update lmms to a between-release git checkout, or wait for rc8 release.

Upstream issue: https://github.com/LMMS/lmms/issues/4640

Upstream pull request: https://github.com/LMMS/lmms/pull/4678
Comment 2 Andreas Stieger 2021-10-25 13:48:32 UTC
Factory has lmms 1.2.2 which is current