Bug 1112639 - Python2/Glade crashes with glade file of green-recorder: gtkstyleproviderprivate.c: No such file or directory.
Python2/Glade crashes with glade file of green-recorder: gtkstyleproviderpriv...
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-21 09:35 UTC by Sebastian Wagner
Modified: 2018-11-21 10:26 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Wagner 2018-10-21 09:35:06 UTC
The program green-recorder does currently crash on openSUSE Tumbleweed (but not on other distros) with a Segmentation fault. Trying to find the reason I found out that the crash happens on loading the glade file for the UI. The original file can be seen here: https://github.com/foss-project/green-recorder/blob/master/ui/ui.glade

The crash can be reproduced with a minimal program:

import gi
gi.require_version('Gtk','3.0')
from gi.repository import Gtk, Gdk, GLib
builder = Gtk.Builder()
builder.add_from_file("ui.glade")

This gives a Segmentation fault at the last line. Using gdb I got this:

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff4eec399 in _gtk_style_provider_private_get_settings (provider=0x0) at gtkstyleproviderprivate.c:123
123	gtkstyleproviderprivate.c: No such file or directory.

All that does not happen on Python3.
Comment 1 Sebastian Wagner 2018-11-19 17:36:58 UTC
python-gobject-Gdk is needed -.-
Comment 2 Dominique Leuenberger 2018-11-21 10:26:51 UTC
(In reply to Sebastian Wagner from comment #1)
> python-gobject-Gdk is needed -.-

right - in openSUSE, we split the pygobject package into two pieces, python-gobject and python-gobject-Gdk - allowing also non-gui applications to make use of gobject-introspection without having to pull in a complete X stack.

As green-recorder is not a TW package, there is nothingn for the distro to fix - as such, I'm closing the bug as invalid.