Bug 1112490 - python3-jupyter_ipython incompatible with current python3-prompt_toolkit 2.0.6
python3-jupyter_ipython incompatible with current python3-prompt_toolkit 2.0.6
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-18 21:01 UTC by Sebastian Wagner
Modified: 2018-10-20 20:40 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Wagner 2018-10-18 21:01:17 UTC
python3-prompt_toolkit has now been updated from version 1.0.5 to version 2.0.6, but this breaks python3-jupyter_ipython's (6.5.0-1.1) requirements python3-prompt_toolkit >= 1.0.4, python3-prompt_toolkit < 2 leading to problems with upgrades:

Problem: python3-jupyter_ipython-6.5.0-1.1.noarch requires python3-prompt_toolkit < 2, but this requirement cannot be provided
  deleted providers: python3-prompt_toolkit-1.0.15-3.1.noarch

Related: https://bugzilla.opensuse.org/show_bug.cgi?id=1101981 (downgrade of python3-prompt_toolkit)
https://bugzilla.opensuse.org/show_bug.cgi?id=1103013 (same bug a while ago)
Comment 1 Todd R 2018-10-20 20:40:44 UTC
An updated version of python3-jupyter_ipython has already been accepted into openSUSE:Factory.