Bug 1112464 - after 20181015 and kernel 4.18.13-1-default nouveau fails to start secondary screen on Nvidia quadro
after 20181015 and kernel 4.18.13-1-default nouveau fails to start secondar...
Status: RESOLVED WORKSFORME
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
x86-64 openSUSE Factory
: P3 - Medium : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-18 17:14 UTC by Philippe Condé
Modified: 2018-11-11 09:08 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
monitor definition (1.12 KB, text/plain)
2018-10-18 17:14 UTC, Philippe Condé
Details
device configuration (614 bytes, text/plain)
2018-10-18 17:15 UTC, Philippe Condé
Details
Screens definition (590 bytes, text/plain)
2018-10-18 17:15 UTC, Philippe Condé
Details
log X11 (48.45 KB, text/plain)
2018-10-18 17:17 UTC, Philippe Condé
Details
output of xrandr --query --verbose (17.35 KB, text/plain)
2018-10-18 19:34 UTC, Philippe Condé
Details
dmesg output (100.68 KB, text/plain)
2018-10-18 21:03 UTC, Philippe Condé
Details
Quadro dual DVI 10de:00f8 xorg.conf, xrandr, xdpyinfo & inxi w/ 1920x1200 & 1280x1024 displays (1.51 KB, text/plain)
2018-10-19 09:43 UTC, Felix Miata
Details
list of packages instalaled snapshot 20181015 (41.01 KB, text/plain)
2018-10-19 19:03 UTC, Philippe Condé
Details
systemsettings monitors setup (55.80 KB, image/png)
2018-11-03 12:14 UTC, Philippe Condé
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Condé 2018-10-18 17:14:26 UTC
Created attachment 786462 [details]
monitor definition

Hello,

I have a HP proliant with a video card nvidia quadro K4200 (GK104GL).
I have two screens one on the DVI-1 port (primary) and the other on the DP-1 port (secondary).
Both screen works at 1920*1080
I have defined a logical screen 3840*1080 
In /etc/X11/xorg.conf.d I have updated the 50-device.conf, 50-screen.conf and 50-monitor.conf files.
This worked perfectly since three year
Now I have only the DVI-1 working. The DP-1 wake up on login but don't display
anything and after some seconds display "No signal"
in the /var/log/Xorg.0.log I have warning
[    52.685] (WW) NOUVEAU(0): Option "Monitor-DVI" is not used
[    52.686] (WW) NOUVEAU(0): Option "Monitor-DP1" is not used
[    52.686] (WW) NOUVEAU(0): Option "Preferred Mode" is not used
[    52.686] (WW) NOUVEAU(0): Option "RightOf" is not used


these data are coming from my 50-xxx.conf files
I attach the Xorg.0.log and the 50-xxxxx.conf files

Many thanks in advance
Philippe
Comment 1 Philippe Condé 2018-10-18 17:15:17 UTC
Created attachment 786463 [details]
device configuration
Comment 2 Philippe Condé 2018-10-18 17:15:56 UTC
Created attachment 786464 [details]
Screens definition
Comment 3 Philippe Condé 2018-10-18 17:17:02 UTC
Created attachment 786465 [details]
log X11
Comment 4 Philippe Condé 2018-10-18 19:34:48 UTC
Created attachment 786474 [details]
output of xrandr --query --verbose
Comment 5 Takashi Iwai 2018-10-18 20:11:29 UTC
Is it really a kernel regression?  I'm asking this since you entered the component Kernel.

That is, if you boot with the previous kernel, does it start working again?
Comment 6 Philippe Condé 2018-10-18 20:43:10 UTC
hello,

I tried the two preceding kernels but the same problem occurs.which I find strange. In the snapshot I don't see anything related to Xorg. Only the kernel is new; a

The problem is present even during the boot:
during the boot the video setting of the screen changes
- before installation of snapshot 20181015 the second monitor started and displayed the same things as the primary monitor.
-  Now I see that the secondary monitor wakes up but don't display nothing ; After some seconds it displays " Display port No signal" and sleeps

same behaviour when I login in KDE: second monitor wakes up , displays nothing and after some seconds goes to sleep

Starting system settings ==> maintain screen ==> I see the two monitors but unable to activate the second 

Regards
Philippe
Comment 7 Philippe Condé 2018-10-18 21:03:07 UTC
Created attachment 786481 [details]
dmesg output
Comment 8 Philippe Condé 2018-10-18 21:04:17 UTC
I have see error in journalctl and also in dmesg

Oct 18 21:17:21 hpprol2 kernel: nouveau 0000:0a:00.0: disp: outp 03:0006:0f42: link rate unsupported by sink
Oct 18 21:17:21 hpprol2 kernel: nouveau 0000:0a:00.0: disp: outp 03:0006:0f42: training failed
Oct 18 21:17:23 hpprol2 kernel: nouveau 0000:0a:00.0: disp: outp 03:0006:0f42: link rate unsupported by sink
Oct 18 21:17:23 hpprol2 kernel: nouveau 0000:0a:00.0: disp: outp 03:0006:0f42: training failed


I have attached the dmesg output

Regards
Philippe
Comment 9 Takashi Iwai 2018-10-19 08:21:00 UTC
Could you check the cables?  Basically if you can't reproduce with the previous kernels, it means something else -- either software or hardware.
Comment 10 Felix Miata 2018-10-19 09:43:02 UTC
Created attachment 786522 [details]
Quadro dual DVI 10de:00f8 xorg.conf, xrandr, xdpyinfo & inxi w/ 1920x1200 & 1280x1024 displays

With kernel 4.12.14-lp150-12.22 both displays work as expected on vttys and Xorg (KDE3). When I try to use a 2560x1080 instead of the right side 1280x1024, both light up at POST and remain so booting to multi-user.target, but the 2560x1080 usually gets put to sleep as X starts, and won't light back up until a full power down/power up restart. Sometimes it lights back up on Ctrl-Alt-F2 or when exiting X back to a vtty. Without the full power down, it produces display error beeps instead of POSTing. A couple of times after first started cold, X worked on both displays instead of the 2560x1080 irretrievably going to sleep. I could occasionally see the mouse pointer goto the right edge of the left display before the right display blanked.

When I try to use xf86v-video-nouveau instead of Xorg's modesetting, the PC locks up hard trying to start X:
[    37.518] (EE) AIGLX error: dlopen of /usr/lib64/dri/nouveau_dri.so failed (/usr/lib64/dri/nouveau_dri.so: cannot open shared object file: No such file or directory)
[    37.518] (EE) AIGLX: reverting to software rendering
Comment 11 Felix Miata 2018-10-19 11:24:18 UTC
TW20181015/4.18.13-1 on same PC is even worse. X locks up the PC quickly with xf86-video-nouveau installed. Without, it takes a bit longer, filling the 1920x1200 screen with raster and putting 2560x1080 screen to sleep as it locks up:
# journalctl -b -1 | tail -n16
Oct 19 07:12:32 big31 systemd[954]: Reached target Basic System.
Oct 19 07:12:32 big31 systemd[954]: Reached target Default.
Oct 19 07:12:32 big31 systemd[954]: Startup finished in 241ms.
Oct 19 07:12:32 big31 systemd[1]: Started User Manager for UID 0.
Oct 19 07:12:32 big31 login[864]: pam_unix(login:session): session opened for user root by LOGIN(uid=0)
Oct 19 07:12:32 big31 login[864]: ROOT LOGIN ON tty3
Oct 19 07:12:40 big31 kernel: nouveau 0000:01:00.0: DRM: 0xCF20: Parsing digital output script table
Oct 19 07:12:40 big31 kernel: nouveau 0000:01:00.0: DRM: 0xCF20: Parsing digital output script table
Oct 19 07:12:41 big31 kernel: nouveau 0000:01:00.0: DRM: 0xCF2E: Parsing digital output script table
Oct 19 07:13:58 big31 systemd[1]: display-manager.service: Start operation timed out. Terminating.
Oct 19 07:13:58 big31 systemd[1]: display-manager.service: Failed with result 'timeout'.
Oct 19 07:13:58 big31 systemd[1]: Failed to start X Display Manager.
Oct 19 07:13:58 big31 systemd[1]: Reached target Graphical Interface.
Oct 19 07:13:58 big31 systemd[1]: Starting Update UTMP about System Runlevel Changes...
Oct 19 07:13:58 big31 systemd[1]: Started Update UTMP about System Runlevel Changes.
Oct 19 07:13:58 big31 systemd[1]: Startup finished in 1.254s (kernel) + 12.408s (initrd) + 2min 26.296s (userspace) = 2min 39.960s.
Comment 12 Philippe Condé 2018-10-19 13:10:51 UTC
Hello,

there is no problem with the cables.I already checked this.
what I forget to sauy is that after the first raboot after installation snapshot 20181015 the problem occured. i checked in /etc/x11/xorg.conf.d and found 
 50-xxxxx.conf 
and 50-xxxx.conf.rpmsave
I saw that the *rpmsave files were my old 50-xxx.conf files and I copied it on the 50-xxx.conf files but this didn't help even after reboot

Regards
Philippe
Comment 13 Takashi Iwai 2018-10-19 13:16:34 UTC
(In reply to Philippe Condé from comment #12)
> Hello,
> 
> there is no problem with the cables.I already checked this.
> what I forget to sauy is that after the first raboot after installation
> snapshot 20181015 the problem occured. i checked in /etc/x11/xorg.conf.d and
> found 
>  50-xxxxx.conf 
> and 50-xxxx.conf.rpmsave
> I saw that the *rpmsave files were my old 50-xxx.conf files and I copied it
> on the 50-xxx.conf files but this didn't help even after reboot

Hrm, but this implies that some X-related packages have been updated?
Since the older kernels show the same behavior, I strongly doubt that it's rather a user-space problem.

So, please double-check which packages have been updated from zypper log.

In anyway, I reassign this to X guys.
Comment 14 Stefan Dirsch 2018-10-19 14:11:59 UTC
(In reply to Philippe Condé from comment #4)
> Created attachment 786474 [details]
> output of xrandr --query --verbose

Looks good. DP-1 monitor is right of DVI-I-1 monitor. DP-2 is disconnected.
Comment 15 Stefan Dirsch 2018-10-19 14:14:57 UTC
I suggest to try without your xorg.conf.d snippets first.
Comment 16 Philippe Condé 2018-10-19 19:03:34 UTC
Created attachment 786593 [details]
list of packages instalaled snapshot 20181015
Comment 17 Philippe Condé 2018-10-19 19:13:52 UTC
hello,

I have attached the list of package installed with snapshot 20181015.

I have removed the 50-device.conf, 50-screen.conf and 50-monitor.conf
I then rebooted the system.
Same symptoms.
the secondary monitor wakes up, display nothing and after some seconds display "Display port no data"
it wakes up 
- during the boot when the display mode changes (starting nouveau?)
- when starting sddm
- when login
- when I wakes up the primary monitor using the mouse
- when some programs are loaded (Yast, systemsettings...)

without the 50-xxx.conf files nouveau is still started
hpprol2:/var/log # lsmod | grep nouveau
nouveau              2174976  15
video                  45056  1 nouveau
mxm_wmi                16384  1 nouveau
wmi                    28672  2 mxm_wmi,nouveau
i2c_algo_bit           16384  1 nouveau
drm_kms_helper        196608  1 nouveau
ttm                   126976  1 nouveau
drm                   471040  18 drm_kms_helper,ttm,nouveau
button                 16384  1 nouveau

Regards
Philippe
Comment 18 Stefan Dirsch 2018-10-22 10:33:44 UTC
Hmm. The only relevant userspace package would be libdrm.
Comment 19 Philippe Condé 2018-10-22 14:35:19 UTC
hello,
If libdrm gives this problem this should explain that it occurs now also with the older kernels

Regards
Philippe
Comment 20 Stefan Dirsch 2018-10-22 14:49:07 UTC
(In reply to Philippe Condé from comment #19)
> hello,
> If libdrm gives this problem this should explain that it occurs now also
> with the older kernels

Yes, but only *IF* ...
Comment 21 Philippe Condé 2018-10-24 15:55:15 UTC
Hello,

I have observed that when I change to a virtual console 1 (alt-ctrl-f1)this generate an error 
Oct 24 17:21:52 hpprol2 kernel: nouveau 0000:0a:00.0: disp: outp 03:0006:0f42: link rate unsupported by sink
Oct 24 17:21:52 hpprol2 kernel: nouveau 0000:0a:00.0: disp: outp 03:0006:0f42: training failed
Oct 24 17:21:53 hpprol2 kernel: nouveau 0000:0a:00.0: disp: outp 03:0006:0f42: link rate unsupported by sink
Oct 24 17:21:53 hpprol2 kernel: nouveau 0000:0a:00.0: disp: outp 03:0006:0f42: training failed
same when I go back to the VT7

there is also a delay (black screen) of 1 or 2 second before the change to VTx occurs

Regards
Philippe
Comment 22 Philippe Condé 2018-10-31 05:13:13 UTC
Hello,

I installed snapshot 20181029 today. It included again libdrm(2.4.96-1.1 ) and a new kernel 4.18.15-1-default.

After reboot the same problem is still present.
Is there something that I can do to help determining this problem?

Many thanks in advance
Philippe
Comment 23 Stefan Dirsch 2018-10-31 11:17:05 UTC
Ok. If it's really a userspace thing, which I doubt, you could uninstall unneeded packages:

libdrm_amdgpu1
libdrm_amdgpu1-32bit
libdrm_intel1
libdrm_intel1-32bit
 libdrm_radeon1
 libdrm_radeon1-32bit

Then downgrade to the following packages  of the original TW ISO - if still available:

libdrm-devel
libdrm2
libdrm2-32bit
libdrm_nouveau2
libdrm_nouveau2-32bit
libkms1
Comment 24 Philippe Condé 2018-11-01 06:34:24 UTC
hello,

I have this iso "openSUSE-Tumbleweed-DVD-x86_64-Snapshot20181001-Media.iso" but therein I cannot find 
- libkms1 
- libdrm_nouveau2-32bit
- libdrm2-32bit

in Yast I see that I can remove libkms1 because this package has no more dependencies.

I'm a bit afraid to break the system installing only the 3 others.
Do you think that I can do it?

Regards
Philippe
Comment 25 Stefan Dirsch 2018-11-01 12:53:37 UTC
Ok. If these packages do not exist on the TW ISO we cannot verify, whether the regression came with the update of libdrm. If using original Kernel from the TW ISO does not help, I can't explain the regression either. :-(
Comment 26 Philippe Condé 2018-11-02 15:47:24 UTC
Hello,

I forced the installation of
libdrm2 version 2.4.93-1.1
libdrm_nouveau2 2.4.93-1.1
I removed libkms1

Rebooted in the oldest kernel 4.18.9 but the problem is still present.

So DRM is probably not involved.
What can I now do?
many thanks in advance
Philippe
Comment 27 Stefan Dirsch 2018-11-03 09:10:16 UTC
I'm sorry. I have no explanation for this change in behaviour then. One possible option would be to switch to NVIDIA drivers ...
Comment 28 Philippe Condé 2018-11-03 12:13:03 UTC
hello,

I never used de proprietary driver but I'll have a look but I known that with Tumbleweed it can be difficult.

now some additional remarks
the nvidia quadro 4200P has 3 outputs 
- 1 DVI 
- 2 display ports DP1 and DP2
only 2 can be simultaneously active DVI and one of the DP
If I run systemsettings5 ==>display and monitors it displays the 2 monitors. I switched DP1 and DP2 and they are correctly recognized: See screenshot systemsetting.png

Hardware info also identifies correctly the monitors. 

In the journalctl I searched all occurrences about nouveau and drm during the boot and I see that the error occurs vey soon in the boot
as  far as I understand it 
- The card is recognized by nouveau, 
- some initialization are set for DRM
- drm starts
- fbcon starts  nd immeditely thereafter the first error occur 
Here under all the lines found in journalctl

Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: NVIDIA GK104 (0e4340a2)
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: bios: version 80.04.fe.00.07
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: fb: 4096 MiB GDDR5
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: VRAM: 4096 MiB
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: GART: 1048576 MiB
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: TMDS table version 2.0
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: DCB version 4.0
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: DCB outp 00: 01000f02 00020030
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: DCB outp 01: 02000f00 00000000
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: DCB outp 03: 02822fa6 0f420010
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: DCB outp 04: 02022f62 00020010
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: DCB outp 05: 04833fb6 0f420010
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: DCB outp 06: 04033f72 00020010
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: DCB conn 00: 00001030
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: DCB conn 02: 00002246
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: DCB conn 03: 00010346
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: DCB conn 04: 00000460
Nov 02 16:36:49 hpprol2 kernel: [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
Nov 02 16:36:49 hpprol2 kernel: [drm] Driver supports precise vblank timestamp query.
Nov 02 16:36:49 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: MM: using COPY for buffer copies
Nov 02 16:36:50 hpprol2 kernel: nouveau 0000:0a:00.0: DRM: allocated 1920x1080 fb: 0xa0000, bo 00000000e20f3def
Nov 02 16:36:50 hpprol2 kernel: fbcon: nouveaufb (fb0) is primary device

Nov 02 16:36:50 hpprol2 kernel: nouveau 0000:0a:00.0: disp: outp 03:0006:0f42: link rate unsupported by sink


Regards
Philippe
Comment 29 Philippe Condé 2018-11-03 12:14:22 UTC
Created attachment 788335 [details]
systemsettings monitors setup
Comment 30 Philippe Condé 2018-11-10 14:43:48 UTC
Hello,

I installed Nvidia hard way and could configure the two monitors. they are working with the default kernel .but I cannot have it working with the Xen kernel.

In Xorg.0.log I have this error

[    54.448] (EE) NVIDIA(0): Failed to allocate software rendering cache surface: out of
[    54.448] (EE) NVIDIA(0):     memory.
[    54.448] (EE) NVIDIA(0):  *** Aborting ***
[
so the card and the monitor are working.

Regards
Philippe
Comment 31 Philippe Condé 2018-11-11 09:08:03 UTC
Hello,

Problem with nouveau is solved.

I installed the Nvidia proprietary driver. I needed to update the Xorg.conf because Nvidia set the second monitor as disabled (nvidia-settings) after multiple restart the second monitor worked.
But Nvidia doesn't work with the Xen kernel and I have some VM that I need.

So I uninstalled the Nvidia proprietary driver and re-enabled nouveau.
After Reboot the second monitor worked. I needed only to restore the desktop configuration which has changed. 
Cannot explain what solved the problem

Thanks for your help
Philippe