Bug 1112389 - GCC8 cannot build Libreoffice on ppc64
GCC8 cannot build Libreoffice on ppc64
Status: RESOLVED FIXED
: 1148374 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Richard Biener
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-18 13:30 UTC by Michal Suchanek
Modified: 2022-03-22 13:06 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Suchanek 2018-10-18 13:30:58 UTC
https://build.opensuse.org/public/build/home:michals/openSUSE_Factory_PowerPC/ppc64/libreoffice/_log

[ 3934s] [build CXX] desktop/source/offacc/acceptor.cxx
[ 3934s] S=/home/abuild/rpmbuild/BUILD/libreoffice-6.1.2.1 && I=$S/instdir && W=$S/workdir &&  mkdir -p $W/CxxObject/desktop/source/offacc/ $W/Dep/CxxObject/desktop/source/offacc/ && cd /home/abuild/rpmbuild/BUILD/libreoffice-6.1.2.1 &&    g++ -DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED -DCPPU_ENV=gcc3 -DENABLE_LTO -DLINUX -DNDEBUG -DOSL_DEBUG_LEVEL=0 -DPOWERPC64 -DPPC -DUNIX -DUNX -D_PTHREADS -D_REENTRANT   -flto=6 -fuse-linker-plugin -O2 -fvisibility=hidden    -Wall -Wno-missing-braces -Wnon-virtual-dtor -Wendif-labels -Wextra -Wundef -Wunreachable-code -Wunused-macros -finput-charset=UTF-8 -fmessage-length=0 -fno-common -pipe  -Wduplicated-cond -Wlogical-op -Wshift-overflow=2 -Wunused-const-variable=1 -Wno-cast-function-type -fvisibility-inlines-hidden -fstack-protector-strong -fPIC -Wshadow -Woverloaded-virtual -std=gnu++14   -DEXCEPTIONS_ON -fexceptions -fno-enforce-eh-specs -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -flifetime-dse=1   -DLIBO_INTERNAL_ONLY  -c $S/desktop/source/offacc/acceptor.cxx -o $W/CxxObject/desktop/source/offacc/acceptor.o  -I$S/include  -I/usr/lib64/jvm/java/include -I/usr/lib64/jvm/java/include/linux -I$S/config_host  -I$W/UnoApiHeadersTarget/udkapi/normal -I$W/UnoApiHeadersTarget/offapi/normal   
[ 3935s] /usr/lib64/gcc/powerpc64-suse-linux/8/../../../../powerpc64-suse-linux/bin/ld: /home/abuild/rpmbuild/BUILD/libreoffice-6.1.2.1/instdir/sdk/lib/libuno_cppuhelpergcc3.so: undefined reference to `LTHUNK76.lto_priv.966'
[ 3935s] /usr/lib64/gcc/powerpc64-suse-linux/8/../../../../powerpc64-suse-linux/bin/ld: /home/abuild/rpmbuild/BUILD/libreoffice-6.1.2.1/instdir/sdk/lib/libuno_cppuhelpergcc3.so: undefined reference to `LTHUNK68.lto_priv.699'
[ 3935s] /usr/lib64/gcc/powerpc64-suse-linux/8/../../../../powerpc64-suse-linux/bin/ld: /home/abuild/rpmbuild/BUILD/libreoffice-6.1.2.1/instdir/sdk/lib/libuno_cppuhelpergcc3.so: undefined reference to `LTHUNK79.lto_priv.967'
[ 3935s] /usr/lib64/gcc/powerpc64-suse-linux/8/../../../../powerpc64-suse-linux/bin/ld: /home/abuild/rpmbuild/BUILD/libreoffice-6.1.2.1/instdir/sdk/lib/libuno_cppuhelpergcc3.so: undefined reference to `LTHUNK2.lto_priv.806'
[ 3935s] /usr/lib64/gcc/powerpc64-suse-linux/8/../../../../powerpc64-suse-linux/bin/ld: /home/abuild/rpmbuild/BUILD/libreoffice-6.1.2.1/instdir/sdk/lib/libuno_cppuhelpergcc3.so: undefined reference to `LTHUNK9.lto_priv.997'
[ 3935s] /usr/lib64/gcc/powerpc64-suse-linux/8/../../../../powerpc64-suse-linux/bin/ld: /home/abuild/rpmbuild/BUILD/libreoffice-6.1.2.1/instdir/sdk/lib/libuno_cppuhelpergcc3.so: undefined reference to `LTHUNK1.lto_priv.807'
[ 3935s] /usr/lib64/gcc/powerpc64-suse-linux/8/../../../../powerpc64-suse-linux/bin/ld: /home/abuild/rpmbuild/BUILD/libreoffice-6.1.2.1/instdir/sdk/lib/libuno_cppuhelpergcc3.so: undefined reference to `LTHUNK78.lto_priv.970'
[ 3935s] /usr/lib64/gcc/powerpc64-suse-linux/8/../../../../powerpc64-suse-linux/bin/ld: /home/abuild/rpmbuild/BUILD/libreoffice-6.1.2.1/instdir/sdk/lib/libuno_cppuhelpergcc3.so: undefined reference to `LTHUNK10.lto_priv.830'
Comment 1 Michael Matz 2018-10-19 12:11:01 UTC
That's proper ppc64 (not ppc64le), right?  In that case we aren't really interested anymore from a SUSE perspective.  But seemingly something in the
necessary thunking on ppc64 interacts badly with LTO, probably something for
upstream to resolve if anyone _there_ is interested.
Comment 2 Michal Suchanek 2018-10-19 12:31:46 UTC
yes, it seems to break in BE only.
Comment 3 Richard Biener 2018-10-19 12:36:25 UTC
IIRC I've seen upstream bugs like this, eventually already fixed.
Comment 4 Martin Liška 2018-10-25 08:30:39 UTC
Hm, I took a look at GCC's bugzilla and I can't find a related issue which would contain 'lto_priv' keyword...
Comment 5 Fabian Vogt 2019-08-27 14:26:05 UTC
*** Bug 1148374 has been marked as a duplicate of this bug. ***
Comment 6 Richard Biener 2022-03-22 13:06:17 UTC
No longer relevant, tumbleweed is using GCC 11 now.