Bug 1112189 - interdiff leaves temporary files after quit
interdiff leaves temporary files after quit
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Development
Current
Other Other
: P3 - Medium : Minor (vote)
: ---
Assigned To: Stefan Dirsch
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-17 13:15 UTC by Takashi Iwai
Modified: 2019-04-09 14:08 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
0001-crypto-ccp-Introduce-the-AMD-Secure-Processor-device.patch (29.80 KB, patch)
2018-10-17 13:27 UTC, Stefan Dirsch
Details | Diff
10-crypto-ccp-introduce-the-amd-secure-processor-device.patch (27.95 KB, patch)
2018-10-17 13:28 UTC, Stefan Dirsch
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Takashi Iwai 2018-10-17 13:15:55 UTC
When some error happens, interdiff seems leaving the whole temporary files in /tmp/interdiff*.

For example, running interdiff for the two patches below will leave lots of temporary files:

% interdiff -p1 FILE1 FILE2
....
1 out of 9 hunks FAILED -- saving rejects to file /tmp/interdiff-1.CDizcJ.rej
interdiff: Error applying patch1 to reconstructed file

% ls /tmp/interdiff*
/tmp/interdiff-1.bhtc7Z.orig  /tmp/interdiff-1.ffy6Rx.orig
/tmp/interdiff-1.CDizcJ       /tmp/interdiff-1.PnWVtD.orig
/tmp/interdiff-1.CDizcJ.orig  /tmp/interdiff-2.AOEV8u
/tmp/interdiff-1.CDizcJ.rej

Although this might be seen as a feature, many files there are garbage, and don't contain paths in *.rej files, so fairly useless.

BTW, running "interdiff FILE1 FILE2" and "interdiff FILE2 FILE1" give completely different results.
Comment 1 Stefan Dirsch 2018-10-17 13:26:25 UTC
At least one can get rid of .orig files by setting POSIXLY_CORRECT environment variable.
Comment 2 Stefan Dirsch 2018-10-17 13:27:41 UTC
Created attachment 786263 [details]
0001-crypto-ccp-Introduce-the-AMD-Secure-Processor-device.patch
Comment 3 Stefan Dirsch 2018-10-17 13:28:01 UTC
Created attachment 786264 [details]
10-crypto-ccp-introduce-the-amd-secure-processor-device.patch
Comment 4 Stefan Dirsch 2018-10-19 12:36:46 UTC
I'm not yet convinced that the issue is resolvable at all in theory ... low priority.
Comment 5 Stefan Dirsch 2019-04-09 14:08:14 UTC
(In reply to Stefan Dirsch from comment #4)
> I'm not yet convinced that the issue is resolvable at all in theory ... low priority.
> BTW, running "interdiff FILE1 FILE2" and "interdiff FILE2 FILE1" give completely different results.

Abou this. I'm facing reality. It's very unlikely I will ever work on this and I still believe it's not really fixable completely. In order to get rid of the temporary files see my comment#1.

--> WONTFIX