Bug 1112158 - hawk2 rpms differ between builds
hawk2 rpms differ between builds
Status: RESOLVED DUPLICATE of bug 1112159
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: High Availability
Current
Other openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: SUSE Linux Enterprise High Availability Team
E-mail List
:
Depends on:
Blocks: 1047218
  Show dependency treegraph
 
Reported: 2018-10-17 10:31 UTC by Bernhard Wiedemann
Modified: 2018-10-17 10:41 UTC (History)
1 user (show)

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Wiedemann 2018-10-17 10:31:17 UTC
While working on reproducible builds for openSUSE, I found that
hawk2 rpms differ between builds
even when trying to build it as similar as possible, I get such diffs:

/var/lib/hawk/tmp/cache/assets/sprockets/v3.0/zi/ziNohlQ6aKL19UhK8SNna2ec3gzWMjn6i19aLaSMWbI.cache differs at offset '2973' (data)
@@ -1,3 +1,3 @@
 00000b80  33 32 34 39 32 33 64 38  37 64 31 33 64 62 06 3b  |324923d87d13db.;|
-00000b90  06 46 3a 0a 6d 74 69 6d  65 6c 2b 07 da cb c2 5b  |.F:.mtimel+....[|
+00000b90  06 46 3a 0a 6d 74 69 6d  65 6c 2b 07 2c cc c2 5b  |.F:.mtimel+.,..[|

from embedded mtime values (likely of files updated during build)

Additionally, there are files renamed or missing.
All under the subdir of /var/lib/hawk/tmp/cache/assets/sprockets/v3.0/

Some of these files are identified as "zlib compressed data"
so uncompressing could give further insight.

These files are created by running in the 
/home/abuild/rpmbuild/BUILD/hawk2-2.1.0+git.1536166588.e5ab7e32/hawk/ dir:
bin/rake assets:precompile


The only other package, that has sprocket-related indeterminism is velum,
but there it looks different.
Comment 1 Bernhard Wiedemann 2018-10-17 10:41:10 UTC
filed twice because of bugzilla server bug (out of memory in sendmail)

*** This bug has been marked as a duplicate of bug 1112159 ***