Bug 1112108 - [Build 20181015] openQA test fails trying to write to serial device /dev/ttyS0 as root with "Input/output error" - agetty failed in background
[Build 20181015] openQA test fails trying to write to serial device /dev/ttyS...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kernel
Current
Other Other
: P5 - None : Major (vote)
: ---
Assigned To: E-mail List
E-mail List
https://openqa.opensuse.org/tests/775...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-17 07:27 UTC by Oliver Kurz
Modified: 2019-11-01 07:06 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: Yes
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Kurz 2018-10-17 07:27:22 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-gnuhealth@64bit fails in
[gnuhealth_install](https://openqa.opensuse.org/tests/775786/modules/gnuhealth_install/steps/5)
on the command `whoami > /dev/ttyS0` as root .

in https://openqa.opensuse.org/tests/775786/file/gnuhealth_install-journal.log it says

```
Oct 17 02:12:09 susetest agetty[1849]: /dev/ttyS0: not a tty
```

and then later

```
Oct 17 02:12:19 susetest systemd[1]: serial-getty@ttyS0.service: Service RestartSec=100ms expired, scheduling restart.
Oct 17 02:12:19 susetest systemd[1]: serial-getty@ttyS0.service: Scheduled restart job, restart counter is at 1.
Oct 17 02:12:19 susetest Stopped Serial Getty on ttyS0.
Oct 17 02:12:19 susetest systemd[1]: Started Serial Getty on ttyS0.
```

so a lot of stuff going on regarding ttyS0 and also it is not exactly new: https://openqa.opensuse.org/tests/763584#step/gnuhealth_install/5 from 18 days ago


## Reproducible

Fails since (at least) Build [20181015](https://openqa.opensuse.org/tests/775239)


## Expected result

Last good: [20180815](https://openqa.opensuse.org/tests/734371/)
we can consider ourselves lucky that there was a bug a bit later in the test 2 months ago because we have the journal file showing that there is no problem (or I could not find one): https://openqa.opensuse.org/tests/734371/file/gnuhealth_install-journal.log , there is just

```
Aug 16 18:26:39 susetest systemd[1]: Started Serial Getty on ttyS0.
```

no further message.


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?distri=opensuse&machine=64bit&version=Tumbleweed&arch=x86_64&flavor=DVD&test=gnuhealth)
Comment 1 Jiri Slaby 2019-06-07 08:16:08 UTC
Wasn't it the known tty_reopen problem already fixed? Could it still be reproduced?
Comment 2 Oliver Kurz 2019-06-07 14:21:06 UTC
(In reply to Jiri Slaby from comment #1)
> Wasn't it the known tty_reopen problem already fixed?

can you please be a bit more specific about the "known tty_reopen" problem? Can you reference a change that has been made? Any other bug or a SR?

> Could it still be reproduced?

Hard to say. The tests are currently very stable after we apply a lot of workarounds, e.g. as visible in https://openqa.opensuse.org/tests/951653#step/gnuhealth_install/19 after we masked the getty service on ttyS0 and such.

If you say what would make sense we could adapt the openQA test and run it (many times) to see if the original problem would still be present.
Comment 3 Jiri Slaby 2019-06-20 09:39:32 UTC
The commit is:
commit d3736d82e8169768218ee0ef68718875918091a0
Author: Dmitry Safonov <dima@arista.com>
Date:   Wed Jan 9 01:17:40 2019 +0000

    tty: Don't hold ldisc lock in tty_reopen() if ldisc present

It was part of 4.20.4 in tumbleweed. Anything newer should not expose the bug I mentioned above.

It may make sense to enable the tests again.
Comment 4 Oliver Kurz 2019-07-15 17:11:08 UTC
ok so I have created https://progress.opensuse.org/issues/54293 to plan for removing the workarounds for at least openSUSE Tumbleweed with the more recent kernel. It is planned to provide the results as feedback in this bug then.
Comment 5 Jiri Slaby 2019-11-01 07:06:40 UTC
When you have the results and they are negative, feel free to reopen.