Bug 1111977 - systemctl unmask packagekit.service: Failed to unmask unit: Connection timed out
systemctl unmask packagekit.service: Failed to unmask unit: Connection timed out
Status: RESOLVED WONTFIX
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
PowerPC-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: openSUSE GNOME
E-mail List
https://openqa.opensuse.org/tests/774...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-16 09:13 UTC by Michel Normand
Modified: 2020-10-16 06:30 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
consoletest_finish-journal.log (328.64 KB, text/x-log)
2018-10-17 14:29 UTC, Michel Normand
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Normand 2018-10-16 09:13:31 UTC
systemctl unmask packagekit.service: Failed to unmask unit: Connection timed out at the end of yast2_ncurses openQA test on ppc64le.


## Observation

openQA test in scenario opensuse-Tumbleweed-DVD-ppc64le-yast2_ncurses@ppc64le fails in
[consoletest_finish](https://openqa.opensuse.org/tests/774714/modules/consoletest_finish/steps/5)


## Reproducible

Fails since (at least) Build [20181002](https://openqa.opensuse.org/tests/766188)


## Expected result

Last good: [20180928](https://openqa.opensuse.org/tests/763962) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?distri=opensuse&machine=ppc64le&version=Tumbleweed&arch=ppc64le&flavor=DVD&test=yast2_ncurses)
Comment 1 Michel Normand 2018-10-17 14:29:48 UTC
Created attachment 786283 [details]
consoletest_finish-journal.log

* I analysed two OpenQA uploaded files and identified 4 hours differences
  probably because one at UTC the other one at UTC-4hours
  autoinst-log.txt at UTC time
  consoletest_finish-journal.log at UTC-4hours
* from autoinst-log.txt
  * unmask requested at [2018-10-16T03:26:11.0039 UTC]
  * unmask failure   at [2018-10-16T03:26:45.0364 UTC]
  * export_logs      at [2018-10-16T03:26:45.0365 UTC]
* From consoletest_finish-journal.log
  * packagekit lines from Oct 15 22:23:42 to Oct 15 22:43:15
  * No packagekit line at Oct 15 23.26 (03:26 UTC-4hours) time of unmask request
  * ROOT LOGIN ON tty5 at Oct 15 23:26:55 when export_logs started

* I do not know how to investigate the reported timed out from uploaded log.
  Any suggestion ?
Comment 2 Michel Normand 2018-10-19 07:43:29 UTC
Problem identified in snapshot 20181015 seems to vanish on two succcessive ones:
20181017 https://openqa.opensuse.org/tests/776706#step/consoletest_finish/3
20181018 https://openqa.opensuse.org/tests/777794#step/consoletest_finish/3 

So returned bug as works for me.
Comment 3 Michel Normand 2018-11-16 12:41:15 UTC
a random failure ?
as back on 20181116 snapshot

https://openqa.opensuse.org/tests/798470#step/consoletest_finish/5

a manual retry on same snapshot, passed with no timed out
https://openqa.opensuse.org/tests/799182#step/consoletest_finish/5


still do not know how to investigate
Comment 4 Michel Normand 2019-01-09 15:05:00 UTC
also failing for Leap15.1 on yast2_ncurses test:
https://openqa.opensuse.org/tests/827264#step/consoletest_finish/5
Comment 5 Héctor Orón Martínez 2020-10-16 06:30:11 UTC
Please reopen if you are still affected by this issue.