Bug 1111443 - [Build 20181009] openQA tests fail in various x11 based test modules: Message "Automatic suspend" about inactivity does not disappear, showing a notice about pending due to inactivity while the machine is being used actively
[Build 20181009] openQA tests fail in various x11 based test modules: Message...
Status: NEW
: 1112616 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
https://openqa.opensuse.org/tests/770...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-10 19:26 UTC by Fabian Vogt
Modified: 2018-10-22 13:45 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Vogt 2018-10-10 19:26:05 UTC
## Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-zdup-13.1-gnome@64bit fails in
[sshxterm](https://openqa.opensuse.org/tests/770897/modules/sshxterm/steps/6)


## Reproducible

Fails since (at least) Build [20180926](https://openqa.opensuse.org/tests/762302)


## Expected result

Last good: [20180925](https://openqa.opensuse.org/tests/761507) (or more recent)


## Further details

Always latest result in this scenario: [latest](https://openqa.opensuse.org/tests/latest?version=Tumbleweed&test=zdup-13.1-gnome&machine=64bit&arch=x86_64&distri=opensuse&flavor=NET)
Comment 1 Oliver Kurz 2018-10-20 19:44:59 UTC
From duplicate report https://bugzilla.opensuse.org/show_bug.cgi?id=1112616

## Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-zdup-13.1-gnome@64bit fails in
[evolution](https://openqa.opensuse.org/tests/778772/modules/evolution/steps/2)
with a popup notice about "Automatic suspend" due to inactivity while the machine is being used actively. This disrupts the window detection in the openQA tests.


## Expected result

The notice about "Automatic suspend" should go away when there is active input to the system as in the openQA tests.
Comment 2 Oliver Kurz 2018-10-20 19:45:57 UTC
*** Bug 1112616 has been marked as a duplicate of this bug. ***
Comment 3 Dominique Leuenberger 2018-10-22 13:45:06 UTC

The message appears after the VM has been reset to 'last good snapshot' - and the '
In jobs where no restore of snapshot happens, this message does not show up. After the restore, time obviously must make a jump to get from the 'snapshotted time to the current time' (but the jumps are not big - yet, the watchdog is skipped a few times