Bug 1111420 - krunner doesn't show results in some openQA tests
krunner doesn't show results in some openQA tests
Status: RESOLVED FIXED
: 1112641 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KDE Workspace (Plasma)
Current
Other Other
: P1 - Urgent : Normal (vote)
: ---
Assigned To: E-Mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-10 15:15 UTC by Fabian Vogt
Modified: 2018-12-09 06:15 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Vogt 2018-10-10 15:15:38 UTC
In some openQA tests, krunner fails to list results.

This might be caused either by a performance issue or in this case by a caching issue as the applications were just installed before:
https://openqa.opensuse.org/tests/770553#step/gimp/19
https://openqa.opensuse.org/tests/770559#step/kate/19
Comment 2 Dominique Leuenberger 2018-11-06 09:48:28 UTC
This is currently amongst the most prominent random failures seen on o3 while testing Tumbleweed
Comment 3 Dominique Leuenberger 2018-11-15 11:56:19 UTC
Raising prio - since it is one of the two most common failures in staging - usually cured by rerunning the tests
Comment 4 Fabian Vogt 2018-11-18 14:12:24 UTC
Turns out there is a 10s delay between the inotify event and the sycoca rebuild.

I submitted a patch to kded reducing it to 1s, let's see what happens.
Comment 5 Fabian Vogt 2018-11-18 17:12:33 UTC
*** Bug 1112641 has been marked as a duplicate of this bug. ***
Comment 6 Fabian Vogt 2018-11-22 12:37:17 UTC
So far no failure again - so FIXED for now.