Bug 1111342 - Backport fix for dnsmasq into Tumbleweed (add permission to open log files)
Backport fix for dnsmasq into Tumbleweed (add permission to open log files)
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: AppArmor
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Christian Boltz
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-10 09:37 UTC by Petr Vorel
Modified: 2019-03-29 23:38 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Vorel 2018-10-10 09:37:15 UTC
There is an AppArmor fix for dnsmasq:
https://gitlab.com/apparmor/apparmor/commit/025c7dc6a131da24c31e41ad32753015a0ec0f76
I'm going to backport it into obs.
Comment 1 Petr Vorel 2018-10-10 10:25:45 UTC
Created submit request id 640981.
Comment 2 Christian Boltz 2018-10-10 18:52:34 UTC
SR 641132 sent to Factory.

For Leap, I'll submit updated packages as soon as the upstream provides maintenance releases - shouldn't take too long ;-)
Comment 3 Swamp Workflow Management 2018-10-11 08:48:45 UTC
This is an autogenerated message for OBS integration:
This bug (1111342) was mentioned in
https://build.opensuse.org/request/show/641133 Factory / apparmor
Comment 4 Petr Vorel 2018-10-11 13:04:25 UTC
(In reply to Christian Boltz from comment #2)
> For Leap, I'll submit updated packages as soon as the upstream provides
> maintenance releases - shouldn't take too long ;-)
OK, thanks :)
Comment 5 Petr Vorel 2018-12-11 11:44:27 UTC
Pattern changed in
3ef8df6ac dnsmasq: Adjust pattern for log files to comply SELinux

Planning to backport it + add one more commit:
49848b908 dnsmasq: Add pid file used by NetworkManager
Comment 6 Petr Vorel 2018-12-11 13:33:49 UTC
Christian Boltz is expecting new upstream release (2.13.2) soon.
It's probably better to wait for it (see https://build.opensuse.org/request/show/657171#comments)
Comment 7 Christian Boltz 2018-12-21 14:40:51 UTC
Updated packages for Tumbleweed are on their way (SR 660561), Leap updates will follow in the next days.
Comment 8 Swamp Workflow Management 2018-12-21 15:10:10 UTC
This is an autogenerated message for OBS integration:
This bug (1111342) was mentioned in
https://build.opensuse.org/request/show/660561 Factory / apparmor
Comment 9 Swamp Workflow Management 2018-12-22 16:30:16 UTC
This is an autogenerated message for OBS integration:
This bug (1111342) was mentioned in
https://build.opensuse.org/request/show/660711 Factory / apparmor
Comment 10 Swamp Workflow Management 2019-01-07 17:50:15 UTC
This is an autogenerated message for OBS integration:
This bug (1111342) was mentioned in
https://build.opensuse.org/request/show/663397 15.0 / apparmor
Comment 14 Swamp Workflow Management 2019-01-24 00:08:40 UTC
SUSE-RU-2019:0151-1: An update that has 7 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1082956,1097370,1100779,1111342,1117354,1119937,1120472
CVE References: 
Sources used:
SUSE Linux Enterprise Module for Server Applications 15 (src):    apparmor-2.12.2-7.9.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (src):    apparmor-2.12.2-7.9.1
SUSE Linux Enterprise Module for Basesystem 15 (src):    apparmor-2.12.2-7.9.1, libapparmor-2.12.2-7.9.1
Comment 15 Christian Boltz 2019-03-29 23:38:34 UTC
Manually pasting the update info - one SLE 15 update for AppArmor didn't make it to Leap because of a regression, and the update released yesterday only listed the changes since the SLE-only update in the patchinfo.


openSUSE-RU-2019:1063-1: An update that has two recommended fixes can now be installed.

Category: recommended (important)
Bug References: 1123820,1127073
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    apparmor-2.12.2-lp150.6.11.2, libapparmor-2.12.2-lp150.6.11.2