Bug 1111047 - haveged crashes regular on openSUSE Kubic
haveged crashes regular on openSUSE Kubic
Status: RESOLVED FIXED
: 1115950 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Major (vote)
: ---
Assigned To: Otto Hollmann
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-08 11:33 UTC by Thorsten Kukuk
Modified: 2022-03-04 08:02 UTC (History)
10 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
core.haveged (5.95 MB, application/x-core)
2018-10-08 11:33 UTC, Thorsten Kukuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Kukuk 2018-10-08 11:33:18 UTC
Created attachment 785324 [details]
core.haveged

haveged crashes regular on openSUSE Kubic, maybe because of the read-only root filesystem?  I don't see this crashes on the tumbleweed installations at the same code level.

Core was generated by `@usr/sbin/haveged -w 1024 -v 0 -F'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007f5b60190d5d in havege_rng (h=0x5654533144b0, 
    buffer=<optimized out>, sz=134217701) at havege.c:239
239     havege.c: No such file or directory.
(gdb) back
#0  0x00007f5b60190d5d in havege_rng (h=0x5654533144b0, 
    buffer=<optimized out>, sz=134217701) at havege.c:239
#1  0x00005654527120fd in run_daemon (argv=0x7fffadef9c78, 
    path=0x565453314260 "@usr/sbin/haveged", h=0x5654533144b0) at haveged.c:633
#2  main (argc=<optimized out>, argv=0x7fffadef9c78) at haveged.c:468
Comment 1 Sean Lewis 2018-10-14 18:22:11 UTC
I see similar segfault issues with haveged on Tumbleweed x86_64 (20181008 snapshot): 

[ 6718.571105] haveged[174]: segfault at 5614dfb6e000 ip 00007f252cc04d5d sp 00007fff84ae81e0 error 6 in libhavege.so.1.1.0[7f252cc04000+15000]
Comment 2 Richard Brown 2018-10-15 16:20:43 UTC
I cant reproduce this on Kubic 1002, 1009, or Tumbleweed 1009

Is it still happening for you?
Comment 3 Thorsten Kukuk 2018-10-15 17:30:05 UTC
Last crash was today (todays snapshot not applied yet). So yes, it's still crashing.
Comment 4 Sean Lewis 2018-10-16 05:50:44 UTC
I'm still seeing this as well, upgraded to TW 20181012 snapshot on X86_64:

[10148.687196] haveged[176]: segfault at 55f269a88000 ip 00007f40aa4f0d5d sp 00007ffecf208ba0 error 6 in libhavege.so.1.1.0[7f40aa4f0000+15000]
Comment 5 Richard Brown 2018-10-16 14:46:12 UTC
Without changing anything I'm seeing it on my Kubic machines now..so I guess I can reproduce it.. so please ignore Comment #3
Comment 6 Fabian Vogt 2019-07-03 09:25:51 UTC
Happens very often on JeOS as well. A restart of haveged works most of the time.

Adding maintainers to CC.
Comment 7 Andreas Schwab 2019-07-25 08:36:48 UTC
*** Bug 1115950 has been marked as a duplicate of this bug. ***
Comment 8 Andreas Schwab 2019-07-25 08:39:02 UTC
That looks like a race condition, get_poolsize being called while /proc isn't mounted yet, so it returns -1.
Comment 9 Andreas Schwab 2019-07-25 09:03:42 UTC
Probably the dependencies of haveged-switch-root.service need to be fixed so that it is started after /proc is mounted.
Comment 10 Kristyna Streitova 2021-03-26 18:57:13 UTC
Hello, is this still an issue with the latest Tumbleweed/Kubic/JeOS? Thanks!
Comment 13 Otto Hollmann 2022-02-23 16:21:50 UTC
I updated haveged to version 1.9.17, tested with Tumbleweed/Kubic and I'm unable to reproduce it. So if there will be no objections, I will close this bug next Friday.
Comment 14 Otto Hollmann 2022-03-04 08:02:29 UTC
Closing this bug.