Bug 1110985 - TW Plasma Intel driver random freezes
TW Plasma Intel driver random freezes
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: X.Org
Current
x86-64 openSUSE Factory
: P5 - None : Major with 1 vote (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-07 21:22 UTC by S. B.
Modified: 2020-02-27 14:40 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
hwinfo (476.25 KB, text/plain)
2018-10-07 21:22 UTC, S. B.
Details
hwinfo-pvince81 (368.30 KB, text/plain)
2018-12-03 21:02 UTC, Vincent Petry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description S. B. 2018-10-07 21:22:11 UTC
Hi, I use Plasma (currently 5.13) on Tumbleweed on a reliable Thinkpad T530 laptop with integrated Intel graphics. (Attaching hwinfo)

I am experiencing random freezes of the Plasma desktop. The mouse still moves, but no response from clicking anywhere. I tried killing the Plasma shell related processes in a virtual terminal, but it doesn't help. It's completely random, but happens several times a day and results in lost work.

I suspect that this is due to a bug in the Xorg Intel driver. I have not tried the fixes yet, such as switching from SNA to UXA acceleration. First I want to try switching the KWin compositor from openGL to Xrender, which I just now did. If that doesn't help, I'll probably just uninstall the Intel driver and use Xmodesetting.

These are probably related bugs, but from Leap:
- https://bugzilla.opensuse.org/show_bug.cgi?id=945444
- https://bugzilla.opensuse.org/show_bug.cgi?id=1014999
- https://bugzilla.opensuse.org/show_bug.cgi?id=1047716
Comment 1 S. B. 2018-10-07 21:22:50 UTC
Created attachment 785280 [details]
hwinfo
Comment 2 S. B. 2018-10-07 21:23:53 UTC
I should have mentioned that this is a fresh install of Tumbleweed with Plasma. Before on this same laptop I was using Tumbleweed with the Cinnamon desktop and the Intel driver (SNA accel) with zero stability issues.
Comment 3 Stefan Dirsch 2018-10-08 11:36:32 UTC
Ok. This is still Ivybridge. Since you said yourself this still worked on TW previously using the Intel SNA driver, it would be worth a try to install
xf86-video-intel package on your freshly installed TW. If this doesn't help, this looks like a regression in the kernel driver.

Or with Plasma we now have completely different requirements for the desktop WRT 3D acceleration, so trying to use Cinnamon desktop again might be the first option.
Comment 4 S. B. 2018-10-08 12:15:01 UTC
Hi, thanks a lot for the reply.

Sorry I wasn't clear, this bug report for random freezing is with my fresh TW installation, using Plasma and the xf86-video-intel driver with SNA.

Just to show that it's not a fundamentally buggy machine, I mentioned that previously I was running TW on it with the **Cinnamon** desktop and the xf86-video-intel driver with SNA.

I originally would have filed this as a Plasma bug, since the only difference appears to be in the desktop environment. But I've researched and asked around a lot, and the general opinion appears to be that Plasma's way of using the video card makes it more likely to run into an underlying Xorg Intel driver bug. Here are some links:
- https://tech.slashdot.org/story/15/08/06/1336251/kde-plasma-5-problem-traced-to-bug-in-intel-graphics-driver
- https://forum.kde.org/viewtopic.php?t=127575
- https://forums.opensuse.org/showthread.php/526313-Plasma-5-Intel-Graphics-Leap-42-3
- https://forum.manjaro.org/t/kde-plasma-desktop-freezing/34855
- https://forums.opensuse.org/showthread.php/526608-KDE-Freezes-randomly-and-only-the-mouse-pointer-works
Comment 5 S. B. 2018-10-08 12:19:26 UTC
I should also mention that I ran the same TW with Cinnamon installation on this laptop for a long time, like 3 years, and I just did the fresh TW install with Plasma a few days ago. It's my daily driver computer.
Comment 6 Stefan Dirsch 2018-10-08 12:27:17 UTC
Well. In that case you may also try modesetting/GLAMOR, i.e. uninstall xf86-video-intel package.
Comment 7 Stefan Dirsch 2018-10-19 12:24:45 UTC
So did you give it a try?
Comment 8 S. B. 2018-10-19 12:32:38 UTC
Since my last post here, I've been running the Intel driver still, but with the Plasma compositor using the Xrender backend. It's looking tentatively much more stable. I'll switch it back to the openGL backend soon to see if it starts freezing again.
Comment 9 Stefan Dirsch 2018-10-25 13:30:12 UTC
(In reply to S. B. from comment #8)
> Since my last post here, I've been running the Intel driver still, but with
> the Plasma compositor using the Xrender backend. It's looking tentatively
> much more stable. I'll switch it back to the openGL backend soon to see if
> it starts freezing again.

Ok. Any news you can share with us on this topic?
Comment 10 S. B. 2018-10-25 14:01:25 UTC
(In reply to Stefan Dirsch from comment #9)
> (In reply to S. B. from comment #8)
> > Since my last post here, I've been running the Intel driver still, but with
> > the Plasma compositor using the Xrender backend. It's looking tentatively
> > much more stable. I'll switch it back to the openGL backend soon to see if
> > it starts freezing again.
> 
> Ok. Any news you can share with us on this topic?

Sorry, not yet, as I was busy with some important work that I couldn't risk losing to a freeze. I just now switched the compositor to openGL again, and I'll report back here immediately if it freezes on me.
Comment 11 S. B. 2018-10-28 18:13:19 UTC
(In reply to S. B. from comment #10)
> I've been running the Intel driver still, but with
> the Plasma compositor using the Xrender backend. 
> It's looking tentatively > > > much more stable. I'll
> switch it back to the openGL backend soon to see if
> it starts freezing again.

Ok, I just now had a freeze with the openGL 2.0 backend, and I had to kill Xorg to recover. Looks like it's the same as the references I linked in #c4, something about the way Kwin uses openGL exposes an underlying flaw in the Intel driver.
Comment 12 Stefan Dirsch 2018-10-29 10:35:03 UTC
Ok, so no good news. But nevertheless thanks for giving it a try!
Comment 13 S. B. 2018-10-29 12:44:11 UTC
(In reply to Stefan Dirsch from comment #12)
> Ok, so no good news. But nevertheless thanks for giving it a try!

Also thanks to you for looking into it. Please let me know if you need any more information.
Comment 14 Vincent Petry 2018-12-03 21:00:05 UTC
I've been experiencing similar freezes recently. Desktop stays visible, mouse can move, music continues playing as normal, but no interaction possible.
No CPU load on X11 nor kwin.

Just now I managed to restore my desktop by going to a virtual terminal, searching for the kwin_x11 process and killing it with `kill -9` then restarting it with `kwin_x11 --replace`. I also killed plasmashell and restarted it the same way. No lost work fortunately, for once.

It started happening after I reinstalled Tumbleweed about a month ago.

Hardware is Dell XPS 13 9333 with Intel driver (I'll attach hwinfo).
Compositor is on openGL 3.1.

This is without any workarounds. Before the reinstall, the desktop was stable.

S.B. did you try switching to UXA yet ? I might try that next as I think I had it before the reinstall. I also remember having worse performance with UXA with Youtube which is why I didn't reenable it yet.
Comment 15 Vincent Petry 2018-12-03 21:02:14 UTC
Created attachment 791658 [details]
hwinfo-pvince81

More info about my setup:

i+ | intel-gpu-tools     | package | 1.23-2.1                       | x86_64 | openSUSE-Tumbleweed-Oss
i+ | intel-vaapi-driver  | package | 2.2.0-1.1                      | x86_64 | openSUSE-Tumbleweed-Oss
i+ | libdrm_intel1       | package | 2.4.96-1.1                     | x86_64 | openSUSE-Tumbleweed-Oss
i+ | libdrm_intel1-32bit | package | 2.4.96-1.1                     | x86_64 | openSUSE-Tumbleweed-Oss
i+ | libvulkan_intel     | package | 18.1.7-208.1                   | x86_64 | openSUSE-Tumbleweed-Oss
i+ | ucode-intel         | package | 20180807a-1.1                  | x86_64 | openSUSE-Tumbleweed-Oss
i+ | xf86-video-intel    | package | 2.99.917+git8674.25c9a2fcc-1.1 | x86_64 | openSUSE-Tumbleweed-Oss


Plasma is 5.14.3-1.1
Comment 16 Stefan Dirsch 2019-02-26 14:08:17 UTC
S. B., could you check whether things improved with latest kernels from 

  https://en.opensuse.org/openSUSE:Kernel_of_the_day

Try with intel and modesetting driver, please.
Comment 17 S. B. 2019-03-05 23:28:41 UTC
(In reply to Stefan Dirsch from comment #16)
> S. B., could you check whether things improved with latest kernels from 
> 
>   https://en.opensuse.org/openSUSE:Kernel_of_the_day
> 
> Try with intel and modesetting driver, please.


Hi, sorry for the delay. I usually have to run VirtualBox for my work, so it's kind of difficult to use a different kernel version. With the standard TW kernel currently at 4.20.12-1-default, I experience relatively frequent (a few times during the workday) problems with xf86-video-intel and Kwin openGL compositing where only the mouse moves but nothing is clickable.
Comment 18 Stefan Dirsch 2019-03-06 01:20:35 UTC
Ok. So no improvements. :-( Thanks for testing nevertheless!
Comment 19 Stefan Dirsch 2020-02-26 17:32:42 UTC
Any new results you could provide with Leap 15.1, Leap 15.2-Beta or Tumbleweed?
Comment 20 S. B. 2020-02-27 14:01:39 UTC
Hi Stefan, I'm going to cautiously say that it is much better now. On my main Tumbleweed + Plasma workstation, I switch back and forth between Intel and Xmodesetting, and I'm currently on Intel. It seems to be behaving pretty well, so I'll close this bug for now. I'll re-open it if anything else comes up. Thanks for the help!
Comment 21 Stefan Dirsch 2020-02-27 14:40:43 UTC
Thanks a lot for the positive feedback! :-)