Bug 1110822 - Tumbleweed 20181001 libkdexoauth2 conflict
Tumbleweed 20181001 libkdexoauth2 conflict
Status: IN_PROGRESS
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Upgrade Problems
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Luca Beltrame
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-04 20:52 UTC by Tom Wroblewski
Modified: 2018-10-11 07:50 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Wroblewski 2018-10-04 20:52:38 UTC
During zypper dup a file conflict appeared:
File /usr/lib64/sas12/libkdexoauth2.so.3.0.0
  from install of
     sas12-kdexoauth2-18.08.1-2.1.x86_64 (openSUSE-Tumbleweed-Oss)
  conflicts with file from package
     sas12-kdexoauth2-3-18.08.1-1.1.x86_64 (@System)

I have 2 tumbleweed installs, notice came up on both. My experimental box was used to say yes to continue, and, it seemed to wipe my Firefox Master Password.  I don't know if this conflict was the actual cause or not, but, before I run it on my active machine, I would like your opinion.   

Resolving the problem was as easy as copying the .mozilla folder from another machine.  I also noticed that my first entry into chrome required me to reset the KDE Wallet password. I haven't noticed any other authorization issues yet.

Zypper.log is over 11 mb, if that would help, I will attach it.  I'm looking for direction.  

Thank You.
Comment 1 Wolfgang Bauer 2018-10-04 22:56:23 UTC
You can safely ignore this.
The package sasl2-kdexoauth2-3 has been renamed to sasl2-kdexoauth2, but zypper apparently didn't uninstall the former and both contain the same files (you could uninstall sasl2-kdexoauth2-3 manually if you want though).

Will be fixed by the update to 18.08.2 at the latest.

And no, this cannot possibly affect Firefox, it's only used by kmail for gmail authentification.
Comment 2 Wolfgang Bauer 2018-10-05 08:02:02 UTC
FTR, this submit to Factory/Tumbleweed should get rid of the libkdexoauth2 file conflict:
https://build.opensuse.org/request/show/640000

But as mentioned, this file conflict is harmless and cannot cause any problems.
Your mentioned issues must be caused by something else.
Comment 3 Tom Wroblewski 2018-10-05 12:32:24 UTC
Thank you for the responses.

Subsequent updates did not cause problems. I should have looked at what libkdexoauth2 was used for before panicking when I saw oauth in its name.
Comment 4 Christian Boltz 2018-10-06 14:41:26 UTC
From your SR:

 Version:        18.08.1
...
 Provides:       sasl2-kdexoauth2-3 = %{version}
-Obsoletes:      sasl2-kdexoauth2-3 < %{version}
+Obsoletes:      sasl2-kdexoauth2-3 <= %{version}

IMHO it would be a good idea to change this to

    Obsoletes:      sasl2-kdexoauth2-3 <= 18.08.1

with a fixed version number instead of %{version}.

(Using %{version} is not terribly bad, so there's no need to replace the pending SR - doing it with the next version update is enough.)

Just for completeness:    Provides:       sasl2-kdexoauth2-3 = %{version}
is correct as is.