Bug 1110266 - zsh: invalid syntax for command-not-found
zsh: invalid syntax for command-not-found
Status: RESOLVED DUPLICATE of bug 1109896
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Basesystem
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Ismail Dönmez
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-01 05:01 UTC by Marguerite Su
Modified: 2018-10-01 07:15 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marguerite Su 2018-10-01 05:01:07 UTC
Hi

With zsh 5.6.2 (x86_64-suse-linux-gnu) and TW 20180920 I experienced this:

$ CD ..
  File "/usr/bin/command-not-found", line 15
    print(file=sys.stderr)
              ^
SyntaxError: invalid syntax

And it didn't occur with bash(so our /usr/bin/command-not-found is good)

After adding this line to my .zshrc, everything works again.

unfunction command_not_found_handler

So something in zsh's command_not_found_handler implementation is broken.

Marguerite
Comment 1 Marguerite Su 2018-10-01 05:01:48 UTC
Assigned to Ismail
Comment 2 Andreas Stieger 2018-10-01 07:15:25 UTC
looks like a dup

*** This bug has been marked as a duplicate of bug 1109896 ***