Bug 1107798 - Fails to update the last python2-appdirs/python3-appdirs in Tumbleweed
Fails to update the last python2-appdirs/python3-appdirs in Tumbleweed
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P2 - High : Normal (vote)
: ---
Assigned To: Matej Cepl
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-10 08:16 UTC by Max Lin
Modified: 2020-05-15 12:25 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Max Lin 2018-09-10 08:16:45 UTC
With the last change in python-appdirs https://build.opensuse.org/request/show/633233 , upgrade to current Tumbleweed from Leap 15.0 fails to work due to python3-appdirs install failed.

2018-09-08 10:11:00 <5> install(3439) [zypp] Exception.cc(log):166 RpmDb.cc(doInstallPackage):2093 THROW:    Subprocess failed. Error: RPM failed: error: unpacking of archive failed on file /usr/lib/python3.6/site-packages/appdirs-1.4.3-py3.6.egg-info: cpio: File from package already exists as a directory in system
2018-09-08 10:11:00 <5> install(3439) [zypp] Exception.cc(log):166 error: python3-appdirs-1.4.3-2.1.noarch: install failed 
2018-09-08 10:11:00 <5> install(3439) [zypp] Exception.cc(log):166 error: python3-appdirs-1.4.3-lp150.1.6.noarch: erase skipped
2018-09-08 10:11:00 <5> install(3439) [zypp] Exception.cc(log):166 
2018-09-08 10:11:01 <0> install(3439) [Pkg] Callbacks.YCP.cc(evaluate):240 Evaluating callback (registered funciton: ruby_reference)
2018-09-08 10:11:01 <0> install(3439) [Ruby] binary/Yast.cc(ycp_module_call_ycp_function):282 Dynamic Proxy: [UI::WidgetExists] with [5] params 
2018-09-08 10:11:01 <0> install(3439) [Ruby] binary/Yast.cc(ycp_module_call_ycp_function):291 Namespace created from UI
2018-09-08 10:11:01 <0> install(3439) [ui] YUINamespace.cc(createFunctionCall):1035 overloaded WidgetExists, 2@46
2018-09-08 10:11:01 <0> install(3439) [Ruby] binary/Yast.cc(ycp_module_call_ycp_function):326 Call WidgetExists
2018-09-08 10:11:01 <0> install(3439) [Ruby] binary/Yast.cc(ycp_module_call_ycp_function):332 Append parameter `progressCurrentPackage
2018-09-08 10:11:01 <0> install(3439) [ui] YUINamespace.cc(finishParameters):915 Actual type: <unspec> (symbol)
2018-09-08 10:11:01 <0> install(3439) [ui] YUINamespace.cc(finishParameters):932 Candidate: boolean WidgetExists (symbol) MATCH: 0
2018-09-08 10:11:01 <1> install(3439) [Ruby] modules/PackageCallbacks.rb:455 DonePackage(error: 3, reason: 'Subprocess failed. Error: RPM failed: error: unpacking of archive failed on file /usr/lib/python3.6/site-packages/appdirs-1.4.3-py3.6.egg-info: cpio: File from package already exists as a directory in system
error: python3-appdirs-1.4.3-2.1.noarch: install failed 
error: python3-appdirs-1.4.3-lp150.1.6.noarch: erase skipped
')
Comment 1 Max Lin 2018-09-10 08:18:26 UTC
The failure on openQA https://openqa.opensuse.org/tests/751252#step/await_install/5 , you can check yast log there.
Comment 2 Max Lin 2018-09-10 09:03:19 UTC
Also breaks Tumbleweed upgrade case from old -> current https://openqa.opensuse.org/tests/751693
Comment 3 Ludwig Nussel 2018-09-10 09:17:59 UTC
Was not a good idea to remove that code:

https://build.opensuse.org/package/rdiff/devel:languages:python/python-appdirs?linkrev=base&rev=10

Note if the package with this change to submitted to other SLE products those submissions need to be stopped ASAP to prevent further damage.
Comment 4 Tomáš Chvátal 2018-09-10 09:33:14 UTC
(In reply to Ludwig Nussel from comment #3)
> Was not a good idea to remove that code:
> 
> https://build.opensuse.org/package/rdiff/devel:languages:python/python-
> appdirs?linkrev=base&rev=10
> 
> Note if the package with this change to submitted to other SLE products
> those submissions need to be stopped ASAP to prevent further damage.

Not really, the problem is that the setuptools dep was reverted without puting back the egginfo conversion, setuptools handle it properly yet the distutils from python itself do not.
Comment 5 Swamp Workflow Management 2018-09-10 12:00:07 UTC
This is an autogenerated message for OBS integration:
This bug (1107798) was mentioned in
https://build.opensuse.org/request/show/634722 Factory / python-appdirs
Comment 6 Tomáš Chvátal 2020-05-15 12:25:59 UTC
As per bot fix for this was included.