Bug 1107793 - Cannot run firewall module
Cannot run firewall module
Status: RESOLVED DUPLICATE of bug 1106319
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
Other Other
: P5 - None : Major (vote)
: ---
Assigned To: Markos Chandras
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-10 07:21 UTC by Marco Varlese
Modified: 2018-09-10 09:38 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Varlese 2018-09-10 07:21:33 UTC
As soon as executing the firewall application (part of the Yast2 modules)  I get the following error:

Execution of command "[["/usr/bin/firewall-config"]]" failed. Exit code: 1 Error output: Traceback (most recent call last): File "/usr/bin/firewall-config", line 8093, in <module> app = FirewallConfig() File "/usr/bin/firewall-config", line 1386, in __init__ self.connection_changed() File "/usr/bin/firewall-config", line 1692, in connection_changed self.update_active_zones() File "/usr/bin/firewall-config", line 2464, in update_active_zones connection, zone ]) File "/usr/lib64/python3.6/site-packages/gi/overrides/Gtk.py", line 1245, in append return self._do_insert(parent, -1, row) File "/usr/lib64/python3.6/site-packages/gi/overrides/Gtk.py", line 1237, in _do_insert row, columns = self._convert_row(row) File "/usr/lib64/python3.6/site-packages/gi/overrides/Gtk.py", line 876, in _convert_row result.append(self._convert_value(cur_col, value)) File "/usr/lib64/python3.6/site-packages/gi/overrides/Gtk.py", line 894, in _convert_value return GObject.Value(self.get_column_type(column), value) File "/usr/lib64/python3.6/site-packages/gi/overrides/GObject.py", line 218, in __init__ self.set_value(py_value) File "/usr/lib64/python3.6/site-packages/gi/overrides/GObject.py", line 274, in set_value (py_value, type(py_value))) ValueError: Expected string but got False<class 'bool'>
Comment 1 Marco Varlese 2018-09-10 07:22:30 UTC
As a matter of completion, the TW version where I am facing the issue is "20180903"
Comment 2 Arvin Schnell 2018-09-10 09:34:46 UTC
Assigning to maintainer of firewall-config.
Comment 3 Markos Chandras 2018-09-10 09:38:09 UTC
This is a duplicate of #1106319

*** This bug has been marked as a duplicate of bug 1106319 ***