Bug 1107777 - Can't connect to wifi network after suspend (not always)
Can't connect to wifi network after suspend (not always)
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Network
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Fabian Vogt
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-10 01:49 UTC by Igor Kuznetsov
Modified: 2019-03-25 04:41 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
hwinfo from fujitsu lifebook s7110 (326.83 KB, text/plain)
2018-10-27 01:37 UTC, Igor Kuznetsov
Details
iwconfig from fujitsu lifebook s7710 (315 bytes, text/plain)
2018-10-27 01:38 UTC, Igor Kuznetsov
Details
journalctl -f from fujitsu lifebook s7110 (3.55 KB, text/plain)
2018-10-27 01:39 UTC, Igor Kuznetsov
Details
hwinfo from toshiba tecra z40b (776.63 KB, text/plain)
2018-10-27 01:39 UTC, Igor Kuznetsov
Details
iwconfig from toshiba tecra z40b (316 bytes, text/plain)
2018-10-27 01:40 UTC, Igor Kuznetsov
Details
journalctl -f from toshiba tecra z40b (20.93 KB, text/plain)
2018-10-27 01:40 UTC, Igor Kuznetsov
Details
networkmanager log while it happen again (100.75 KB, text/plain)
2018-11-01 17:18 UTC, Igor Kuznetsov
Details
journalctl -l -a -S today (1.25 MB, text/plain)
2018-11-09 17:00 UTC, Igor Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Kuznetsov 2018-09-10 01:49:24 UTC
Sometimes after suspend can't connect to wifi network. All wi-fi networks is listed, but can't connect.

had try nmcli network off ; nmcli network on
and systemctl restart network.service, but this is did not help.
Comment 1 Zejin Xu 2018-10-24 09:27:54 UTC
Hi Igor,

Is this still happening? If so, could you please attach some logs while the issue is happening? If you felt confused, you could get the logs via commands like 'hwinfo', 'journalctl -f', 'iwconfig'. For more guidance on attaching the needed log, please reference to this document.

Thanks
Comment 2 Igor Kuznetsov 2018-10-27 01:37:05 UTC
sending the files from two laptops. today it is happen on toshiba tecra z40b on tumbleweed 64bit, yesterday it is happen on fujitsu lifebook s7110 on tumbleweed 32bit. Sending hwinfo iwconfig and journalctl -f (try to connect, try to powerdown wifi, powerup wifi and try to connect again)
Comment 3 Igor Kuznetsov 2018-10-27 01:37:59 UTC
Created attachment 787459 [details]
hwinfo from fujitsu lifebook s7110
Comment 4 Igor Kuznetsov 2018-10-27 01:38:38 UTC
Created attachment 787460 [details]
iwconfig from fujitsu lifebook s7710
Comment 5 Igor Kuznetsov 2018-10-27 01:39:12 UTC
Created attachment 787461 [details]
journalctl -f from fujitsu lifebook s7110
Comment 6 Igor Kuznetsov 2018-10-27 01:39:52 UTC
Created attachment 787462 [details]
hwinfo from toshiba tecra z40b
Comment 7 Igor Kuznetsov 2018-10-27 01:40:23 UTC
Created attachment 787463 [details]
iwconfig  from toshiba tecra z40b
Comment 8 Igor Kuznetsov 2018-10-27 01:40:50 UTC
Created attachment 787464 [details]
journalctl -f  from toshiba tecra z40b
Comment 9 Igor Kuznetsov 2018-10-27 01:42:23 UTC
toshiba now rebooted and work fine. Fujitsu i go sleep without reboot. So it is still can't connect to wi-fi networks.
Comment 10 Igor Kuznetsov 2018-10-27 01:44:22 UTC
i forgot. On both laptops is tumbleweed with fresh updates with zypper dup (two or free days ago)
Comment 12 Jonathan Kang 2018-10-31 06:35:12 UTC
Please add the following to /etc/NetworkManager/NetworkManager.conf and attach
related log back

> [logging]
> level=trace
Comment 13 Igor Kuznetsov 2018-11-01 17:18:46 UTC
Created attachment 788172 [details]
networkmanager log while it happen again
Comment 14 Jonathan Kang 2018-11-09 02:13:24 UTC
(In reply to Igor Kuznetsov from comment #13)
> Created attachment 788172 [details]
> networkmanager log while it happen again

From the log, the only hint I can find is
> NetworkManager[30840]: <warn>  [1541091826.9778] device (wlp2s0): No agents were available for this request

It means no secret agent is registered to provide password for Wi-Fi connections.
Can you attach a new log with all system logs?
Comment 15 Igor Kuznetsov 2018-11-09 17:00:40 UTC
Created attachment 789261 [details]
journalctl -l -a -S today

attaching journalctl for today. This problem was at 18:21

ноя 09 18:21:21 lnxvrx NetworkManager[5701]: <info>  [1541773281.1629] device (wlp2s0): state change: need-auth -> failed (reason 'no-secrets', sys-iface-state: 'managed')
ноя 09 18:21:21 lnxvrx NetworkManager[5701]: <info>  [1541773281.1642] manager: NetworkManager state is now DISCONNECTED
ноя 09 18:21:21 lnxvrx NetworkManager[5701]: <warn>  [1541773281.1658] device (wlp2s0): Activation: failed for connection 'virex8297'
ноя 09 18:21:21 lnxvrx NetworkManager[5701]: <info>  [1541773281.1665] device (wlp2s0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
ноя 09 18:21:21 lnxvrx kernel: IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
ноя 09 18:21:21 lnxvrx dhclient[5385]: receive_packet failed on wlp2s0: Network is down
ноя 09 18:21:21 lnxvrx NetworkManager[5701]: <info>  [1541773281.1890] device (wlp2s0): set-hw-addr: set MAC address to C2:F9:7D:1D:92:D1 (scanning)
ноя 09 18:21:21 lnxvrx kernel: IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
ноя 09 18:21:21 lnxvrx NetworkManager[5701]: <info>  [1541773281.2077] device (wlp2s0): supplicant interface state: scanning -> disabled
ноя 09 18:21:21 lnxvrx NetworkManager[5701]: <info>  [1541773281.2128] device (wlp2s0): supplicant interface state: disabled -> scanning
ноя 09 18:21:24 lnxvrx NetworkManager[5701]: <info>  [1541773284.4745] device (wlp2s0): supplicant interface state: scanning -> disconnected
ноя 09 18:21:25 lnxvrx plasmashell[2389]: qml: temp unit: 0
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <info>  [1541773287.0338] device (wlp2s0): Activation: starting connection 'virex5a' (9aa77c96-710d-44b8-88db-88ecf173710b)
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <info>  [1541773287.0340] audit: op="connection-activate" uuid="9aa77c96-710d-44b8-88db-88ecf173710b" name="virex5a" pid=2389 uid=1000 result="success"
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <info>  [1541773287.0344] device (wlp2s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <info>  [1541773287.0366] manager: NetworkManager state is now CONNECTING
ноя 09 18:21:27 lnxvrx dhclient[5385]: receive_packet failed on wlp2s0: Network is down
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <info>  [1541773287.0413] device (wlp2s0): set-hw-addr: reset MAC address to E4:F8:9C:52:F8:46 (preserve)
ноя 09 18:21:27 lnxvrx kernel: IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <info>  [1541773287.0476] device (wlp2s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <info>  [1541773287.0493] device (wlp2s0): Activation: (wifi) access point 'virex5a' has security, but secrets are required.
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <info>  [1541773287.0493] device (wlp2s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <warn>  [1541773287.0519] device (wlp2s0): No agents were available for this request.
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <info>  [1541773287.0520] device (wlp2s0): state change: need-auth -> failed (reason 'no-secrets', sys-iface-state: 'managed')
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <info>  [1541773287.0532] manager: NetworkManager state is now DISCONNECTED
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <warn>  [1541773287.0544] device (wlp2s0): Activation: failed for connection 'virex5a'
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <info>  [1541773287.0594] device (wlp2s0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
ноя 09 18:21:27 lnxvrx kernel: IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
ноя 09 18:21:27 lnxvrx dhclient[5385]: receive_packet failed on wlp2s0: Network is down
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <info>  [1541773287.0643] device (wlp2s0): set-hw-addr: set MAC address to E6:10:BF:CF:08:3E (scanning)
ноя 09 18:21:27 lnxvrx kernel: IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <info>  [1541773287.0715] device (wlp2s0): supplicant interface state: disconnected -> disabled
ноя 09 18:21:27 lnxvrx NetworkManager[5701]: <info>  [1541773287.0930] device (wlp2s0): supplicant interface state: disabled -> scanning
ноя 09 18:21:28 lnxvrx plasmashell[2389]: qml: temp unit: 0
ноя 09 18:21:30 lnxvrx NetworkManager[5701]: <info>  [1541773290.3616] device (wlp2s0): supplicant interface state: scanning -> disconnected
Comment 16 Igor Kuznetsov 2018-11-11 16:07:38 UTC
I think the problem is in kde wallet.
Comment 17 Jonathan Kang 2018-11-12 02:14:02 UTC
(In reply to Igor Kuznetsov from comment #15)
> Created attachment 789261 [details]
> journalctl -l -a -S today
> 
Looks like kwallet didn't even start, so there is no secret agent providing
the password needed for this connection.
Comment 18 Igor Kuznetsov 2019-03-25 04:41:42 UTC
After several updates all work fine