Bug 1106841 - AArch32 KVM guests break on Hi1616 with 4.18
AArch32 KVM guests break on Hi1616 with 4.18
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: KVM
Current
aarch64 openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Alexander Graf
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-02 07:17 UTC by Alexander Graf
Modified: 2018-09-02 09:25 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Graf 2018-09-02 07:17:09 UTC
When updating to 4.18, our Hi1616 build workers stopped to be able to build AArch32 build jobs properly. Upstream managed to trim it down to a side effect of new FPU switching code in core arm64 code and KVM FPU switching:

  https://www.spinics.net/lists/kvm-arm/msg32520.html

Until the patch trickles in through -stable, we should carry it in our tree to ensure that build jobs keep running properly.
Comment 1 Alexander Graf 2018-09-02 07:19:13 UTC
Pull request sent to git.