Bug 1106834 - Snappy cannot perform readlinkat() on the mount namespace
Snappy cannot perform readlinkat() on the mount namespace
Status: RESOLVED FIXED
: 1100660 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Zygmunt Krynicki
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-01 15:43 UTC by Nathan Wolf
Modified: 2018-11-06 21:44 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan Wolf 2018-09-01 15:43:10 UTC
When attempting to run any snap packages, I am getting this error:

cannot perform readlinkat() on the mount namespace file descriptor of the init process: Permission denied

I did find this on the launchpad site:
https://bugs.launchpad.net/snappy/+bug/1709155

Where this was the solution:
Now you can just `sudo snap refresh core --beta` for the 4.18 problem 

But this didn't solve the problem on openSUSE Tumbleweed 20180829.
Comment 1 Nathan Wolf 2018-09-25 14:27:27 UTC
Disabling AppArmor does not seem to change the outcome. All snap applications I have tested will still output the same error.

cannot perform readlinkat() on the mount namespace file descriptor of the init process: Permission denied
Comment 2 Marcus Rückert 2018-10-17 11:47:59 UTC
I am pretty sure this is not about the snappy library but snap the package format
Comment 4 Zygmunt Krynicki 2018-10-18 07:17:33 UTC
I will update the package tomorrow, it should fix this issue as it doesn't happen in out internal CI.
Comment 5 Nathan Wolf 2018-10-27 20:33:05 UTC
From my machine, it doesn't seem to have been fixed yet. Is there a way to to dig into the error to find the point of failure?
Comment 6 Traace Barbek 2018-11-04 13:33:31 UTC
Issue still exist, as least in community packages.

OS: openSUSE Tumbleweed 20181029
Kernel: 4.18.15-1 x86_x64
snap: 2.34.3-5.8
installed from repo: home:fusion809 [community] | system:snappy (NOT TESTED)
snap-core: rev.5861 v.16-2.36+git [edge]

AppArmor permissions should be correct.
Comment 7 Zygmunt Krynicki 2018-11-05 17:21:38 UTC
The fixed package is under review. I expect to release it across openSUSE family tomorrow.
Comment 8 Nathan Wolf 2018-11-06 16:02:50 UTC
The current error I receive with running snaps:

2018/11/06 11:02:23.011745 system_key.go:121: cannot determine nfs usage in generateSystemKey: cannot parse /proc/self/mountinfo: open /proc/self/mountinfo: permission denied
internal error, please report: running "hello-world" failed: open /snap/hello-world/27/meta/snap.yaml: permission denied

The same error exists when running it as root.
Comment 9 Zygmunt Krynicki 2018-11-06 21:42:22 UTC
I have just released 2.36 for all supported openSUSE releases. Please try it out but I believe this his fixed based on my testing.
Comment 10 Zygmunt Krynicki 2018-11-06 21:44:35 UTC
*** Bug 1100660 has been marked as a duplicate of this bug. ***