Bug 1106705 - NetworkManager requires CA private key for OpenVPN connection
NetworkManager requires CA private key for OpenVPN connection
Status: RESOLVED FIXED
: 1106584 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Network
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Jonathan Kang
E-mail List
https://gitlab.gnome.org/GNOME/networ...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-31 06:39 UTC by Stefan Weiberg
Modified: 2018-11-16 23:21 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
Screenshot NetworkManager OpenVPN setup (44.58 KB, image/png)
2018-08-31 06:46 UTC, Stefan Weiberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Weiberg 2018-08-31 06:39:48 UTC
Newer versions of the NetworkManager require the CA private key to connect to the OpenVPN network. Without CA private key the settings can't be saved. I am pretty sure that most OpenVPN providers don't share their private key for their CA and this basically blocks setting up an OpenVPN connection.

The same bug was reported for Arch Linux a few weeks ago:
https://bugs.archlinux.org/task/59677

Their solution was to downgrade the nm-connection-editor to an earlier version that didn't require the CA private key.

Information for package NetworkManager-openvpn:
-----------------------------------------------
Repository     : openSUSE:Tumbleweed                   
Name           : NetworkManager-openvpn                
Version        : 1.8.4-1.2                             
Arch           : x86_64                                
Vendor         : openSUSE                              
Installed Size : 155.9 KiB                             
Installed      : Yes                                   
Status         : up-to-date                            
Source package : NetworkManager-openvpn-1.8.4-1.2.src  
Summary        : NetworkManager VPN support for OpenVPN

Information for package NetworkManager:
---------------------------------------
Repository     : openSUSE:Tumbleweed                       
Name           : NetworkManager                            
Version        : 1.12.2-1.2                                
Arch           : x86_64                                    
Vendor         : openSUSE                                  
Installed Size : 5.2 MiB                                   
Installed      : Yes                                       
Status         : up-to-date                                
Source package : NetworkManager-1.12.2-1.2.src             
Summary        : Network Link Manager and User Applications
Comment 1 Stefan Weiberg 2018-08-31 06:43:27 UTC
This applies to the authentication methods password, password with certificates (TLS) and Certificates (TLS).
Comment 2 Stefan Weiberg 2018-08-31 06:46:30 UTC
Created attachment 781432 [details]
Screenshot NetworkManager OpenVPN setup
Comment 3 Stefan Weiberg 2018-08-31 06:50:46 UTC
Upstream bug in the NetworkManager project:
https://gitlab.gnome.org/GNOME/network-manager-applet/issues/20
Comment 4 Jonathan Kang 2018-11-12 06:13:26 UTC
Fix[1] will be available soon in Tumbleweed.

*[1] https://build.opensuse.org/request/show/647254
Comment 5 Jonathan Kang 2018-11-16 05:39:12 UTC
RESOLVED FIXED.
Comment 6 Scott Reeves 2018-11-16 23:21:59 UTC
*** Bug 1106584 has been marked as a duplicate of this bug. ***