Bug 1106693 - python2-pyliblzma does not conflict with python-pyliblzma
python2-pyliblzma does not conflict with python-pyliblzma
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other openSUSE Factory
: P5 - None : Normal (vote)
: ---
Assigned To: Martin Pluskal
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-31 04:17 UTC by Bernhard Wiedemann
Modified: 2018-08-31 13:35 UTC (History)
1 user (show)

See Also:
Found By: Development
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Wiedemann 2018-08-31 04:17:40 UTC
When doing zypper dup on a tumbleweed-20180723 system, it reported this error:
File /usr/lib64/python2.7/site-packages/lzma.so
  from install of
     python2-pyliblzma-0.5.3-4.2.x86_64 (repo-oss)
  conflicts with file from package
     python-pyliblzma-0.5.3-13.34.x86_64 (@System)


And indeed:
> rpm -qp --obsoletes /var/cache/zypp/packages/repo-oss/x86_64/python2-pyliblzma-0.5.3-4.2.x86_64.rpm
python-pyliblzma < 0.5.3-4.2
python2-pyliblzma-doc
> rpm -qp --conflicts /var/cache/zypp/packages/repo-oss/x86_64/python2-pyliblzma-0.5.3-4.2.x86_64.rpm

Why don't our single-spec macros add the Obsoletes automatically?
Comment 1 Bernhard Wiedemann 2018-08-31 04:24:53 UTC
Err: macros should add the Conflicts automatically

In my case the old package was from
devel:languages:python / openSUSE_Tumbleweed
but I think, official packages would have had the same trouble
because of the rename.
Comment 3 Bernhard Wiedemann 2018-08-31 13:35:05 UTC
So an Obsolete indeed includes a Conflict, but here, the version numbers were inverted, because it switched from the dlp to repo-oss version
and thus no package conflict was considered.

The 'no-vendor-change' did not apply,
because python2-pyliblzma was a new package.