Bug 1106319 - Exception when starting firewall tool from YaST2 GUI
Exception when starting firewall tool from YaST2 GUI
Status: RESOLVED FIXED
: 1107793 1108129 1113175 1113630 1113675 1115164 (view as bug list)
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: YaST2
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Markos Chandras
Jiri Srain
https://github.com/firewalld/firewall...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-28 22:23 UTC by Henk Kaas
Modified: 2019-03-27 08:20 UTC (History)
9 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
stacktrace (1.26 KB, text/plain)
2018-08-28 22:23 UTC, Henk Kaas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Henk Kaas 2018-08-28 22:23:50 UTC
Created attachment 781076 [details]
stacktrace

Wanted to use the firewall config GUI for the first time today, so yast installed it. When trying to run it I get this error message (see attachment), possible related to this forumpost: https://forums.opensuse.org/showthread.php/532842-firewall-config-not-running?p=2878654#post2878654
Comment 1 Josef Reidinger 2018-08-29 07:52:02 UTC
firewall-config failing, so lets reassign to its maintainer.
Comment 2 Markos Chandras 2018-08-29 08:10:31 UTC
Yeah this has been fixed upstream

https://github.com/firewalld/firewalld/issues/370

I will ask upstream if they plan to release a new version soon otherwise I will backport it to 0.6.1
Comment 3 Sebastian Wagner 2018-09-01 14:21:30 UTC
I can confirm that applying this patch fixes the problem:

https://github.com/firewalld/firewalld/pull/373
Comment 4 Swamp Workflow Management 2018-09-06 11:50:06 UTC
This is an autogenerated message for OBS integration:
This bug (1106319) was mentioned in
https://build.opensuse.org/request/show/633723 Factory / firewalld
Comment 5 Markos Chandras 2018-09-06 14:49:38 UTC
Fixed submitted to Factory and it should be available in the upcoming snapshots.
Comment 6 Markos Chandras 2018-09-10 09:38:10 UTC
*** Bug 1107793 has been marked as a duplicate of this bug. ***
Comment 7 Arvin Schnell 2018-09-12 08:05:13 UTC
*** Bug 1108129 has been marked as a duplicate of this bug. ***
Comment 8 Swamp Workflow Management 2018-09-24 10:10:28 UTC
This is an autogenerated message for OBS integration:
This bug (1106319) was mentioned in
https://build.opensuse.org/request/show/637406 Factory / firewalld
Comment 9 Markos Chandras 2018-10-25 09:53:23 UTC
*** Bug 1113175 has been marked as a duplicate of this bug. ***
Comment 12 Markos Chandras 2018-10-29 10:47:13 UTC
*** Bug 1113675 has been marked as a duplicate of this bug. ***
Comment 13 Martin Vidner 2018-10-29 12:16:40 UTC
*** Bug 1113630 has been marked as a duplicate of this bug. ***
Comment 16 Yifan Jiang 2018-11-08 09:23:24 UTC
*** Bug 1115164 has been marked as a duplicate of this bug. ***
Comment 17 Swamp Workflow Management 2018-11-13 23:15:16 UTC
SUSE-RU-2018:3762-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1106319
CVE References: 
Sources used:
SUSE Linux Enterprise Module for Desktop Applications 15 (src):    firewalld-0.5.5-4.18.1
SUSE Linux Enterprise Module for Basesystem 15 (src):    firewalld-0.5.5-4.18.1
Comment 18 Swamp Workflow Management 2018-11-16 20:23:04 UTC
openSUSE-RU-2018:3794-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1106319
CVE References: 
Sources used:
openSUSE Leap 15.0 (src):    firewalld-0.5.5-lp150.2.15.1