Bug 1106104 - OBS (Open Broadcaster) Studio does not open
OBS (Open Broadcaster) Studio does not open
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Alessandro de Oliveira Faria
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-27 13:38 UTC by Rob Holt
Modified: 2018-12-26 17:25 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rob Holt 2018-08-27 13:38:09 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.84 Safari/537.36
Build Identifier: 

Both the official version in the repo and the Flatpak refuse to run.
The official RPM does nothing at all when attempting to launch.
The Flatpak launches the licence agreement then a error message advising to check graphics drivers.

For reference, other screen recording software such as Simple screen Recorder work fine.

I run Nvidia drivers 390.77 from the Nvidia repo.

Desktop is KDE 5.13.4

Reproducible: Always

Steps to Reproduce:
1.Install OBS from the repo
2.Launch from menu
3.
Actual Results:  
Application will not launch

Expected Results:  
Application should launch

PC config:
Dell 7010 SFF
Intel core i7
Nvidia GT 1030
Comment 1 Víctor Sánchez 2018-08-30 19:00:53 UTC
I encountered this one 2 days ego too. Got this from journalctl

Aug 28 07:09:34 joder-pc systemd-coredump[20215]: Resource limits disable core dumping for process 20213 (obs).
Aug 28 07:09:34 joder-pc systemd-coredump[20215]: Process 20213 (obs) of user 2001 dumped core.
-- Subject: Process 20213 (obs) dumped core
-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: man:core(5)
-- 
-- Process 20213 (obs) crashed and dumped core.
-- 
-- This usually indicates a programming error in the crashing program and
-- should be reported to its vendor as a bug.


Today i tried the flatpak from flathub, it did work for me but i had to 1st launch it with "flatpak run" or the entry on the menu would not work otherwise.

I am on tumbleweed:20180820 KDE using NVidia's 396.54
Comment 2 Alessandro de Oliveira Faria 2018-10-17 03:38:59 UTC
Hi

Try this my repository

zypper addrepo https://download.opensuse.org/repositories/home:cabelo/openSUSE_Tumbleweed/home:cabelo.repo
zypper refresh
zypper install obs-studio
Comment 3 Víctor Sánchez 2018-10-24 00:02:57 UTC
(In reply to Alessandro de Oliveira Faria from comment #2)
> Hi
> 
> Try this my repository
> 
> zypper addrepo
> https://download.opensuse.org/repositories/home:cabelo/openSUSE_Tumbleweed/
> home:cabelo.repo
> zypper refresh
> zypper install obs-studio

Not working either. I am on the lastest Tumbleweed snapshot 20181018.
Comment 4 Alessandro de Oliveira Faria 2018-11-04 19:03:19 UTC
The installed codecs need to be from the packman repository.
Comment 5 Víctor Sánchez 2018-11-20 12:24:38 UTC
(In reply to Alessandro de Oliveira Faria from comment #4)
> The installed codecs need to be from the packman repository.

Well its working for me now. OBS + all other dependencies need to be installed from packman to avoid this.
Comment 6 Alessandro de Oliveira Faria 2018-12-26 17:25:26 UTC
The dependencies need to be installed from packman (non-free packages)