Bug 1106039 - Package libOpenCL1 should create symlink libOpenCL.so
Package libOpenCL1 should create symlink libOpenCL.so
Status: NEW
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Scott Reeves
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-27 08:16 UTC by Bug Reporter
Modified: 2018-11-26 13:08 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
mpluskal: needinfo? (bugreporter)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bug Reporter 2018-08-27 08:16:15 UTC
User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build Identifier: 

The package libOpenCL1 should also create the symlink /usr/lib{64}/libOpenCL.so (of /usr/lib{64}/libOpenCL.so.1.0.0) for better compatibility with OpenCL applications and when trying to compile OpenCL applications.
Otherwise, OpenCL support may erroneously not be found.

Reproducible: Always
Comment 1 Tiago Marques 2018-11-26 12:27:57 UTC
Had the same issue with this on Leap 15.0, until I placed a manual symlink. Please fix this.
Comment 2 Martin Pluskal 2018-11-26 13:08:29 UTC
libOpenCL.so is part of corresponding devel package, in full accordance with packaging guidelines - packages requiring this have to have their dependencies corrected - please specify which packages are affected.