Bug 1104695 - Cannot open console with virt-viewer after starting kvm-guest
Cannot open console with virt-viewer after starting kvm-guest
Status: RESOLVED DUPLICATE of bug 1104820
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Virtualization:Tools
Current
x86-64 Other
: P3 - Medium : Major (vote)
: ---
Assigned To: Larry Dewey
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-13 15:23 UTC by Philip Raets
Modified: 2018-08-14 18:28 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
guest xml file (6.22 KB, text/xml)
2018-08-14 14:39 UTC, Philip Raets
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Raets 2018-08-13 15:23:53 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build Identifier: 

If I start a KVM-guest in virt-manager and then open the console I get the following message:

Error connecting to graphical console:
internal error: failed to parse JSON 1:59: too big integer near '18446744073709551615'



Reproducible: Always

Steps to Reproduce:
1. start guest from virt-manager
2. open virt-viewer to get the console
3.
Actual Results:  
Error connecting to graphical console:
internal error: failed to parse JSON 1:59: too big integer near '18446744073709551615'

Expected Results:  
get a connection to graphical console
Comment 1 Mark Draheim 2018-08-13 17:43:12 UTC
I also had this error. It went away after I changed something in the VM's config. Cannot remember what it was, though. Maybe the config just needs to be rewritten after a change.
Comment 2 Philip Raets 2018-08-14 07:00:33 UTC
This also happens when the guests are started at boot time, after I log in, I can't open the console.

The only way to work in the guest is to destroy it, then open virt-viewer, and then start the guest.

I also can't clean shut down or reboot the guests. They are shutting down and then hang.

This would be unusable when used in server-environments.

Let me know if you need any log-files or certain command-outputs. I don't know how to debug this.
Comment 3 Philip Raets 2018-08-14 12:55:16 UTC
Seems to be this: https://bugzilla.redhat.com/show_bug.cgi?id=1614569
Comment 4 Liang Yan 2018-08-14 14:28:37 UTC
Should have a workaround? I could not reproduce from my tw environment which I just updated to latest.

Could you provide your vm xml file, along with output for "virt-manager --debug" and "virt-viewer --debug" for a quick look? Thanks.
Comment 5 Bruce Rogers 2018-08-14 14:33:48 UTC
CCing Jim as the the issue seems to be a libvirt one.
Comment 6 Philip Raets 2018-08-14 14:39:37 UTC
Created attachment 779705 [details]
guest xml file
Comment 7 Liang Yan 2018-08-14 18:28:56 UTC
Looks a duplication of https://bugzilla.opensuse.org/show_bug.cgi?id=1104820, feel free to reopen it if it is not case.

*** This bug has been marked as a duplicate of bug 1104820 ***