Bug 1104594 - VoIP programs fail to connect to a SIP account.
VoIP programs fail to connect to a SIP account.
Status: NEW
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Frederic Crozat
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-12 10:29 UTC by Marek Paśnikowski
Modified: 2021-02-06 18:35 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
ekiga -d 2 > ekiga.log 2>&1 (10.66 KB, text/x-log)
2018-08-14 10:18 UTC, Marek Paśnikowski
Details
Ekiga output file from terminal dump (ekiga -d 4) (84.43 KB, text/plain)
2021-01-24 21:24 UTC, Klaus-Dieter Fietze
Details
WhireShark Output file taken at the same time as attachment 845460 (134.32 KB, application/x-pcapng)
2021-01-25 08:13 UTC, Klaus-Dieter Fietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Paśnikowski 2018-08-12 10:29:16 UTC
I have a SIP account registered with SipGate. Both Ekiga and Ring fail to connect to that account. I did not have this problem when I used SUSE Linux Enterprise Desktop on the same computer.
Comment 1 Tomáš Chvátal 2018-08-14 08:38:25 UTC
Without any logs or additional information this bug is virtually unfixable.
Comment 2 Marek Paśnikowski 2018-08-14 10:18:09 UTC
Created attachment 779676 [details]
ekiga -d 2 > ekiga.log 2>&1

1. Program launched.
2. Opened accounts.
3. Disable and enable the account.
4. Waited for "could not connect" error.
5. Closed the program.
Comment 3 Marek Paśnikowski 2018-08-14 10:18:35 UTC
Silly me. It seems I am not good at bug reporting yet. I apologise for that.

For now I attach a log from launching "ekiga -d 2". Ring kept crashing when I tried to connect to the SIP account, so I had deleted the configuration. Let me know if you are interested it's log as well. Tell me which other logs would be valuable as well.
Comment 4 Tomáš Chvátal 2018-08-17 08:35:16 UTC
Yea the crash log might help.

The content of this log just says the app tried to connect to the server yet it never got any response from it.
Comment 5 Marek Paśnikowski 2018-08-17 09:06:58 UTC
I realised something just now.

Is Ekiga trying to connect using UDP or TCP? A minute ago I had configured a VoIP app (Linphone) on my mobile phone to see if I could find out anything new. It presents a choice of transports between UDP, TCP and TLS. Out of those three only UDP connects instantly. The other two time out.
Comment 6 Marek Paśnikowski 2018-08-18 08:40:41 UTC
Following the mobile phone test I decided to try Linphone on my computer. Sure enough, I was able to make connections both ways. It appears that the issue is that Ring and Ekiga don't connect on UDP, while my SIP provider accepts only UDP connections.
Comment 7 Tomáš Chvátal 2018-08-21 09:50:03 UTC
2018/08/14 12:02:48.530	  0:19.153	Opal Liste...a269596700	SIP	Invalid version (0) received on udp$217.10.79.23:5060<if=udp$*:5060>

It should be sending udp data. Maybe the opal maintainers will know as it is the app that is handling the communication for both ekiga and ring.
Comment 8 Dieter Wörz 2020-06-10 22:21:40 UTC
Same with linphone-4.1.1-8.6.x86_64
According to debian bugzilla libbellesip0 ssems to be the problem. There seems to be a new version of libbellesip0, which did not make it into the official repositories.
Repeat by:
 Start linphone
 Create a new account, e.g. for telekom.de
 Add password
 Press OK
linphone crashes
Comment 9 Klaus-Dieter Fietze 2021-01-24 21:24:02 UTC
Created attachment 845460 [details]
Ekiga output file from terminal dump (ekiga -d 4)

Dear Maintainer,
I have been using Ekiga since 2016, starting with openSUSE 13.2. The Ekiga release was always the same on all openSUSE installations, namely 4.0.1. Until last autumn I never had a problem with this program except some missing icons on the toolbar, where it turned out that I had to add the gnome-icon theme. Some weeks ago the trouble began when I moved from openSUSE Leap 15.2 to openSUSE Tumbleweed: After having installed Ekiga the program was not able to connect with my SIP provider Diamondcard.us. It displayed the error message: "Could not register. Remote party host is offline".
To check where the problem may come from I installed a Jami SIP client with the same credentials – it worked perfectly well.
Knowing that Jami works without STUN I installed gconf-editor and removed STUN from the Ekiga setup. Yet, Ekiga could not register either and produced the error message mentioned above.
To narrow down the problem I started Ekiga from a terminal in dump mode (ekiga -d 4). At the same time I recorded all activities of port 5060 with WhireShark. I am enclosing the dump output as well as the WhireShark output file (sorry too big 84 MB). I hope this will help to find out what goes wrong.
To countercheck I have removed the Ekiga version 4.1.0 that comes with Tumbleweed and have installed version 4.0.1 from the Leap 15.2 repository:
https://download.opensuse.org/distribution/leap/15.2/repo/oss/
To my big surprise, the newly installed version is indicated as 4.1.0, too, but it works fine with a standard setup using STUN!
Here is my configuration:

Operating System: openSUSE Tumbleweed 20210121
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.7-1-default
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-7700T CPU @ 2.90GHz
Memory: 7.6 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 630

Please note that I have made all my tests on one and the same machine using the same openSUSE Tumbleweed installation.
Let me know if I can be of further help or if you need additional information.
Thank you,
Klaus
Comment 10 Klaus-Dieter Fietze 2021-01-25 08:13:32 UTC
Created attachment 845467 [details]
WhireShark Output file taken at the same time as attachment 845460 [details]

I managed to remove a good deal of packets of the communication that are only repeats of previous ones. Now the file size fits to the limits.
Comment 11 Klaus-Dieter Fietze 2021-02-06 18:35:50 UTC
Frederic Crozat pushed a fix on one of the underlying libraries used by Ekiga. After installing the latest Tumbleweed update the bug disappeared. The program works fine again, except the calling window looks a bid weird, but it is suitable to call someone.
Remark: I am using the standard configuration with STUN.
Thanks to Frederic Crozat!