Bug 1103912 - Latest update removes pam_mount from gdm
Latest update removes pam_mount from gdm
Status: RESOLVED INVALID
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: GNOME
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: E-mail List
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-06 12:52 UTC by Philip Raets
Modified: 2018-08-06 13:26 UTC (History)
1 user (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
new gdm (345 bytes, text/plain)
2018-08-06 12:52 UTC, Philip Raets
Details
old gdm (350 bytes, text/plain)
2018-08-06 12:52 UTC, Philip Raets
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Raets 2018-08-06 12:52:25 UTC
Created attachment 778997 [details]
new gdm

I use pam_mount on login with gdm, and with the latest update it removed the entries from /etc/pam.d/gdm.

Luckily there is the gdm.rmpsave with the old configuration.

It's the same thing as happened in https://bugzilla.opensuse.org/show_bug.cgi?id=1076745
Comment 1 Philip Raets 2018-08-06 12:52:58 UTC
Created attachment 778998 [details]
old gdm
Comment 2 Dominique Leuenberger 2018-08-06 13:02:10 UTC
Worked as intended - it's config files - you either lose the distro config or the personal config and have to merge after modifications on either side. That's the reason for the .rpmsave to exist in first place (you should not just copy the .rpmsave back in place as this will undo the distro changes completely)

AS it works as intended, there is no bug
Comment 3 Philip Raets 2018-08-06 13:26:34 UTC
I haven't, I just copied the 2 lines back.

Is there a notification somewhere when this things happen? I've never added this manually to gdm, it is because of a winbind configuration in YaST.

But if this happens to more config files, is there a way to keep track of such changes?