Bug 1103906 - Refocus Kubic on new architecture design
Refocus Kubic on new architecture design
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Kubic
Current
Other Other
: P5 - None : Normal (vote)
: ---
Assigned To: Kubic Bugs
E-mail List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-06 12:20 UTC by Richard Brown
Modified: 2018-11-14 15:07 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Brown 2018-08-06 12:20:24 UTC
Kubic will be divesting itself from it's previous goal of synchronising with the SUSE CaaS Stack, and instead focusing on the investigation and integration of a new Kubic CaaS Stack (which may also become the future SUSE CaaS Stack)

This means the following for Kubic immediately

- the removal of current admin/worker/plain system roles
- focus on kubeadm as the default k8s bootstrapping tool (including a new system role)
- adaption & introduction of new openQA tests to fit this new architecture
- removal of Container RPMs from Factory & Kubic media

Future steps include
- replace kubeadm containers with opensuse based ones
- establishment of new Container release process to a registry

For more, see https://trello.com/b/wjHyQDK6/kubic-project

This new direction will be described to the community more verbosely in a pending blog post to kubic.opensuse.org, meanwhile this bug is to track any efforts and fallout of this major change.
Comment 1 Thorsten Kukuk 2018-08-14 13:03:45 UTC
*** Bug 1099700 has been marked as a duplicate of this bug. ***
Comment 2 Richard Brown 2018-11-14 15:07:26 UTC
- the removal of current admin/worker/plain system roles - DONE
- focus on kubeadm as the default k8s bootstrapping tool (including a new system role) - DONE
- adaption & introduction of new openQA tests to fit this new architecture  - DONE (though Multi-machine tests still WIP)
- removal of Container RPMs from Factory & Kubic media - DONE

There was no major fallout, users are able to use this new architecture, so this bug is being closed