Bug 1103904 - Update Minetest to 4.17.1 please
Update Minetest to 4.17.1 please
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Tumbleweed
Classification: openSUSE
Component: Other
Current
Other Other
: P5 - None : Normal (vote)
: Current
Assigned To: Ferdinand Thiessen
E-mail List
https://dev.minetest.net/Changelog#0....
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-08-06 12:07 UTC by Foss Fan
Modified: 2018-09-22 07:17 UTC (History)
7 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Foss Fan 2018-08-06 12:07:36 UTC
Hello,
on June 10, 2018 new Minetest version was released 0.4.17.1 to add features and fix crashes.

It's important feature-wise and Minetest is more stable with this. Also some mods require version 4.17.

From changelog:
 0.4.17 → 0.4.17.1

Patched 0.4.17 to fix a crash, released on June 10, 2018.

    Correct character encoding for chat_send_player and chat_send_all
    Fix crash caused by log_deprecated and the use of deprecated functions
    Fix crash on pause menu when pressing up/down keys
    Android build system fixes 

0.4.16 → 0.4.17

0.4.17 was released on June 3, 2018.
Features

    Builtin auth handler: Speed up file writing
    LBM lookup performance improvement on mapblock loading
    Minetest ASCII art: Move from actionstream to rawstream
    CollisionMoveSimple: Collide with 'ignore' nodes
    Allow objects to exist outside of 'mapgen limit' (mapblocks may exist)
    Find nodes in area (under air): Raise volume limit
    Allow dumping userdata using dump()
    Add minetest.is_player API function
    Refine movement anticheat (again)
    Apply physics overrides correctly during anticheat calculations
    Shut down mapgen threads before other shutdown tasks
    Show script source of deprecated function calls
    Inventory: Restrict access from too far away (anticheat)
    Improve Settings tab button alignments
    Add minetest.sha1 util API function
    Avoid filtering low-res textures for animated meshes
    Add setting for near plane distance to improve performance
    Footstep sounds: Reduce gain to balance volume
    Positional sound: Limit volume when closer than 1 node
    Leveled nodebox: Change levels from 1/63rds to 1/64ths
    ClientInterface: user limit checking function
    Make dropped items colorable
    Trigger on_rightclick regardless on the formspec meta field
    Clarify "Full viewing range" key message
    Rework new sneak code, minimize
    Tile material: Opaque textures by default to prevent xray effect
    Automatic item and node colorization
    find_nodes_in_area: Extend maximal count to U32_MAX
    Add server option to remove color codes from chat messages 

Bug fixes and Improvements

    Various build fixes (LuaJIT not found, OpenBSD)
    Dungeons: Mostly fix missing stair nodes
    Cavegen: Fix variable typo that broke mgvalleys large cave distribution
    Prevent translating empty strings
    upright_sprite: Fix texture position for players
    core.rotate_node: Do not trigger after_place_node for mod compatibility
    macOS: don't require X11 libraries during compilation
    Generate Notifier: Clear events once after all 'on generated' functions
    Fix liquid post effect colour behaviour in third person view
    Delete world dialog: Move buttons to avoid double click deletion
    Fix /shutdown countdown parameter
    Check argument types inside MetaDataRef Lua API
    Fix "Ignoring CONTENT_IGNORE redefinition" warning
    dropped items and falling nodes: Delete in 'ignore' nodes
    Move setlocale from Lua to C++
    Fix off-by-one in log output line length
    Fix buffer parameter not working in getMapSlice()
    Fix rounding error in g/set_node caused by truncation to float
    Fix dancing text in text input fields
    Fix undefined behaviour on getting pointer to data in empty vector
    Fix wrong scrolling in text areas
    Builtin: Fix handle_node_drops crash with nil digger
    Damage: Remove damage ignore timer due to abuse potential
    Ensure no item stack is being held before crafting
    Several documentation additions, improvements
    core.rotate_node: Run callbacks like with any regular placed node
    Biome dust node: Only place on 'walkable' cubic non-liquid drawtypes
    Make use of safe file writing in auth handler
    Add minetest.safe_write_file() API function
    Fix issue Minetest crash when custom font path is not exist
    Fix Settings tab formspec alignment
    Do not scale texture unless necessary
    httpfetch: Enable gzip support
    Fix day_night_ratio_do_override not being initialised server-side
    Fix default item callbacks to work with nil users
    Prevent from crafting non-existent, unknown items
    Profiler: Fix var args not being passed to callback register function
    Unkown nodes: Provide position on interact
    Fix attached particle spawners far from spawn
    Localplayer: Fix disable_jump effect and standing node position
    Fix blocks written by vmanip not being marked as modified
    Set placer to nil instead of a non-functional one in item_OnPlace
    Fix Rotate Node Placement
    ServerEnv: Clean up object lifecycle handling (item deletion)
    Fix the core.wrap_text function
    Fix empty legacy meta being persisted
    Statbars: fix incorrect half-images in non-standard orientations
    Android stepheight: Only increase if 'touching ground'
    Fix Android node selection distance
    serialize: use a temporary for SerializeException
    Fix player coordinate rounding in collisionMoveSimple()
    Various crash and error fixes
    Fix for empty key/value when reading item string with wear but no metadata
    Fix render order of overlays
    Fix console resize issue when maximising game window
    Fix console not being properly resized after window size changed
    Verify HudSetParams input when hotbar textures are set
    (Re)spawn players within 'mapgen_limit'
    Fix sending color codes to clients that don't support them 

Please, update the packages in the repositories
Thank you in advance!
Comment 1 Andreas Stieger 2018-08-06 18:50:04 UTC
(In reply to Foss Fan from comment #0)
> on June 10, 2018 new Minetest version was released 0.4.17.1 to add features
> and fix crashes.

Assigning to maintainers.
Comment 2 Ferdinand Thiessen 2018-08-08 14:52:38 UTC
See request for factory: https://build.opensuse.org/request/show/628133
Comment 3 Swamp Workflow Management 2018-08-09 00:30:05 UTC
This is an autogenerated message for OBS integration:
This bug (1103904) was mentioned in
https://build.opensuse.org/request/show/628292 15.0+42.3 / minetest
https://build.opensuse.org/request/show/628293 15.0+42.3 / minetest-game
Comment 4 Swamp Workflow Management 2018-08-16 13:10:13 UTC
This is an autogenerated message for OBS integration:
This bug (1103904) was mentioned in
https://build.opensuse.org/request/show/629575 Backports:SLE-15 / minetest-game_Update
Comment 5 Andreas Stieger 2018-08-26 17:48:45 UTC
done
Comment 6 Swamp Workflow Management 2018-08-26 22:09:56 UTC
openSUSE-RU-2018:2526-1: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1103904
CVE References: 
Sources used:
openSUSE Leap 42.3 (src):    minetest-0.4.17.1-2.3.1, minetest-game-0.4.17-2.3.1
openSUSE Leap 15.0 (src):    minetest-0.4.17.1-lp150.5.3.1, minetest-game-0.4.17-lp150.3.3.1
Comment 7 Swamp Workflow Management 2018-09-22 07:17:03 UTC
openSUSE-RU-2018:2526-2: An update that has one recommended fix can now be installed.

Category: recommended (moderate)
Bug References: 1103904
CVE References: 
Sources used:
openSUSE Backports SLE-15 (src):    minetest-0.4.17.1-bp150.2.3.1, minetest-game-0.4.17-bp150.3.3.1