Bug 1102671 - libavcodec58/libavformat58 breaks Netflix/Firefox
libavcodec58/libavformat58 breaks Netflix/Firefox
Status: RESOLVED FIXED
: 1102793 (view as bug list)
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Upgrade Problems
Leap 42.3
x86-64 Other
: P5 - None : Normal (vote)
: ---
Assigned To: Tomáš Chvátal
Jiri Srain
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-07-26 04:08 UTC by Mike Galbraith
Modified: 2018-08-21 21:16 UTC (History)
10 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Galbraith 2018-07-26 04:08:29 UTC
Greetings,

Updating yesterday upgraded Chromium to 67.0.3396.99.lp150.2.3.3, which pulled in libavcodec58 and libavformat58 4.0.1-lp150.2.2, which in turn broke Netflix Player for Firefox, which then gripes "Whoops, something went wrong... (Netflix Player is unavailable etc etc) Error Code: F7355".

Removing these two packages downgraded Chromium to 66.0.3359.170-lp150.1.1, and restored Netflix/Firefox to their previous functional state.  Verified on desktop and laptop.
Comment 1 Andreas Stieger 2018-07-27 07:01:35 UTC
*** Bug 1102793 has been marked as a duplicate of this bug. ***
Comment 2 Dave Howorth 2018-07-27 10:34:57 UTC
Given how many people had said it was broken on the 'duplicate' bug, why does this bug still have status NEW?
Comment 3 Loki Drow 2018-07-27 12:48:28 UTC
Seems fixed now.
After update some files from packman repo:
libavutil56
libswresample3
libavformat58
libavcodec58
gstreamer-plugins-libav
libavdevice58
libavfilter7
libavresample4
libpostproc55
libswscale5
Comment 4 Tomáš Chvátal 2018-07-27 12:56:40 UTC
Yea we had to release update for ffmpeg to cover deps in packman. It is not technically bug in opensuse.
Comment 5 Gregg Moore 2018-08-09 17:18:55 UTC
Perhaps Resolved/Fixed is overstating it.

My Leap 42.3 system has the 27th July updates but video playback in Firefox was still broken.  I removed the *58 files which forced the downgrade of Chromium and video playback in Firefox works again.  I have locked Chromium in Yast to prevent the update being reinstalled, so would like to know when I can unlock it.
Comment 6 Wolfgang Bauer 2018-08-09 18:15:15 UTC
(In reply to Gregg Moore from comment #5)
> Perhaps Resolved/Fixed is overstating it.

It is fixed.

Packman meanwhile does provide ffmpeg-4 as well.

Just make sure that your libavformat58 (and so on) packages do come from Packman.
In short, run "zypper dup --from Packman" or similar and all should be well.

If you still have problems, better ask in a user support forum, like https://forums.opensuse.org/ e.g.
Comment 7 Wolfgang Bauer 2018-08-09 18:29:04 UTC
(In reply to Wolfgang Bauer from comment #6)
> Packman meanwhile does provide ffmpeg-4 as well.

Ok, not for Leap 42.3 though, it seems.

ffmpeg-4 is unresolvable in Packman:
https://pmbs.links2linux.de/package/show/Essentials/A_42.3-ffmpeg-4
Comment 8 Dave Howorth 2018-08-09 19:41:55 UTC
Is changing the version from Leap 15.0 to Leap 42.3 a helpful thing to do?

Surely the correct thing is to clone the bug, change the version and open it as new?
Comment 9 Wolfgang Bauer 2018-08-09 20:15:46 UTC
(In reply to Dave Howorth from comment #8)
> Is changing the version from Leap 15.0 to Leap 42.3 a helpful thing to do?

Maybe, maybe not.
I just reopened it.

And the responsible people are subscribed.

> Surely the correct thing is to clone the bug, change the version and open it
> as new?

Your comment is not really helpful either though... :-/
Feel free to do what you suggest though.
Comment 10 Wolfgang Bauer 2018-08-21 21:16:22 UTC
(In reply to Wolfgang Bauer from comment #7)
> (In reply to Wolfgang Bauer from comment #6)
> > Packman meanwhile does provide ffmpeg-4 as well.
> 
> Ok, not for Leap 42.3 though, it seems.
> 
> ffmpeg-4 is unresolvable in Packman:
> https://pmbs.links2linux.de/package/show/Essentials/A_42.3-ffmpeg-4

Fixed meanwhile (by a forced rebuild), a full-featured ffmpeg-4 (libavcodec58, libavformat58, ...) is now available on Packman for Leap 42.3 as well.